aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--lang/gcc47/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/lang/gcc47/Makefile b/lang/gcc47/Makefile
index 07d8daa19807..4eb391fa2fae 100644
--- a/lang/gcc47/Makefile
+++ b/lang/gcc47/Makefile
@@ -1,14 +1,14 @@
# Created by: Gerald Pfeifer <gerald@FreeBSD.org>
# $FreeBSD$
-PORTNAME= gcc47
+PORTNAME= gcc
PORTVERSION= 4.7.4
PORTREVISION= 2
PORTEPOCH= 1
CATEGORIES= lang java
MASTER_SITES= ${MASTER_SITE_GCC}
MASTER_SITE_SUBDIR= releases/gcc-${DISTVERSION}
-DISTNAME= gcc-${DISTVERSION}
+PKGNAMESUFFIX= ${SUFFIX}
MAINTAINER= gerald@FreeBSD.org
COMMENT= GNU Compiler Collection 4.7
@@ -27,6 +27,7 @@ BUILD_DEPENDS+= runtest:${PORTSDIR}/misc/dejagnu
.endif
CONFLICTS= gcc-4.7.*
+CPE_VENDOR= gnu
# DISTVERSION relates to downloads, GCC_VERSION and SUFFIX to names
# of executables and directories once installed.
@@ -34,7 +35,7 @@ DISTVERSION= ${PORTVERSION}
GCC_VERSION= ${PORTVERSION:C/(.+)\.[0-9]{8}/\1/}
SUFFIX= ${PORTVERSION:C/([0-9]+).([0-9]+).*/\1\2/}
ONLY_FOR_ARCHS= amd64 i386 powerpc powerpc64 sparc64
-USES= gmake iconv libtool makeinfo perl5 tar:bzip2
+USES= cpe gmake iconv libtool makeinfo perl5 tar:bzip2
USE_BINUTILS= yes
USE_PERL5= build
SSP_UNSAFE= yes