aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/go-btree/Makefile23
-rw-r--r--devel/go-btree/distinfo2
-rw-r--r--devel/go-btree/pkg-descr4
-rw-r--r--devel/go-btree/pkg-plist6
5 files changed, 36 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index af903ba0c71d..2f566fa2423d 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -714,6 +714,7 @@
SUBDIR += gnustep
SUBDIR += gnustep-make
SUBDIR += go-bindata
+ SUBDIR += go-btree
SUBDIR += go-flags
SUBDIR += go-hashicorp-logutils
SUBDIR += go-json-rest
diff --git a/devel/go-btree/Makefile b/devel/go-btree/Makefile
new file mode 100644
index 000000000000..21ec47ed1ab2
--- /dev/null
+++ b/devel/go-btree/Makefile
@@ -0,0 +1,23 @@
+# Created by: Akinori MUSHA aka knu <knu@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= btree
+PORTVERSION= 0.0.0.20150414
+CATEGORIES= devel
+PKGNAMEPREFIX= go-
+
+MAINTAINER= knu@FreeBSD.org
+COMMENT= BTree implementation for Go
+
+LICENSE= APACHE20
+
+USE_GITHUB= yes
+GH_ACCOUNT= google
+GH_PROJECT= ${PORTNAME}
+GH_TAGNAME= cc6329d
+
+GO_PKGNAME= github.com/${GH_ACCOUNT}/${GH_PROJECT}
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/lang/go/files/bsd.go.mk"
+.include <bsd.port.post.mk>
diff --git a/devel/go-btree/distinfo b/devel/go-btree/distinfo
new file mode 100644
index 000000000000..8833d97e560b
--- /dev/null
+++ b/devel/go-btree/distinfo
@@ -0,0 +1,2 @@
+SHA256 (google-btree-0.0.0.20150414-cc6329d_GH0.tar.gz) = 0e99ef9aa857291b90d8371272665d8fffe382a3c991dd41853beab9a04e8fdf
+SIZE (google-btree-0.0.0.20150414-cc6329d_GH0.tar.gz) = 11293
diff --git a/devel/go-btree/pkg-descr b/devel/go-btree/pkg-descr
new file mode 100644
index 000000000000..d257737765d3
--- /dev/null
+++ b/devel/go-btree/pkg-descr
@@ -0,0 +1,4 @@
+This package provides an in-memory B-Tree implementation for Go,
+useful as a an ordered, mutable data structure.
+
+WWW: https://github.com/google/btree
diff --git a/devel/go-btree/pkg-plist b/devel/go-btree/pkg-plist
new file mode 100644
index 000000000000..11d9dc8144c3
--- /dev/null
+++ b/devel/go-btree/pkg-plist
@@ -0,0 +1,6 @@
+%%GO_LIBDIR%%/github.com/google/btree.a
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/LICENSE
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/README.md
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/btree.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/btree_mem.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/btree_test.go