aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/php5-ice/Makefile69
-rw-r--r--devel/php5-ice/distinfo3
-rw-r--r--devel/php5-ice/files/patch-config+Make.rules50
-rw-r--r--devel/php5-ice/pkg-descr11
-rw-r--r--devel/php5-ice/pkg-plist4
6 files changed, 138 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 0d9fe8448fb2..6ca0feaca37f 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1815,6 +1815,7 @@
SUBDIR += php4-sysvshm
SUBDIR += php4-tokenizer
SUBDIR += php5-gettext
+ SUBDIR += php5-ice
SUBDIR += php5-ncurses
SUBDIR += php5-pcntl
SUBDIR += php5-pcre
diff --git a/devel/php5-ice/Makefile b/devel/php5-ice/Makefile
new file mode 100644
index 000000000000..bb70d402518f
--- /dev/null
+++ b/devel/php5-ice/Makefile
@@ -0,0 +1,69 @@
+# New ports collection makefile for: php-ice
+# Date created: 2007-08-21
+# Whom: DIrk Ye <dirk.ye@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Ice
+PORTVERSION= 3.2.1
+CATEGORIES= devel
+MASTER_SITES= http://www.zeroc.com/download/Ice/3.2/ \
+ http://www.dirk.sh/dirk/php/Ice/
+PKGNAMEPREFIX= php5-
+DISTNAME= IcePHP-${PORTVERSION}
+
+MAINTAINER= dirk.ye@gmail.com
+COMMENT= An Ice (Internet Communications Engine) language mapping for PHP
+
+LIB_DEPENDS= Ice.32:${PORTSDIR}/devel/ice
+
+USE_GMAKE= yes
+MAKE_ARGS+= PHP_EXT_DIR=${PHP_EXT_DIR}
+DEFAULT_PHP_VER=5
+IGNORE_WITH_PHP=4
+USE_PHP= yes
+USE_PHP_BUILD= yes
+
+LIB_VRS= ${PORTVERSION:S|.||g:C|0$||}
+PHP_MODNAME?= IcePHP
+
+CFLAGS+= -ftemplate-depth-128 -fPIC -DPIC -Wall -D_REENTRANT ${PTHREAD_CFLAGS}
+.if defined(DEBUG)
+CFLAGS+= -g
+.else
+CFLAGS+= -DNDEBUG
+.endif
+
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "ia64"
+BROKEN= does not compile
+.endif
+
+.if ((${ARCH} != i386) && (${ARCH} != powerpc))
+MAKE_ENV= LP64=yes
+.endif
+
+post-extract:
+ ${CP} ${WRKSRC}/config/Make.rules.Linux ${WRKSRC}/config/Make.rules.FreeBSD
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-pthread|${PTHREAD_LIBS}|' ${WRKSRC}/config/Make.rules.FreeBSD
+ ${REINPLACE_CMD} 's|%%INSTALL_PROGRAM%%|${INSTALL_PROGRAM}|g; \
+ s|%%INSTALL_DATA%%|${INSTALL_DATA}|g; \
+ s|%%PREFIX%%|${PREFIX}|g ; \
+ s|%%LOCALBASE%%|${LOCALBASE}|g' ${WRKSRC}/config/Make.rules
+post-install:
+ @${ECHO_CMD} extension=${PHP_MODNAME}.so \
+ >> ${PREFIX}/etc/php/extensions.ini
+ @${ECHO_CMD} "****************************************************************************"
+ @${ECHO_CMD} ""
+ @${ECHO_CMD} "The following line has been added to your ${PREFIX}/etc/php/extensions.ini"
+ @${ECHO_CMD} "configuration file to automatically load the installed extension:"
+ @${ECHO_CMD} ""
+ @${ECHO_CMD} "extension=${PHP_MODNAME}.so"
+ @${ECHO_CMD} ""
+ @${ECHO_CMD} "****************************************************************************"
+
+.include <bsd.port.post.mk>
diff --git a/devel/php5-ice/distinfo b/devel/php5-ice/distinfo
new file mode 100644
index 000000000000..acc9897abbd2
--- /dev/null
+++ b/devel/php5-ice/distinfo
@@ -0,0 +1,3 @@
+MD5 (IcePHP-3.2.1.tar.gz) = e32a8988dfae57775d9c71e7ace4c687
+SHA256 (IcePHP-3.2.1.tar.gz) = 6e1560ca2b344ff19f5a9c8f0b0777644b3dea60949b46a2fab202a71a891f8a
+SIZE (IcePHP-3.2.1.tar.gz) = 78072
diff --git a/devel/php5-ice/files/patch-config+Make.rules b/devel/php5-ice/files/patch-config+Make.rules
new file mode 100644
index 000000000000..a6fc981bb6e3
--- /dev/null
+++ b/devel/php5-ice/files/patch-config+Make.rules
@@ -0,0 +1,50 @@
+--- config/Make.rules.orig Wed Aug 22 16:32:59 2007
++++ config/Make.rules Wed Aug 22 21:34:34 2007
+@@ -7,6 +7,8 @@
+ #
+ # **********************************************************************
+
++ICE_HOME = %%LOCALBASE%%
++
+ ifndef ICE_HOME
+ ifneq ($(shell test -f /usr/include/Ice/Ice.h && echo 0),0)
+ $(error Ice installation not found, please set ICE_HOME!)
+@@ -18,7 +20,7 @@ endif
+ # if it does not exist.
+ #
+
+-prefix ?= /opt/IcePHP-$(VERSION)
++prefix ?= %%PREFIX%%/lib/php/$(PHP_EXT_DIR)
+
+ #
+ # The "root directory" for runpath embedded in executables. Can be unset
+@@ -31,7 +33,7 @@ embedded_runpath_prefix ?= /opt/Ice-$(V
+ # Otherwise the Ice extension is built with debug information.
+ #
+
+-#OPTIMIZE = yes
++OPTIMIZE = yes
+
+ #
+ # Define LP64 as yes if you want to build in 64 bit mode on a platform
+@@ -54,7 +56,7 @@ embedded_runpath_prefix ?= /opt/Ice-$(V
+ # PHP_INCLUDE_DIR and PHP_LIB_DIR.
+ #
+
+-PHP_HOME ?= /opt/php
++PHP_HOME ?= /usr/local
+
+ UNAME := $(shell uname)
+
+@@ -134,9 +136,9 @@ else
+ endif
+
+ ifeq ($(LP64),yes)
+- install_libdir = $(prefix)/lib$(lp64suffix)
++ install_libdir = $(prefix)$(lp64suffix)
+ else
+- install_libdir = $(prefix)/lib
++ install_libdir = $(prefix)
+ endif
+
+ ifneq ($(embedded_runpath_prefix),)
diff --git a/devel/php5-ice/pkg-descr b/devel/php5-ice/pkg-descr
new file mode 100644
index 000000000000..cf687e625c26
--- /dev/null
+++ b/devel/php5-ice/pkg-descr
@@ -0,0 +1,11 @@
+An Ice language mapping for PHP is a recent and welcome addition
+to the Ice product portfolio, enabling developers to take advantage
+of the productivity offered by PHP's friendly syntax and extensive
+function library.
+
+This Ice distribution is released under the GNU General Public License (GPL).
+
+WWW: http://www.zeroc.org/
+
+- DIrk Ye
+dirk.ye@gmail.com
diff --git a/devel/php5-ice/pkg-plist b/devel/php5-ice/pkg-plist
new file mode 100644
index 000000000000..60fbb33cc8ae
--- /dev/null
+++ b/devel/php5-ice/pkg-plist
@@ -0,0 +1,4 @@
+lib/php/%%PHP_EXT_DIR%%/ICE_LICENSE
+lib/php/%%PHP_EXT_DIR%%/IcePHP.so
+lib/php/%%PHP_EXT_DIR%%/LICENSE
+@dirrm lib/php/%%PHP_EXT_DIR%%/slice