aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--audio/clementine-player/Makefile11
-rw-r--r--audio/clementine-player/distinfo5
-rw-r--r--audio/clementine-player/files/patch-git_ded312634
-rw-r--r--audio/clementine-player/files/patch-src_internet_vk_vkconnection.h11
4 files changed, 10 insertions, 51 deletions
diff --git a/audio/clementine-player/Makefile b/audio/clementine-player/Makefile
index 9ed92cc4faeb..3b0a46c68f79 100644
--- a/audio/clementine-player/Makefile
+++ b/audio/clementine-player/Makefile
@@ -2,8 +2,9 @@
# $FreeBSD$
PORTNAME= clementine
-PORTVERSION= 1.3.1
-PORTREVISION= 21
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.3.1-441
+DISTVERSIONSUFFIX= -gc01b7bc
CATEGORIES= audio
PKGNAMESUFFIX= -player
@@ -36,7 +37,8 @@ USES= cmake \
pkgconfig \
sqlite
-USE_GL= glew
+USE_GL= gl glew glu
+USE_XORG= x11
CONFLICTS_BUILD= qt-3.*
USE_QT4= corelib \
@@ -170,7 +172,8 @@ GOOGLE_DRIVE_CMAKE_OFF= -DENABLE_GOOGLE_DRIVE=OFF
GPOD_LIB_DEPENDS= libgpod.so:audio/libgpod \
libplist.so:devel/libplist \
- libusbmuxd.so:comms/libusbmuxd
+ libusbmuxd.so:comms/libusbmuxd \
+ libimobiledevice.so:comms/libimobiledevice
GPOD_CMAKE_ON= -DENABLE_LIBGPOD=ON
GPOD_CMAKE_OFF= -DENABLE_LIBGPOD=OFF
diff --git a/audio/clementine-player/distinfo b/audio/clementine-player/distinfo
index 7f53b1fb10db..ed0082c62a89 100644
--- a/audio/clementine-player/distinfo
+++ b/audio/clementine-player/distinfo
@@ -1,2 +1,3 @@
-SHA256 (clementine-player-Clementine-1.3.1_GH0.tar.gz) = f885931a9ab7c88607d07b50c64fcce46fc05f13dd2c0a04188c94eff938f37c
-SIZE (clementine-player-Clementine-1.3.1_GH0.tar.gz) = 8501827
+TIMESTAMP = 1527263085
+SHA256 (clementine-player-Clementine-v1.3.1-441-gc01b7bc_GH0.tar.gz) = 78082a523dc21b6ddf17fd7bd3ab7734634bce93dacdc1a50efb4dda4e346be6
+SIZE (clementine-player-Clementine-v1.3.1-441-gc01b7bc_GH0.tar.gz) = 8468459
diff --git a/audio/clementine-player/files/patch-git_ded3126 b/audio/clementine-player/files/patch-git_ded3126
deleted file mode 100644
index 6deda743096d..000000000000
--- a/audio/clementine-player/files/patch-git_ded3126
+++ /dev/null
@@ -1,34 +0,0 @@
-Add compatibility with chromaprint >= 1.4
-
-diff --git a/src/musicbrainz/chromaprinter.cpp b/src/musicbrainz/chromaprinter.cpp
-index 9579b62..c7ad99e 100644
---- src/musicbrainz/chromaprinter.cpp.orig
-+++ src/musicbrainz/chromaprinter.cpp
-@@ -143,16 +143,24 @@ QString Chromaprinter::CreateFingerprint() {
- ChromaprintContext* chromaprint =
- chromaprint_new(CHROMAPRINT_ALGORITHM_DEFAULT);
- chromaprint_start(chromaprint, kDecodeRate, kDecodeChannels);
-- chromaprint_feed(chromaprint, reinterpret_cast<void*>(data.data()),
-+ chromaprint_feed(chromaprint, reinterpret_cast<int16_t *>(data.data()),
- data.size() / 2);
- chromaprint_finish(chromaprint);
-
-- void* fprint = nullptr;
- int size = 0;
-+
-+#if CHROMAPRINT_VERSION_MAJOR >= 1 && CHROMAPRINT_VERSION_MINOR >= 4
-+ u_int32_t *fprint = nullptr;
-+ char *encoded = nullptr;
-+#else
-+ void *fprint = nullptr;
-+ void *encoded = nullptr;
-+#endif
-+
- int ret = chromaprint_get_raw_fingerprint(chromaprint, &fprint, &size);
-+
- QByteArray fingerprint;
- if (ret == 1) {
-- void* encoded = nullptr;
- int encoded_size = 0;
- chromaprint_encode_fingerprint(fprint, size, CHROMAPRINT_ALGORITHM_DEFAULT,
- &encoded, &encoded_size, 1);
diff --git a/audio/clementine-player/files/patch-src_internet_vk_vkconnection.h b/audio/clementine-player/files/patch-src_internet_vk_vkconnection.h
deleted file mode 100644
index 3d99d371098a..000000000000
--- a/audio/clementine-player/files/patch-src_internet_vk_vkconnection.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/internet/vk/vkconnection.h.orig 2016-04-19 15:08:35 UTC
-+++ src/internet/vk/vkconnection.h
-@@ -19,6 +19,8 @@
- #ifndef INTERNET_VK_VKCONNECTION_H_
- #define INTERNET_VK_VKCONNECTION_H_
-
-+#include <time.h>
-+
- #include "vreen/client.h"
- #include "vreen/connection.h"
-