aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--games/groundhog/Makefile8
-rw-r--r--multimedia/mjpegtools/Makefile4
-rw-r--r--science/ghemical/Makefile8
3 files changed, 18 insertions, 2 deletions
diff --git a/games/groundhog/Makefile b/games/groundhog/Makefile
index c5bdfd121c63..f76884a0faa5 100644
--- a/games/groundhog/Makefile
+++ b/games/groundhog/Makefile
@@ -20,4 +20,10 @@ LIB_DEPENDS= gtk-x11-2.0.200:${PORTSDIR}/x11-toolkits/gtk20 \
USE_GMAKE= yes
GNU_CONFIGURE= yes
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502102
+BROKEN= "Does not compile"
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/multimedia/mjpegtools/Makefile b/multimedia/mjpegtools/Makefile
index afa3ccce3313..e3059ef1ecfb 100644
--- a/multimedia/mjpegtools/Makefile
+++ b/multimedia/mjpegtools/Makefile
@@ -54,6 +54,10 @@ post-install:
.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 502102
+BROKEN= "Does not compile"
+.endif
+
.if ${ARCH} != "i386"
PLIST_SUB+= DIVX='@comment '
.else
diff --git a/science/ghemical/Makefile b/science/ghemical/Makefile
index 3aa770f9d606..291a6dbd2755 100644
--- a/science/ghemical/Makefile
+++ b/science/ghemical/Makefile
@@ -29,6 +29,12 @@ CONFIGURE_ARGS= --enable-mpqc
USE_AUTOCONF= yes
USE_AUTOCONF_VER= 253
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502102
+BROKEN= "Does not compile"
+.endif
+
pre-configure:
@cd ${WRKDIR}/${DISTNAME} ; ${AUTOCONF}
@@ -39,4 +45,4 @@ pre-patch:
pre-build:
@${REINPLACE_CMD} -e 's|f2c.h|g2c.h|g;' ${WRKSRC}/miniMOPAC/*.c
@${REINPLACE_CMD} -e 's|f2c.h|g2c.h|g;' ${WRKSRC}/src/common/qm1e_mopac.cpp
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>