aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--mail/couriergraph/Makefile16
-rw-r--r--mail/couriergraph/distinfo6
-rw-r--r--mail/couriergraph/files/couriergraph.sh.in1
-rw-r--r--mail/couriergraph/files/patch-couriergraph.cgi12
-rw-r--r--mail/couriergraph/files/patch-couriergraph.pl12
-rw-r--r--mail/couriergraph/pkg-plist1
6 files changed, 17 insertions, 31 deletions
diff --git a/mail/couriergraph/Makefile b/mail/couriergraph/Makefile
index 3e572623a757..6fcd87c01c34 100644
--- a/mail/couriergraph/Makefile
+++ b/mail/couriergraph/Makefile
@@ -6,11 +6,10 @@
#
PORTNAME= couriergraph
-PORTVERSION= 20041207
+PORTVERSION= 20060202
CATEGORIES= mail
-MASTER_SITES= http://www.stahl.bau.tu-bs.de/~hildeb/postfix/couriergraph/
-DISTNAME= ${PORTNAME}
-DIST_SUBDIR= ${PORTNAME}-${PORTVERSION}
+MASTER_SITES= ftp://ftp.oav.net/couriergraph/
+DIST_SUBDIR= ${PORTNAME}
MAINTAINER= kiwi@oav.net
COMMENT= A RRDtool frontend for Courier statistics
@@ -19,14 +18,14 @@ RUN_DEPENDS= ${SITE_PERL}/RRDp.pm:${PORTSDIR}/net/rrdtool \
${SITE_PERL}/File/Tail.pm:${PORTSDIR}/devel/p5-File-Tail
NO_BUILD= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}
DATADIR?= /var/db/couriergraph
COURIERGRAPH_USER?= ${WWWOWN}
COURIERGRAPH_GROUP?= ${WWWGRP}
-USE_RC_SUBR= yes
-RC_SCRIPTS_SUB= PREFIX=${PREFIX} RC_SUBR=${RC_SUBR} DATADIR=${DATADIR} \
- COURIERGRAPH_USER=${COURIERGRAPH_USER} COURIERGRAPH_GROUP=${COURIERGRAPH_GROUP}
+USE_RC_SUBR= ${PORTNAME}.sh
+SUB_LIST+= COURIERGRAPH_USER=${COURIERGRAPH_USER} COURIERGRAPH_GROUP=${COURIERGRAPH_GROUP}
STARTUP_FILE= ${PREFIX}/etc/rc.d/couriergraph.sh
@@ -53,9 +52,6 @@ do-install:
@${CHOWN} -R ${COURIERGRAPH_USER}:${COURIERGRAPH_GROUP} ${DATADIR}
@${INSTALL_SCRIPT} ${WRKSRC}/couriergraph.pl ${PREFIX}/sbin
@${INSTALL_SCRIPT} ${WRKSRC}/couriergraph.cgi ${PREFIX}/www/cgi-bin
- @${SED} ${RC_SCRIPTS_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} \
- ${FILESDIR}/couriergraph.sh.in > ${STARTUP_FILE}
- @${CHMOD} 755 ${STARTUP_FILE}
post-install:
@${ECHO}
diff --git a/mail/couriergraph/distinfo b/mail/couriergraph/distinfo
index d843b709f5ed..7c6f753af062 100644
--- a/mail/couriergraph/distinfo
+++ b/mail/couriergraph/distinfo
@@ -1,3 +1,3 @@
-MD5 (couriergraph-20041207/couriergraph.tar.gz) = 19d63b9740c63aaf29b24141b37984df
-SHA256 (couriergraph-20041207/couriergraph.tar.gz) = b888361ae69db62da61e47c117f5910e430584473ac2f7bd968e3bc69daa7ba7
-SIZE (couriergraph-20041207/couriergraph.tar.gz) = 7657
+MD5 (couriergraph/couriergraph-20060202.tar.gz) = 0c9fcbc1223fd7e7b594d4bcfae5f70b
+SHA256 (couriergraph/couriergraph-20060202.tar.gz) = 3159948a122d808e90567a12ad7db4031b5e47e9ec6c7e90f6fc3283eb0cdc7f
+SIZE (couriergraph/couriergraph-20060202.tar.gz) = 7559
diff --git a/mail/couriergraph/files/couriergraph.sh.in b/mail/couriergraph/files/couriergraph.sh.in
index 3ce36484e285..6aa96cc61c16 100644
--- a/mail/couriergraph/files/couriergraph.sh.in
+++ b/mail/couriergraph/files/couriergraph.sh.in
@@ -4,6 +4,7 @@
#
# PROVIDE: couriergraph
# REQUIRE: DAEMON
+# BEFORE: mail
#
# Add the following line to /etc/rc.conf to enable mailgraph:
#
diff --git a/mail/couriergraph/files/patch-couriergraph.cgi b/mail/couriergraph/files/patch-couriergraph.cgi
index d1ca7da8ab67..e6c6798fd565 100644
--- a/mail/couriergraph/files/patch-couriergraph.cgi
+++ b/mail/couriergraph/files/patch-couriergraph.cgi
@@ -1,15 +1,11 @@
---- couriergraph.cgi.orig Thu Dec 29 07:42:00 2005
-+++ couriergraph.cgi Thu Dec 29 07:44:42 2005
-@@ -18,9 +18,10 @@
+--- couriergraph.cgi.orig Tue Aug 8 11:56:47 2006
++++ couriergraph.cgi Tue Aug 8 11:57:09 2006
+@@ -18,7 +18,7 @@
my $points_per_sample = 3;
my $ypoints = 160;
my $ypoints_err = 96;
-my $rrd = '/etc/postfix/couriergraph.rrd'; # path to where the RRD database is
--my $rrd_virus = '/etc/postfix/mailgraph_virus.rrd'; # path to where the Virus RRD database is
-+my $rrd = '%%DATADIR%%/etc/postfix/couriergraph.rrd'; # path to where the RRD database is
-+my $rrd_virus = '%%DATADIR%%/etc/postfix/mailgraph_virus.rrd'; # path to where the Virus RRD database is
++my $rrd = '%%DATADIR%%/couriergraph.rrd'; # path to where the RRD database is
my $tmp_dir = '/tmp/couriergraph'; # temporary directory where to store the images
-+my $rrdtool_1_0 = ($RRDs::VERSION < 1.199908);
my @graphs = (
- { title => 'Day Graphs', seconds => 3600*24, },
diff --git a/mail/couriergraph/files/patch-couriergraph.pl b/mail/couriergraph/files/patch-couriergraph.pl
index 3c5436b5f495..f08d3c751cd2 100644
--- a/mail/couriergraph/files/patch-couriergraph.pl
+++ b/mail/couriergraph/files/patch-couriergraph.pl
@@ -1,5 +1,5 @@
---- couriergraph.pl.orig Thu Dec 29 07:47:47 2005
-+++ couriergraph.pl Thu Dec 29 07:48:36 2005
+--- couriergraph.pl.orig Tue Jun 20 11:11:39 2006
++++ couriergraph.pl Tue Aug 8 12:02:45 2006
@@ -314,11 +314,11 @@
my $daemon_logfile = '/var/log/couriergraph.log';
@@ -23,7 +23,7 @@
print " --daemon-log=FILE write verbose-log to FILE instead of /var/log/mailgraph.log\n";
print " --rrd-name=NAME use NAME.rrd for the rrd files\n";
-@@ -473,12 +473,12 @@
+@@ -473,7 +473,7 @@
my $prog = $sl->[2];
my $text = $sl->[4];
@@ -32,9 +32,3 @@
if($text =~ /LOGIN,/) {
event($time, 'pop3d_login');
}
- }
-- elsif ($prog eq 'imaplogin') {
-+ elsif ($prog eq 'imap') {
- if($text =~ /LOGIN,/) {
- event($time, 'imapd_login');
- }
diff --git a/mail/couriergraph/pkg-plist b/mail/couriergraph/pkg-plist
index b8f98023f15f..50023bb6307b 100644
--- a/mail/couriergraph/pkg-plist
+++ b/mail/couriergraph/pkg-plist
@@ -1,4 +1,3 @@
-etc/rc.d/couriergraph.sh
www/cgi-bin/couriergraph.cgi
sbin/couriergraph.pl
@dirrmtry www/cgi-bin