aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--lang/Makefile1
-rw-r--r--lang/tinypy/Makefile50
-rw-r--r--lang/tinypy/distinfo3
-rw-r--r--lang/tinypy/pkg-descr19
4 files changed, 73 insertions, 0 deletions
diff --git a/lang/Makefile b/lang/Makefile
index 50b3ac6155a0..89ca060a1de5 100644
--- a/lang/Makefile
+++ b/lang/Makefile
@@ -342,6 +342,7 @@
SUBDIR += tclX
SUBDIR += tcltutor
SUBDIR += tinycobol
+ SUBDIR += tinypy
SUBDIR += tolua
SUBDIR += tolua++
SUBDIR += tolua++50
diff --git a/lang/tinypy/Makefile b/lang/tinypy/Makefile
new file mode 100644
index 000000000000..aa177dff0653
--- /dev/null
+++ b/lang/tinypy/Makefile
@@ -0,0 +1,50 @@
+# New ports collection makefile for: tinypy
+# Date created: 2009-02-26
+# Whom: Marcin Cieslak <saper@SYSTEM.PL>
+#
+# $FreeBSD$
+#
+
+PORTNAME= tinypy
+PORTVERSION= 1.1
+CATEGORIES= lang python
+MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
+
+MAINTAINER= saper@SYSTEM.PL
+COMMENT= A minimalist implementation of python in 64k of code
+
+USE_PYTHON_BUILD= yes
+USE_PYDISTUTILS= yes
+
+PYDISTUTILS_BUILD_TARGET= linux
+PYDISTUTILS_NOEGGINFO= yes
+
+PLIST_FILES= bin/tinypy
+PORTEXAMPLES= *
+
+OPTIONS= PYGAME "Enable PyGame support (requires SDL)" off
+
+.include <bsd.port.options.mk>
+
+.if defined(WITH_PYGAME)
+PYDISTUTILS_BUILD_TARGET+= pygame
+USE_SDL= sdl
+.endif
+
+.include <bsd.port.pre.mk>
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-O.||; s|gcc $$WFLAGS|${CC} ${CFLAGS} -std=c89 -Wall|' \
+ ${WRKSRC}/setup.py
+
+do-configure:
+ @${DO_NADA}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/build/tinypy ${PREFIX}/bin
+.if !defined(NOPORTEXAMPLES) && defined(WITH_PYGAME)
+ @${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/examples/julia.py ${EXAMPLESDIR}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/lang/tinypy/distinfo b/lang/tinypy/distinfo
new file mode 100644
index 000000000000..422e9f9867ff
--- /dev/null
+++ b/lang/tinypy/distinfo
@@ -0,0 +1,3 @@
+MD5 (tinypy-1.1.tar.gz) = 1091300b72fcc1f75cafb91bea92772e
+SHA256 (tinypy-1.1.tar.gz) = 858d68d3643614e3646776ad99d5e4ad7cbd6428f44c3acd4cf7b11db1c55b39
+SIZE (tinypy-1.1.tar.gz) = 40632
diff --git a/lang/tinypy/pkg-descr b/lang/tinypy/pkg-descr
new file mode 100644
index 000000000000..8f4eebe27c5f
--- /dev/null
+++ b/lang/tinypy/pkg-descr
@@ -0,0 +1,19 @@
+tinypy is a minimalist implementation of python in 64k of code
+
+it includes a whole heap of features:
+
+ * parser and bytecode compiler written in tinypy
+ * fully bootstrapped
+ * luaesque virtual machine with garbage collection written in C
+ it's "stackless" sans any "stackless" features
+ * cross-platform :) it runs under windows / linux / macosx
+ * a fairly decent subset of python
+ o classes and single inheritance
+ o functions with variable or keyword arguments
+ o strings, lists, dicts, numbers
+ o modules, list comprehensions
+ o exceptions with full traceback
+ o some builtins
+ * batteries not included -- yet
+
+WWW: http://www.tinypy.org/