aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Spoon/Makefile47
-rw-r--r--devel/p5-Spoon/distinfo2
-rw-r--r--devel/p5-Spoon/pkg-descr14
-rw-r--r--devel/p5-Spoon/pkg-plist19
5 files changed, 83 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 8a77bbf8b7a8..28c4ee44adfb 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -925,6 +925,7 @@
SUBDIR += p5-Sort-Tree
SUBDIR += p5-Sort-Versions
SUBDIR += p5-Spiffy
+ SUBDIR += p5-Spoon
SUBDIR += p5-Storable
SUBDIR += p5-String-Approx
SUBDIR += p5-String-CRC32
diff --git a/devel/p5-Spoon/Makefile b/devel/p5-Spoon/Makefile
new file mode 100644
index 000000000000..08d4a5959533
--- /dev/null
+++ b/devel/p5-Spoon/Makefile
@@ -0,0 +1,47 @@
+# New ports collection makefile for: p5-Spoon
+# Date created: Fri Jul 16 14:17:55 CST 2004
+# Whom: Cheng-Lung Sung <clsung@dragon2.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Spoon
+PORTVERSION= 0.16
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../../authors/id/I/IN/INGY/
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= A Spiffy Application Building Framework
+
+BUILD_DEPENDS= ${SITE_PERL}/Spiffy.pm:${PORTSDIR}/devel/p5-Spiffy \
+ ${SITE_PERL}/IO/All.pm:${PORTSDIR}/devel/p5-IO-All \
+ ${SITE_PERL}/${PERL_ARCH}/Template.pm:${PORTSDIR}/www/p5-Template-Toolkit
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Spoon.3 \
+ Spoon::Base.3 \
+ Spoon::CGI.3 \
+ Spoon::Config.3 \
+ Spoon::ContentObject.3 \
+ Spoon::Cookie.3 \
+ Spoon::DataObject.3 \
+ Spoon::Formatter.3 \
+ Spoon::Hub.3 \
+ Spoon::Installer.3 \
+ Spoon::MetadataObject.3 \
+ Spoon::Template.3 \
+ Spoon::Template::TT2.3 \
+ Spoon::Registry.3 \
+ Spoon::Plugin.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500601
+IGNORE= This port requires perl 5.6.1 or later. Install lang/perl5 then try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Spoon/distinfo b/devel/p5-Spoon/distinfo
new file mode 100644
index 000000000000..e31c7a623f6d
--- /dev/null
+++ b/devel/p5-Spoon/distinfo
@@ -0,0 +1,2 @@
+MD5 (Spoon-0.16.tar.gz) = 89b2b38768d2977d075a80c61d8ba962
+SIZE (Spoon-0.16.tar.gz) = 17091
diff --git a/devel/p5-Spoon/pkg-descr b/devel/p5-Spoon/pkg-descr
new file mode 100644
index 000000000000..227b1c2bcb51
--- /dev/null
+++ b/devel/p5-Spoon/pkg-descr
@@ -0,0 +1,14 @@
+Spoon - A Spiffy Application Building Framework
+
+Spoon is an Application Framework that is designed primarily for
+building Social Software web applications. The Kwiki wiki software is
+built on top of Spoon.
+
+Spoon::Base is the primary base class for all the Spoon::* modules.
+Spoon.pm inherits from Spiffy.pm.
+
+Spoon is not an application in and of itself. (As compared to Kwiki) You
+ need to build your own applications from it.
+
+WWW: http://search.cpan.org/~ingy/Spoon/
+Author: Brian Ingerson <INGY at cpan.org>
diff --git a/devel/p5-Spoon/pkg-plist b/devel/p5-Spoon/pkg-plist
new file mode 100644
index 000000000000..37861ebdecad
--- /dev/null
+++ b/devel/p5-Spoon/pkg-plist
@@ -0,0 +1,19 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Spoon/.packlist
+%%SITE_PERL%%/Spoon.pm
+%%SITE_PERL%%/Spoon/Base.pm
+%%SITE_PERL%%/Spoon/CGI.pm
+%%SITE_PERL%%/Spoon/Config.pm
+%%SITE_PERL%%/Spoon/ContentObject.pm
+%%SITE_PERL%%/Spoon/Cookie.pm
+%%SITE_PERL%%/Spoon/DataObject.pm
+%%SITE_PERL%%/Spoon/Formatter.pm
+%%SITE_PERL%%/Spoon/Hub.pm
+%%SITE_PERL%%/Spoon/Installer.pm
+%%SITE_PERL%%/Spoon/MetadataObject.pm
+%%SITE_PERL%%/Spoon/Template.pm
+%%SITE_PERL%%/Spoon/Template/TT2.pm
+%%SITE_PERL%%/Spoon/Registry.pm
+%%SITE_PERL%%/Spoon/Plugin.pm
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Spoon
+@dirrm %%SITE_PERL%%/Spoon/Template
+@dirrm %%SITE_PERL%%/Spoon