aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Mk/bsd.port.mk30
1 files changed, 20 insertions, 10 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 3f2104bde282..4fab3b15499b 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -3,7 +3,7 @@
# bsd.port.mk - 940820 Jordan K. Hubbard.
# This file is in the public domain.
#
-# $Id: bsd.port.mk,v 1.91 1995/01/03 11:51:59 jkh Exp $
+# $Id: bsd.port.mk,v 1.92 1995/01/04 07:35:46 jkh Exp $
#
# Please view me with 4 column tabs!
@@ -17,7 +17,9 @@
# (default: ${PORTSDIR}/distfiles).
# PREFIX - Where to install things in general (default: /usr/local).
# MASTER_SITES - Primary location(s) for distribution files if not found
-# locally.
+# locally (default:
+# ftp://ftp.freebsd.org/pub/FreeBSD/ports/distfiles)
+#
# MASTER_SITE_OVERRIDE - If set, override the MASTER_SITES setting with this
# value.
# MASTER_SITE_FREEBSD - If set, only use the FreeBSD master repository for
@@ -27,9 +29,12 @@
# GMAKE - Set to path of GNU make if not in $PATH (default: gmake).
# XMKMF - Set to path of `xmkmf' if not in $PATH (default: xmkmf).
#
-# Variables that typically apply to an individual port:
+# Variables that typically apply to an individual port. Non-Boolean
+# variables without defaults are *mandatory*.
+#
#
-# WRKDIR - A temporary working directory that gets *clobbered* on clean.
+# WRKDIR - A temporary working directory that gets *clobbered* on clean
+# (default: ${.CURDIR}/work).
# WRKSRC - A subdirectory of ${WRKDIR} where the distribution actually
# unpacks to. (Default: ${WRKDIR}/${DISTNAME} unless
# NO_WRKSUBDIR is set, in which case simply ${WRKDIR}).
@@ -38,12 +43,17 @@
# (default: ${DISTDIR}/${DISTNAME}${EXTRACT_SUFX}).
# PKGNAME - Name of the package file to create if the DISTNAME
# isn't really relevant for the port/package
+# (default: ${DISTNAME}).
# EXTRACT_ONLY - If defined, a subset of ${DISTFILES} you want to
# actually extract.
-# PATCHDIR - A directory containing any required patches.
-# SCRIPTDIR - A directory containing any auxilliary scripts.
+# PATCHDIR - A directory containing any required patches
+# (default: ${.CURDIR}/patches)
+# SCRIPTDIR - A directory containing any auxilliary scripts
+# (default: ${.CURDIR}/scripes)
# FILESDIR - A directory containing any miscellaneous additional files.
+# (default: ${.CURDIR}/files)
# PKGDIR - A direction containing any package creation files.
+# (default: ${.CURDIR}/pkg)
#
# NO_EXTRACT - Use a dummy (do-nothing) extract target.
# NO_CONFIGURE - Use a dummy (do-nothing) configure target.
@@ -60,11 +70,11 @@
# target.
# HAS_CONFIGURE - Says that the port has its own configure script.
# GNU_CONFIGURE - Set if you are using GNU configure (optional).
-# CONFIGURE_ARGS - Pass these args to configure, if $HAS_CONFIGURE.
+# CONFIGURE_ARGS - Pass these args to configure, if ${HAS_CONFIGURE} set.
# IS_INTERACTIVE - Set this if your port needs to interact with the user
-# during a build. User can then decide to skip this port by
-# setting BATCH, or compile ONLY interactive ports by setting
-# INTERACTIVE.
+# during a build. User can then decide to skip this port by
+# setting ${BATCH}, or compiling only the interactive ports
+# by setting ${INTERACTIVE}.
# DEPENDS - A list of other ports this package depends on being
# made first, relative to ${PORTSDIR} (e.g. x11/tk, lang/tcl,
# etc).
perl frameworkaz2013-08-031-7/+2 * Deprecate and set expiration date for ports broken for more than 6 monthbapt2013-07-271-0/+3 * Convert to new options frameworkbapt2013-06-071-10/+9 * Convert from WITHOUT_NLS to PORT_OPTIONS:MNLSbapt2013-05-061-7/+9 * Fix build on currentbapt2013-05-061-1/+1 * In preparation of removing devel/libusb (expires 2013-04-30), remove itrene2013-04-301-3/+0 * - Convert USE_ICONV=yes to USES=iconvmva2013-04-286-10/+6 * - Convert USE_GETTEXT to USES (part 4)ak2013-04-262-3/+2 * - Convert USE_GETTEXT to USES (part 1)ak2013-04-243-6/+3 * Finish converting the whole ports tree to USES=pkgconfigbapt2013-04-234-6/+4 * Reassign skv@ ports to the heapbapt2013-04-221-6/+2 * - Fix typo in OptionsNG conversionwg2013-04-071-1/+1 * - Broken fails to buildmiwi2013-04-021-0/+1 * Style: tab -> space.eadler2013-03-291-1/+1 * Drop support for old versions of FreeBSD from unmaintained portseadler2013-03-281-4/+0 * Mechanically convert unmaintained ports which use "gnomehack" to use "pathfix...eadler2013-03-282-11/+6 * Readd removed commentsbdrewery2013-03-221-0/+2 * Convert to new options framework ports in p* catoriesbapt2013-03-221-16/+12 * Add an explicit dependency on pkgconfbapt2013-03-221-6/+4 * Add an explicit dependency on pkgconfbapt2013-03-221-6/+2 * This changes almost all the "gnomehack" only USE_GNOME cases to USES= pathfix.eadler2013-03-193-3/+3 * In categories starting with [n-s], remove empty lines (and also few cases ofdanfe2013-03-171-1/+0 * Convert USE_BISON to USES= bisonbapt2013-03-081-7/+3 * Convert to new options frameworkbapt2013-02-211-6/+5