aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--devel/libg++/Makefile8
-rw-r--r--net/ipex/Makefile8
-rw-r--r--sysutils/lsof/Makefile2
3 files changed, 16 insertions, 2 deletions
diff --git a/devel/libg++/Makefile b/devel/libg++/Makefile
index e296a56ac566..698210379450 100644
--- a/devel/libg++/Makefile
+++ b/devel/libg++/Makefile
@@ -31,4 +31,10 @@ PLIST_SUB= GCC28SUBDIR=${GCC28DIR}
pre-configure:
@${CP} -p ${FILESDIR}/Makefile.libg++ ${WRKSRC}/Makefile
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 800000
+BROKEN= does not build
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net/ipex/Makefile b/net/ipex/Makefile
index 205b2e6d7f4d..c91bab5f04c8 100644
--- a/net/ipex/Makefile
+++ b/net/ipex/Makefile
@@ -24,4 +24,10 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/ipex ${PREFIX}/bin/ipex
${INSTALL_MAN} ${WRKSRC}/doc/ipex.1.gz ${MANPREFIX}/man/man1/ipex.1.gz
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 800000
+BROKEN= does not build
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/sysutils/lsof/Makefile b/sysutils/lsof/Makefile
index 0b7cfa1117a5..985ea4343e87 100644
--- a/sysutils/lsof/Makefile
+++ b/sysutils/lsof/Makefile
@@ -99,6 +99,8 @@ pre-configure:
@${ECHO} "************************************************************"
@${ECHO} ""
.endif
+.elif ${OSVERSION} >= 800000
+BROKEN= does not build
.endif
post-install: