aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--mail/cyrus-imapd/Makefile9
-rw-r--r--mail/cyrus-imapd2/Makefile5
-rw-r--r--mail/cyrus-imapd22/Makefile5
-rw-r--r--mail/cyrus-imapd23/Makefile5
-rw-r--r--mail/cyrus-imapd24/Makefile5
5 files changed, 28 insertions, 1 deletions
diff --git a/mail/cyrus-imapd/Makefile b/mail/cyrus-imapd/Makefile
index c819d1140b99..823d187b4eb9 100644
--- a/mail/cyrus-imapd/Makefile
+++ b/mail/cyrus-imapd/Makefile
@@ -62,6 +62,13 @@ HTDOCS= anoncvs bugs changes faq feedback index install-admin-mb \
install-testing install-upgrade install mailing-list man \
notes os overview questions readme sieve-protocol sieve specs
+.include <bsd.port.pre.mk>
+
+.include "${PORTSDIR}/security/openssl/bsd.openssl.mk"
+.if !defined(WITH_OPENSSL_BASE)
+CONFIGURE_ARGS+= --with-openssl=${OPENSSLBASE}
+.endif
+
post-patch:
@${REINPLACE_CMD} -e "s|/etc/|${PREFIX}/etc/|" \
${WRKSRC}/tools/mkimap
@@ -110,4 +117,4 @@ post-install:
@PKG_PREFIX=${PREFIX} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/mail/cyrus-imapd2/Makefile b/mail/cyrus-imapd2/Makefile
index 9e832a616c45..282fef93b819 100644
--- a/mail/cyrus-imapd2/Makefile
+++ b/mail/cyrus-imapd2/Makefile
@@ -112,6 +112,11 @@ RUN_DEPENDS+= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/File/Temp.pm:${PORTSD
RUN_DEPENDS+= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Pod/Parser.pm:${PORTSDIR}/textproc/p5-PodParser
.endif
+.include "${PORTSDIR}/security/openssl/bsd.openssl.mk"
+#.if !defined(WITH_OPENSSL_BASE)
+CONFIGURE_ARGS+= --with-openssl=${OPENSSLBASE}
+#.endif
+
pre-everything::
.if !defined(WITH_BDB_VER)
@if ${LDCONFIG} -r | ${GREP} -qwE -e "-ldb(41|4)"; then \
diff --git a/mail/cyrus-imapd22/Makefile b/mail/cyrus-imapd22/Makefile
index f8c97262f25d..5d59ceff21aa 100644
--- a/mail/cyrus-imapd22/Makefile
+++ b/mail/cyrus-imapd22/Makefile
@@ -137,6 +137,11 @@ RUN_DEPENDS+= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/File/Temp.pm:${PORTSD
RUN_DEPENDS+= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Pod/Parser.pm:${PORTSDIR}/textproc/p5-PodParser
.endif
+.include "${PORTSDIR}/security/openssl/bsd.openssl.mk"
+.if !defined(WITH_OPENSSL_BASE)
+CONFIGURE_ARGS+= --with-openssl=${OPENSSLBASE}
+.endif
+
pre-everything::
.if !defined(WITH_BDB_VER)
@if ${LDCONFIG} -r | ${GREP} -qwE -e "-ldb(41|4)"; then \
diff --git a/mail/cyrus-imapd23/Makefile b/mail/cyrus-imapd23/Makefile
index f8c97262f25d..5d59ceff21aa 100644
--- a/mail/cyrus-imapd23/Makefile
+++ b/mail/cyrus-imapd23/Makefile
@@ -137,6 +137,11 @@ RUN_DEPENDS+= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/File/Temp.pm:${PORTSD
RUN_DEPENDS+= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Pod/Parser.pm:${PORTSDIR}/textproc/p5-PodParser
.endif
+.include "${PORTSDIR}/security/openssl/bsd.openssl.mk"
+.if !defined(WITH_OPENSSL_BASE)
+CONFIGURE_ARGS+= --with-openssl=${OPENSSLBASE}
+.endif
+
pre-everything::
.if !defined(WITH_BDB_VER)
@if ${LDCONFIG} -r | ${GREP} -qwE -e "-ldb(41|4)"; then \
diff --git a/mail/cyrus-imapd24/Makefile b/mail/cyrus-imapd24/Makefile
index f8c97262f25d..5d59ceff21aa 100644
--- a/mail/cyrus-imapd24/Makefile
+++ b/mail/cyrus-imapd24/Makefile
@@ -137,6 +137,11 @@ RUN_DEPENDS+= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/File/Temp.pm:${PORTSD
RUN_DEPENDS+= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Pod/Parser.pm:${PORTSDIR}/textproc/p5-PodParser
.endif
+.include "${PORTSDIR}/security/openssl/bsd.openssl.mk"
+.if !defined(WITH_OPENSSL_BASE)
+CONFIGURE_ARGS+= --with-openssl=${OPENSSLBASE}
+.endif
+
pre-everything::
.if !defined(WITH_BDB_VER)
@if ${LDCONFIG} -r | ${GREP} -qwE -e "-ldb(41|4)"; then \