aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/yaml-cpp03/Makefile26
-rw-r--r--devel/yaml-cpp03/distinfo2
-rw-r--r--devel/yaml-cpp03/files/patch-CMakeLists.txt20
-rw-r--r--devel/yaml-cpp03/pkg-descr3
-rw-r--r--devel/yaml-cpp03/pkg-plist33
6 files changed, 85 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 6a369cf22d98..978ab2995a2a 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4744,6 +4744,7 @@
SUBDIR += yajl
SUBDIR += yajl-tcl
SUBDIR += yaml-cpp
+ SUBDIR += yaml-cpp03
SUBDIR += yasm
SUBDIR += yasm-devel
SUBDIR += z80-asm
diff --git a/devel/yaml-cpp03/Makefile b/devel/yaml-cpp03/Makefile
new file mode 100644
index 000000000000..cb7bd51aa437
--- /dev/null
+++ b/devel/yaml-cpp03/Makefile
@@ -0,0 +1,26 @@
+# Created by: Tim Niemueller <tim@niemueller.de>
+# $FreeBSD$
+
+PORTNAME= yaml-cpp
+PORTVERSION= 0.3.0
+CATEGORIES= devel
+MASTER_SITES= GOOGLE_CODE
+PKGNAMESUFFIX= 03
+
+MAINTAINER= tim@niemueller.de
+COMMENT= YAML parser and emitter in C++ matching the YAML 1.2 spec
+
+LICENSE= MIT
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+USES= cmake
+USE_LDCONFIG= yes
+CMAKE_ARGS+= -DBUILD_SHARED_LIBS:BOOL=ON -DYAML_CPP_BUILD_TOOLS=0
+
+post-patch: .SILENT
+ ${FIND} ${WRKSRC} -name '*.[hc]*' -o -name CMakeLists.txt | \
+ ${XARGS} ${REINPLACE_CMD} -e 's|yaml-cpp|yaml-cpp${PKGNAMESUFFIX}|g'
+ ${MV} ${WRKSRC}/include/yaml-cpp ${WRKSRC}/include/yaml-cpp${PKGNAMESUFFIX}
+ ${MV} ${WRKSRC}/yaml-cpp.pc.cmake ${WRKSRC}/yaml-cpp${PKGNAMESUFFIX}.pc.cmake
+
+.include <bsd.port.mk>
diff --git a/devel/yaml-cpp03/distinfo b/devel/yaml-cpp03/distinfo
new file mode 100644
index 000000000000..656537fb6ff9
--- /dev/null
+++ b/devel/yaml-cpp03/distinfo
@@ -0,0 +1,2 @@
+SHA256 (yaml-cpp-0.3.0.tar.gz) = 2cd038b5a1583b6745e949e196fba525f6d0d5fd340566585fde24fc7e117b82
+SIZE (yaml-cpp-0.3.0.tar.gz) = 82674
diff --git a/devel/yaml-cpp03/files/patch-CMakeLists.txt b/devel/yaml-cpp03/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..07cd134f202d
--- /dev/null
+++ b/devel/yaml-cpp03/files/patch-CMakeLists.txt
@@ -0,0 +1,20 @@
+--- CMakeLists.txt.orig 2013-04-14 03:37:53.000000000 +0400
++++ CMakeLists.txt 2014-09-11 17:37:09.000000000 +0400
+@@ -240,7 +240,7 @@
+
+ set_target_properties(yaml-cpp PROPERTIES
+ VERSION "${YAML_CPP_VERSION}"
+- SOVERSION "${YAML_CPP_VERSION_MAJOR}.${YAML_CPP_VERSION_MINOR}"
++ SOVERSION "${YAML_CPP_VERSION_MAJOR}"
+ PROJECT_LABEL "yaml-cpp ${LABEL_SUFFIX}"
+ )
+
+@@ -272,7 +272,7 @@
+ if(UNIX)
+ set(PC_FILE ${CMAKE_BINARY_DIR}/yaml-cpp.pc)
+ configure_file("yaml-cpp.pc.cmake" ${PC_FILE} @ONLY)
+- install(FILES ${PC_FILE} DESTINATION ${LIB_INSTALL_DIR}/pkgconfig)
++ install(FILES ${PC_FILE} DESTINATION libdata/pkgconfig)
+ endif()
+
+
diff --git a/devel/yaml-cpp03/pkg-descr b/devel/yaml-cpp03/pkg-descr
new file mode 100644
index 000000000000..c2ea498a54ef
--- /dev/null
+++ b/devel/yaml-cpp03/pkg-descr
@@ -0,0 +1,3 @@
+yaml-cpp is a YAML parser and emitter in C++ matching the YAML 1.2 spec.
+
+WWW: http://code.google.com/p/yaml-cpp/
diff --git a/devel/yaml-cpp03/pkg-plist b/devel/yaml-cpp03/pkg-plist
new file mode 100644
index 000000000000..517eb9d730bb
--- /dev/null
+++ b/devel/yaml-cpp03/pkg-plist
@@ -0,0 +1,33 @@
+include/yaml-cpp03/aliasmanager.h
+include/yaml-cpp03/anchor.h
+include/yaml-cpp03/binary.h
+include/yaml-cpp03/contrib/anchordict.h
+include/yaml-cpp03/contrib/graphbuilder.h
+include/yaml-cpp03/conversion.h
+include/yaml-cpp03/dll.h
+include/yaml-cpp03/emitfromevents.h
+include/yaml-cpp03/emitter.h
+include/yaml-cpp03/emittermanip.h
+include/yaml-cpp03/eventhandler.h
+include/yaml-cpp03/exceptions.h
+include/yaml-cpp03/iterator.h
+include/yaml-cpp03/ltnode.h
+include/yaml-cpp03/mark.h
+include/yaml-cpp03/node.h
+include/yaml-cpp03/nodeimpl.h
+include/yaml-cpp03/nodereadimpl.h
+include/yaml-cpp03/nodeutil.h
+include/yaml-cpp03/noncopyable.h
+include/yaml-cpp03/null.h
+include/yaml-cpp03/ostream.h
+include/yaml-cpp03/parser.h
+include/yaml-cpp03/stlemitter.h
+include/yaml-cpp03/stlnode.h
+include/yaml-cpp03/traits.h
+include/yaml-cpp03/yaml.h
+lib/libyaml-cpp03.so
+lib/libyaml-cpp03.so.0
+lib/libyaml-cpp03.so.0.3.0
+libdata/pkgconfig/yaml-cpp03.pc
+@dirrm include/yaml-cpp03/contrib
+@dirrm include/yaml-cpp03