aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--databases/libgnomedb/Makefile3
-rw-r--r--deskutils/notify-osd/Makefile2
-rw-r--r--net/liferea/Makefile2
-rw-r--r--sysutils/gtk-send-pr/Makefile1
-rw-r--r--textproc/qstardict/Makefile1
-rw-r--r--textproc/scim-bridge/Makefile3
-rw-r--r--x11-toolkits/nucleo/Makefile2
-rw-r--r--x11/hs-X11-xft/Makefile1
-rw-r--r--x11/xscreensaver-gnome/Makefile5
9 files changed, 10 insertions, 10 deletions
diff --git a/databases/libgnomedb/Makefile b/databases/libgnomedb/Makefile
index c1e8cee4aa4c..e5cfd019aa49 100644
--- a/databases/libgnomedb/Makefile
+++ b/databases/libgnomedb/Makefile
@@ -21,10 +21,9 @@ USE_BZIP2= yes
.if !defined(REFERENCE_PORT)
USE_AUTOTOOLS= libtool
-USE_GMAKE= yes
USE_GNOME= gnomeprefix gnomehack libgnomeui libgda3 gtksourceview \
intlhack referencehack
-USES= gettext
+USES= gettext gmake pkgconfig
GNU_CONFIGURE= yes
INSTALLS_OMF= yes
USE_LDCONFIG= yes
diff --git a/deskutils/notify-osd/Makefile b/deskutils/notify-osd/Makefile
index 62e605203a4c..f26e77e37e1f 100644
--- a/deskutils/notify-osd/Makefile
+++ b/deskutils/notify-osd/Makefile
@@ -20,7 +20,7 @@ LIB_DEPENDS= dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib \
RUN_DEPENDS= dbus-daemon:${PORTSDIR}/devel/dbus
GNU_CONFIGURE= yes
-USES= gmake
+USES= gmake pkgconfig
USE_GNOME= libwnck gconf2
USE_GCC= yes
diff --git a/net/liferea/Makefile b/net/liferea/Makefile
index 3848f3c521d4..da396ec3a0d8 100644
--- a/net/liferea/Makefile
+++ b/net/liferea/Makefile
@@ -16,7 +16,7 @@ LIB_DEPENDS= webkitgtk-1.0:${PORTSDIR}/www/webkit-gtk2 \
json-glib-1.0:${PORTSDIR}/devel/json-glib
USE_BZIP2= yes
-USES= gmake pathfix
+USES= gmake pathfix pkgconfig
USE_GNOME= gnomeprefix gconf2
USE_AUTOTOOLS= libtool
USE_SQLITE= 3
diff --git a/sysutils/gtk-send-pr/Makefile b/sysutils/gtk-send-pr/Makefile
index 872677db6322..f0161ab8ec60 100644
--- a/sysutils/gtk-send-pr/Makefile
+++ b/sysutils/gtk-send-pr/Makefile
@@ -13,6 +13,7 @@ COMMENT= GTK2 send-pr tool
LIB_DEPENDS= esmtp.7:${PORTSDIR}/mail/libesmtp
+USES= pkgconfig
USE_GNOME= gtk20
MAN1= gtk-send-pr.1
diff --git a/textproc/qstardict/Makefile b/textproc/qstardict/Makefile
index 6b72fcff3526..1570e20f7374 100644
--- a/textproc/qstardict/Makefile
+++ b/textproc/qstardict/Makefile
@@ -13,6 +13,7 @@ MASTER_SITES= http://qstardict.ylsoftware.com/files/
MAINTAINER= makc@FreeBSD.org
COMMENT= Dictionary program written in Qt4
+USES= pkgconfig
USE_BZIP2= yes
USE_QT4= gui network xml qmake_build uic_build moc_build rcc_build
QMAKE_ARGS+= -recursive
diff --git a/textproc/scim-bridge/Makefile b/textproc/scim-bridge/Makefile
index edb44132515a..214130f0167e 100644
--- a/textproc/scim-bridge/Makefile
+++ b/textproc/scim-bridge/Makefile
@@ -16,8 +16,7 @@ COMMENT= Scim-bridge agent (server)
LIB_DEPENDS= scim-1.0.10:${PORTSDIR}/textproc/scim
-USE_GMAKE= yes
-USES= gettext
+USES= gettext gmake pkgconfig
GNU_CONFIGURE= yes
LICENSE= GPLv2 LGPL21
diff --git a/x11-toolkits/nucleo/Makefile b/x11-toolkits/nucleo/Makefile
index 7ccfc0122a57..d8c0aa809ee3 100644
--- a/x11-toolkits/nucleo/Makefile
+++ b/x11-toolkits/nucleo/Makefile
@@ -18,7 +18,7 @@ LIB_DEPENDS= freetype:${PORTSDIR}/print/freetype2 \
exif:${PORTSDIR}/graphics/libexif
USE_BZIP2= yes
-USE_GMAKE= yes
+USES= gmake pkgconfig
USE_GL= glu
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/x11/hs-X11-xft/Makefile b/x11/hs-X11-xft/Makefile
index 8ddb55eab4a6..4299136bac4b 100644
--- a/x11/hs-X11-xft/Makefile
+++ b/x11/hs-X11-xft/Makefile
@@ -10,6 +10,7 @@ COMMENT= Bindings to the Xft, Xrender and Freetype for Haskell programs
LICENSE= LGPL21
+USES= pkgconfig
USE_CABAL= utf8-string>=0.1 X11>=1.2.1
USE_XORG= xft xrender
diff --git a/x11/xscreensaver-gnome/Makefile b/x11/xscreensaver-gnome/Makefile
index a1796faafb5c..7db73d451a2d 100644
--- a/x11/xscreensaver-gnome/Makefile
+++ b/x11/xscreensaver-gnome/Makefile
@@ -19,10 +19,9 @@ LIB_DEPENDS= gle.4:${PORTSDIR}/graphics/gle \
USE_XORG= x11 xpm
USE_GL= gl
-USE_GMAKE= yes
-USE_PERL5_RUN= yes
+USE_PERL5= run
USE_GNOME= gnomehier libglade2 gnomehack
-USES= gettext
+USES= gettext gmake perl5 pkgconfig
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-gtk --with-gl --with-gle --with-pixbuf --with-xpm \
--with-jpeg=${LOCALBASE} --with-xshm-ext --with-xdbe-ext \