aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Mk/Scripts/qa.sh6
-rw-r--r--Mk/Uses/libtool.mk9
2 files changed, 6 insertions, 9 deletions
diff --git a/Mk/Scripts/qa.sh b/Mk/Scripts/qa.sh
index e7cf6dd12199..b214f42af396 100644
--- a/Mk/Scripts/qa.sh
+++ b/Mk/Scripts/qa.sh
@@ -196,10 +196,10 @@ suidfiles() {
libtool() {
if [ -z "${USESLIBTOOL}" ]; then
- find ${STAGEDIR} -type f -name '*.la' | while read f; do
+ find ${STAGEDIR} -name '*.la' | while read f; do
grep -q 'libtool library' "${f}" &&
- warn ".la libraries found, port needs USES=libtool" &&
- return 0 || true
+ err ".la libraries found, port needs USES=libtool" &&
+ return 1 || true
done
# The return above continues here.
fi
diff --git a/Mk/Uses/libtool.mk b/Mk/Uses/libtool.mk
index 7d01d0ef1257..f8e928185931 100644
--- a/Mk/Uses/libtool.mk
+++ b/Mk/Uses/libtool.mk
@@ -4,12 +4,9 @@
#
# Feature: libtool
# Usage: USES=libtool or USES=libtool:args
-# Valid args: keepla Normally libtool libraries (*.la) are not installed.
-# With this option they are. This is needed as long
-# as there are dependent ports with .la libraries that
-# refer to .la libraries in this port. As soon as all
-# those dependent ports have some form of USES=libtool
-# keepla can be removed.
+# Valid args: keepla Don't remove libtool libraries (*.la) from the stage
+# directory. Some ports need them at runtime (e.g. ports
+# that call lt_dlopen from libltdl).
# build Add a build dependency on devel/libtool. This can
# be used when a port does not generate its own libtool
# script and relies on the system to provide one.