aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--security/denyhosts/Makefile10
-rw-r--r--security/denyhosts/distinfo6
-rw-r--r--security/denyhosts/files/denyhosts.in23
-rw-r--r--security/denyhosts/files/patch-denyhosts.cfg-dist26
-rw-r--r--security/denyhosts/pkg-plist3
5 files changed, 51 insertions, 17 deletions
diff --git a/security/denyhosts/Makefile b/security/denyhosts/Makefile
index 12f29dbad048..de6ede2d5dd6 100644
--- a/security/denyhosts/Makefile
+++ b/security/denyhosts/Makefile
@@ -6,11 +6,11 @@
#
PORTNAME= denyhosts
-PORTVERSION= 2.2
+DISTVERSION= 2.4b
CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
-DISTNAME= DenyHosts-${PORTVERSION}
+DISTNAME= DenyHosts-${DISTVERSION}
MAINTAINER= janos.mohacsi@bsd.hu
COMMENT= Script to thwart ssh attacks
@@ -18,10 +18,12 @@ COMMENT= Script to thwart ssh attacks
USE_PYTHON= yes
USE_PYDISTUTILS= yes
+USE_RC_SUBR= denyhosts
+
DOC_FILES= CHANGELOG.txt LICENSE.txt README.txt
pre-configure:
- ${REINPLACE_CMD} -e 's,%%PREFIX%%,${PREFIX},' \
+ @${REINPLACE_CMD} -e 's,%%PREFIX%%,${PREFIX},' \
${WRKSRC}/daemon-control-dist \
${WRKSRC}/denyhosts.cfg-dist \
${WRKSRC}/setup.py
@@ -33,6 +35,6 @@ post-install:
@${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
.endfor
.endif
- @${CAT} ${PKGMESSAGE}
+ @${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>
diff --git a/security/denyhosts/distinfo b/security/denyhosts/distinfo
index 2fad049f45b6..60f84300d4e1 100644
--- a/security/denyhosts/distinfo
+++ b/security/denyhosts/distinfo
@@ -1,3 +1,3 @@
-MD5 (DenyHosts-2.2.tar.gz) = feba0e9a48dbf1fa9cbd2b5b8907f349
-SHA256 (DenyHosts-2.2.tar.gz) = 369d37528287550ae152b2cd553549c021dab3c5a6b15fea93656749e7559bfd
-SIZE (DenyHosts-2.2.tar.gz) = 40972
+MD5 (DenyHosts-2.4b.tar.gz) = c60df73b29baeadffbbb1ef8f130dd8d
+SHA256 (DenyHosts-2.4b.tar.gz) = 851a050c6eb78618605eecdfae80a1ac412b2adc99160fb9c9d275f64858a7c1
+SIZE (DenyHosts-2.4b.tar.gz) = 42206
diff --git a/security/denyhosts/files/denyhosts.in b/security/denyhosts/files/denyhosts.in
new file mode 100644
index 000000000000..1524c48ef328
--- /dev/null
+++ b/security/denyhosts/files/denyhosts.in
@@ -0,0 +1,23 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+# PROVIDE: denyhosts
+# REQUIRE: DAEMON
+#
+
+. %%RC_SUBR%%
+
+name="denyhosts"
+rcvar=${name}_enable
+
+command="%%PREFIX%%/bin/denyhosts.py"
+command_interpreter="/usr/local/bin/python"
+command_args="--config %%PREFIX%%/etc/denyhosts.conf --daemon"
+pidfile="/var/run/${name}.pid"
+
+load_rc_config $name
+
+: ${denyhosts_enable="NO"}
+
+run_rc_command "$1"
diff --git a/security/denyhosts/files/patch-denyhosts.cfg-dist b/security/denyhosts/files/patch-denyhosts.cfg-dist
index 5505eb82602b..ab162d6a66ab 100644
--- a/security/denyhosts/files/patch-denyhosts.cfg-dist
+++ b/security/denyhosts/files/patch-denyhosts.cfg-dist
@@ -1,8 +1,5 @@
-
-$FreeBSD$
-
---- denyhosts.cfg-dist.orig
-+++ denyhosts.cfg-dist
+--- denyhosts.cfg-dist.orig Sun Apr 9 14:37:46 2006
++++ denyhosts.cfg-dist Fri May 5 11:37:13 2006
@@ -9,10 +9,10 @@
# argument
#
@@ -16,7 +13,16 @@ $FreeBSD$
#
# SuSE:
#SECURE_LOG = /var/log/messages
-@@ -23,7 +23,7 @@
+@@ -22,7 +22,7 @@
+ #SECURE_LOG = /private/var/log/asl.log
+ #
+ # Mac OS X (v10.3 or earlier):
+-SECURE_LOG=/private/var/log/system.log
++#SECURE_LOG=/private/var/log/system.log
+ #
+ ########################################################################
+
+@@ -31,7 +31,7 @@
# HOSTS_DENY: the file which contains restricted host access information
#
# Most operating systems:
@@ -25,7 +31,7 @@ $FreeBSD$
#
# Some BSD (FreeBSD) Unixes:
#HOSTS_DENY = /etc/hosts.allow
-@@ -66,7 +66,7 @@
+@@ -90,7 +90,7 @@
# To block all services for the offending host:
#BLOCK_SERVICE = ALL
# To block only sshd:
@@ -34,7 +40,7 @@ $FreeBSD$
# To only record the offending host and nothing else (if using
# an auxilary file to list the hosts). Refer to:
# http://denyhosts.sourceforge.net/faq.html#aux
-@@ -126,7 +126,7 @@
+@@ -150,7 +150,7 @@
# Note: it is recommended that you use an absolute pathname
# for this value (eg. /home/foo/denyhosts/data)
#
@@ -43,7 +49,7 @@ $FreeBSD$
#
#######################################################################
-@@ -152,7 +152,7 @@
+@@ -176,7 +176,7 @@
# the corresponding hostname will be looked up and reported as well
# (if available).
#
@@ -52,7 +58,7 @@ $FreeBSD$
#
######################################################################
-@@ -168,10 +168,10 @@
+@@ -192,10 +192,10 @@
# running at a time.
#
# Redhat/Fedora:
diff --git a/security/denyhosts/pkg-plist b/security/denyhosts/pkg-plist
index a6d7618f95bf..256020e1c602 100644
--- a/security/denyhosts/pkg-plist
+++ b/security/denyhosts/pkg-plist
@@ -29,6 +29,9 @@ bin/denyhosts.py
%%PYTHON_SITELIBDIR%%/DenyHosts/plugin.py
%%PYTHON_SITELIBDIR%%/DenyHosts/plugin.pyc
%%PYTHON_SITELIBDIR%%/DenyHosts/plugin.pyo
+%%PYTHON_SITELIBDIR%%/DenyHosts/purgecounter.py
+%%PYTHON_SITELIBDIR%%/DenyHosts/purgecounter.pyc
+%%PYTHON_SITELIBDIR%%/DenyHosts/purgecounter.pyo
%%PYTHON_SITELIBDIR%%/DenyHosts/constants.py
%%PYTHON_SITELIBDIR%%/DenyHosts/constants.pyc
%%PYTHON_SITELIBDIR%%/DenyHosts/constants.pyo
d class='commitgraph'>* print/hplip-plugin: sync RESTRICTED with ports/LEGALmakc2014-07-281-1/+1 * Turn SDK option on by default to unbreak print/cups-filtersantoine2014-07-271-0/+2 * print/qpdf: update 5.1.1 -> 5.1.2robak2014-07-263-33/+37 * - Update from 20140714 to 20140725danilo2014-07-253-3/+16 * - Update from 2.0.0 to 2.3.8danilo2014-07-255-147/+95 * - Add stage supportdanilo2014-07-251-18/+14 * - Update from 5.2.8 to 5.2.10danilo2014-07-2514-53/+681 * Reset maintainership for ports not staged with no pending PRbapt2014-07-2525-25/+25 * Support stagebapt2014-07-251-9/+3 * Support stagebapt2014-07-241-3/+2 * Finish some removalsantoine2014-07-231-2/+0 * Remove some teTeX bitsbapt2014-07-2320-379/+0 * Continue decomissioning teTeXbapt2014-07-23102-21787/+0 * Update texi2dvi to latest versionjohans2014-07-232-3/+3 * Start decomissioning some latex portsbapt2014-07-2359-1417/+0 * - Replace security/gnutls with security/gnutls3 and update to 3.2.15tijl2014-07-231-1/+1 * Deprecate some ports BROKEN for more than 6 monthsantoine2014-07-231-0/+2 * Fix build with texlivebapt2014-07-221-0/+1 * Fix typobapt2014-07-221-1/+1 * Fix build on headbapt2014-07-221-0/+1 * Fix LIB_DEPENDSantoine2014-07-211-1/+1 * Remove print/ifxetex in two weeks per maintainer recommendationmarino2014-07-211-0/+3 * Fix LIB_DEPENDSantoine2014-07-211-1/+1 * Remove libtool .la files from all Qt portstijl2014-07-192-1/+1 * print/hplip-plugin:makc2014-07-191-10/+5 * Remove indefinite articles and trailing periods from COMMENT, plusolgeni2014-07-1747-47/+47 * Update to 2.1.1.rakuco2014-07-174-5/+18 * Fix some non default LIB_DEPENDSbapt2014-07-162-6/+6 * Add DOCS option for ports with PORTDOCS in plist.adamw2014-07-163-4/+7 * Correct all instances where OPTIONS_DEFINE was being overwrittenadamw2014-07-162-4/+0 * Add DOCS to OPTIONS_DEFINE to ports that check for PORT_OPTIONS:MDOCS.adamw2014-07-163-0/+6 * - Update from 20140706 to 20140714danilo2014-07-153-7/+31 * Modernize LIB_DEPENDSbapt2014-07-156-13/+13 * - Update to 2.19.10gahr2014-07-142-5/+4 * - Convert to USES=libtooltijl2014-07-093-7/+6 * - Convert to USES=libtool and INSTALL_TARGET=install-striptijl2014-07-092-23/+9 * - Convert print/pslib to USES=libtool and bump dependent portstijl2014-07-093-9/+10 * - USES=libtool tar:bzip2tijl2014-07-092-279/+19 * - Update from 20140627 to 20140706 [1]danilo2014-07-083-6/+10 * Update to 0.7.2; use staging; add licensebf2014-07-072-15/+23 * Stagify.vanilla2014-07-073-29/+11 * Stagify, use options helper function.vanilla2014-07-071-23/+8 * Stagify, use shebangfix to fix bash path.vanilla2014-07-071-13/+8 * 1: Stagify.vanilla2014-07-072-18/+17 * - Try to override FCLIST so configure doesn't invoke fc-list and a cache is notgahr2014-07-071-1/+2 * Add missing patch.vanilla2014-07-071-0/+65 * Update to 1.8.6 release.ale2014-07-072-11/+11 * Stagify.vanilla2014-07-073-14/+19 * Stagify.vanilla2014-07-072-7/+2 * remove NO_STAGE.vanilla2014-07-071-1/+0 * - Update to 2.19.9gahr2014-07-072-3/+3 * 1: Stagify.vanilla2014-07-071-2/+1 * 1: Stagify.vanilla2014-07-073-109/+102 * Stagify.vanilla2014-07-072-6/+3 * - Add staging supportpawel2014-07-072-6/+7 * Add staging supportpawel2014-07-071-18/+13 * - Add staging supportpawel2014-07-071-7/+4 * indexinfo is lighter and does a better job that texinfo-litebapt2014-07-075-130/+0 * - Add staging supportpawel2014-07-071-10/+7 * Add staging supportpawel2014-07-062-11/+9 * - Add staging supportpawel2014-07-062-13/+20 * - Port is stage safepawel2014-07-061-2/+1 * - Add staging support, allow it as regular userpawel2014-07-064-11/+12 * Add staging supportpawel2014-07-061-3/+5 * - Add LICENSE (GPLv2)nivit2014-07-063-126/+119 * Remove NOPORTDOCS.adamw2014-07-053-6/+6 * Convert textproc/aspell to "USES=libtool tar:bzip2" and bump dependent portstijl2014-07-052-1/+2 * Support stage for texlive, given it is impossible to rebuild the fmt files intobapt2014-07-0518-57/+74 * Attempt to unbreak on freebsd < 10, the desthack was not properly quotedantoine2014-07-043-0/+33 * . fix build:bsam2014-07-032-1/+14 * . support STAGE;bsam2014-07-032-4/+4 * Switch to use rpm 4 as the default rpmbapt2014-07-031-2/+2 * Revert staging teTeX doesn't seems to behave the same when make stage is run ...bapt2014-07-032-147/+101 * print/dvips: Reset maintainer and deprecate interactive portmarino2014-07-031-1/+4 * Support stagebapt2014-07-021-20/+7 * Support stagebapt2014-07-022-37/+27 * Support stagebapt2014-07-022-11/+8 * Support stagebapt2014-07-022-10/+7 * Support stagebapt2014-07-022-101/+147 * Support stagebapt2014-07-021-14/+11 * Support stagebapt2014-07-021-14/+8 * Support stagebapt2014-07-021-17/+6 * Fix incomplete plistbapt2014-07-021-0/+2 * Add forgotten plistbapt2014-07-021-0/+158 * Support stagebapt2014-07-021-36/+9 * Simplify plist handlingbapt2014-07-021-13/+6 * Support stagebapt2014-07-021-13/+7 * Support stagebapt2014-07-022-14/+11 * Support stagebapt2014-07-022-19/+14 * - Update to 1.7.3jhale2014-07-026-92/+210 * Stagify, add orphaned file.kwm2014-07-012-6/+6 * - Support staging [1]jhale2014-06-302-16/+15 * Chase hyphen shlib changebapt2014-06-301-0/+1 * Fix installation/packaging when ${PREFIX}/share/texmf already existed,antoine2014-06-302-2/+12 * print/font-amsfonts: keep pkg-plist sortedpi2014-06-291-1/+1 * print/font-amsfonts: fix for fontconfigpi2014-06-292-2/+4 * - Stage supportmiwi2014-06-281-14/+11 * Support stagebapt2014-06-281-4/+2 * USES= tar:xz libtool:oldverbapt2014-06-281-2/+1 * Convert to libtool:oldverbapt2014-06-281-4/+2 * - Remove editors/emacs21, and editors/emacs22 as they're no longer maintainedashish2014-06-271-1/+0 * - Update from 20140425 to 20140627danilo2014-06-273-94/+118 * Update to 0.2 (fdclosedir is only avaiable on FreeBSD 10+)bapt2014-06-262-3/+3 * print/py-pollyreports: support stagewg2014-06-261-12/+4 * Add a minimal tool to regenerate GNU info page indexesbapt2014-06-264-0/+24 * Allow to build with texinfo from portsantoine2014-06-261-0/+1 * Allow to build with texinfo from portsantoine2014-06-261-1/+1 * Use gmake lite to avoid circular dependency when building on a system thatbapt2014-06-251-1/+1 * Convert GMAKE to MAKE_CMDbapt2014-06-259-18/+18 * Forgot to commit that partbapt2014-06-251-1/+1 * Rename to -lite for consistencybapt2014-06-254-1/+1 * print/typetools: update to 2.101wg2014-06-252-3/+3 * Forgot to change the suffixbapt2014-06-251-1/+1 * Rename to texinfo-minimalbapt2014-06-245-1/+1 * Fix categoriesbapt2014-06-241-1/+1 * Add a stripped fown version of texinfo (only install-info and info) to allowbapt2014-06-245-0/+130 * - Update to 1.0.3jhale2014-06-244-33/+24 * print/detex: Fix typo to pass the Freshports sanity check.rene2014-06-231-2/+2 * Mark as broken: no distinfo providedbapt2014-06-231-1/+1 * Bump PORTREVISION for jbigkit library version bump.tijl2014-06-231-1/+1 * - Stageify.araujo2014-06-221-12/+11 * Unbreakantoine2014-06-211-1/+2 * - Update to 1.9.67sunpoet2014-06-212-4/+3 * - Correctly bump PORTREVISION after previous changesamdmi32014-06-211-1/+1 * Deprecate unmaintained interactive ports for removal in 2 monthsmarino2014-06-212-0/+6 * - Switch to USES=libtool, drop .la filesamdmi32014-06-202-4/+4 * - Switch print/libpaper to USES=libtool, drop .la filesamdmi32014-06-2016-18/+22 * - Convert USE_XZ to USESamdmi32014-06-201-2/+2 * - Support stagingamdmi32014-06-201-11/+9 * Deprecate print/ghostview for removal at end of July 2014marino2014-06-191-0/+3 * - Remove pkg-plist after switch to PYDISTUTILS_AUTOPLISTantoine2014-06-182-498/+2 * - Strip binarymiwi2014-06-172-3/+5 * - Add missing USES=libtool to print/qpdf, drop .la filesamdmi32014-06-173-5/+6 * - Switch to USES=libtool, drop .la filesamdmi32014-06-172-6/+6 * Update texinfo.tex and texi2dvi to latest versionjohans2014-06-172-5/+5 * print/py-reportlab2: update to 2.7wg2014-06-174-48/+26 * - The build process invokes fontforge, which creates $HOME/.FontForge. Let'sgahr2014-06-161-1/+1 * - Update to 2.19.8gahr2014-06-162-3/+3 * - Support stagingjhale2014-06-154-18/+16 * - Enable stagedir supportmva2014-06-15