aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--audio/muse/Makefile2
-rw-r--r--audio/muse/files/patch-src_linklist.h11
-rw-r--r--math/blas/Makefile4
-rw-r--r--security/pam_af/Makefile2
-rw-r--r--security/pam_af/files/patch-common_subr.c11
5 files changed, 27 insertions, 3 deletions
diff --git a/audio/muse/Makefile b/audio/muse/Makefile
index 9c8db8098621..4632f99e3b91 100644
--- a/audio/muse/Makefile
+++ b/audio/muse/Makefile
@@ -13,7 +13,7 @@ CATEGORIES= audio
MASTER_SITES= ftp://ftp.dyne.org/muse/releases/ \
http://www.ljudmila.org/~jaromil/muse/releases/
-MAINTAINER= ssedov@mbsd.msk.ru
+MAINTAINER= stas@FreeBSD.org
COMMENT= Multiple Streaming Engine
LIB_DEPENDS= vorbis.3:${PORTSDIR}/audio/libvorbis \
diff --git a/audio/muse/files/patch-src_linklist.h b/audio/muse/files/patch-src_linklist.h
new file mode 100644
index 000000000000..93ecc15d3e37
--- /dev/null
+++ b/audio/muse/files/patch-src_linklist.h
@@ -0,0 +1,11 @@
+--- src/linklist.h.orig Sun Oct 1 18:28:22 2006
++++ src/linklist.h Sun Oct 1 18:28:52 2006
+@@ -44,7 +44,7 @@
+ bool movedown(int pos);
+ bool moveto(int num, int pos);
+ Entry *pick(int pos);
+- Entry *Linklist::selected();
++ Entry *selected();
+
+ Entry *operator[](int pos) { return pick(pos); };
+
diff --git a/math/blas/Makefile b/math/blas/Makefile
index e0e63a7bd719..f46220c17651 100644
--- a/math/blas/Makefile
+++ b/math/blas/Makefile
@@ -14,13 +14,15 @@ MASTER_SITES= ftp://netlib.bell-labs.com/netlib/blas/ \
DISTNAME= ${PORTNAME}
EXTRACT_SUFX= .tgz
-MAINTAINER= ssedov@mbsd.msk.ru
+MAINTAINER= stas@FreeBSD.org
COMMENT= Basic Linear Algebra, level 1, 2, and 3
CONFLICTS= elmer-mathlibs-1*
USE_LDCONFIG= yes
NO_WRKSUBDIR= yes
+USE_GCC= 2.7+
+WITH_FORTRAN= yes
PLIST_FILES= lib/libblas.a lib/libblas.so lib/libblas.so.1
diff --git a/security/pam_af/Makefile b/security/pam_af/Makefile
index 70556ad8e89e..a5883cc55585 100644
--- a/security/pam_af/Makefile
+++ b/security/pam_af/Makefile
@@ -10,7 +10,7 @@ PORTVERSION= 1.0
CATEGORIES= security
MASTER_SITES= http://mbsd.msk.ru/dist/
-MAINTAINER= ssedov@mbsd.msk.ru
+MAINTAINER= stas@FreeBSD.org
COMMENT= Anti-bruteforce PAM module
USE_BZIP2= yes
diff --git a/security/pam_af/files/patch-common_subr.c b/security/pam_af/files/patch-common_subr.c
new file mode 100644
index 000000000000..807db943817d
--- /dev/null
+++ b/security/pam_af/files/patch-common_subr.c
@@ -0,0 +1,11 @@
+--- common/subr.c.orig Sun Oct 1 18:13:16 2006
++++ common/subr.c Sun Oct 1 18:14:09 2006
+@@ -322,7 +322,7 @@
+ const char *db;
+ char *host;
+ {
+- datum key, data;
++ datum key, data = {NULL, 0};
+ struct myaddrinfo *res0, *res;
+ static hostrule_t hstent;
+ int found = 0;