aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--cad/brlcad/Makefile4
-rw-r--r--devel/boost-libs/Makefile4
-rw-r--r--graphics/darktable/Makefile8
3 files changed, 15 insertions, 1 deletions
diff --git a/cad/brlcad/Makefile b/cad/brlcad/Makefile
index e610f00fe675..61d82fee7658 100644
--- a/cad/brlcad/Makefile
+++ b/cad/brlcad/Makefile
@@ -165,6 +165,10 @@ EXTRA_LIBS= ${PTHREAD_LIBS}
CONFIGURE_ARGS+= --disable-debug --enable-optimized
.endif
+.if ${ARCH} == "sparc64"
+BROKEN= Does not compile on sparc64: invokes i386 assembler
+.endif
+
post-patch:
${REINPLACE_CMD} "s+-exact Tcl 8\.5\.1+Tcl 8.5+" ${WRKSRC}/src/other/tcl/library/init.tcl
diff --git a/devel/boost-libs/Makefile b/devel/boost-libs/Makefile
index c9d3bd2e023f..144f464ff428 100644
--- a/devel/boost-libs/Makefile
+++ b/devel/boost-libs/Makefile
@@ -32,6 +32,10 @@ LIB_DEPENDS+= icuuc:${PORTSDIR}/devel/icu
BJAM_OPTIONS+= -sICU_PATH=${LOCALBASE}
.endif
+.if ${ARCH} == "sparc64"
+BROKEN= Does not compile on sparc64: invokes i386 assembler
+.endif
+
post-patch: customize-boost-build
# The following directory is empty and causes issues with pkg_{add,delete}
${RMDIR} ${WRKSRC}/boost/interprocess/containers/detail
diff --git a/graphics/darktable/Makefile b/graphics/darktable/Makefile
index ac89757206ce..64ee7672c2d3 100644
--- a/graphics/darktable/Makefile
+++ b/graphics/darktable/Makefile
@@ -57,4 +57,10 @@ post-patch:
# Do not install useless documentation files
@${REINPLACE_CMD} -e 's, install-dtdocDATA,,' ${WRKSRC}/Makefile.in
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "sparc64"
+BROKEN= Does not compile on sparc64: invokes i386 assembler
+.endif
+
+.include <bsd.port.post.mk>