aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--games/Makefile1
-rw-r--r--games/xtgyoretsu/Makefile31
-rw-r--r--games/xtgyoretsu/distinfo2
-rw-r--r--games/xtgyoretsu/pkg-descr9
4 files changed, 43 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index 449e66c45ed0..4acc45db1e5a 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -1142,6 +1142,7 @@
SUBDIR += xspringies
SUBDIR += xteddy
SUBDIR += xtet42
+ SUBDIR += xtgyoretsu
SUBDIR += xtic
SUBDIR += xtriangles
SUBDIR += xtris
diff --git a/games/xtgyoretsu/Makefile b/games/xtgyoretsu/Makefile
new file mode 100644
index 000000000000..22fb4f470bec
--- /dev/null
+++ b/games/xtgyoretsu/Makefile
@@ -0,0 +1,31 @@
+# Created by: Dmitry Marakasov <amdmi3@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= xtgyoretsu
+PORTVERSION= git20140822
+CATEGORIES= games
+
+MAINTAINER= amdmi3@FreeBSD.org
+COMMENT= Extended ncurses version of "Renshu-cho gyoretsu"
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+USE_GITHUB= yes
+GH_ACCOUNT= Penguinum
+GH_PROJECT= ${PORTNAME}-forked
+GH_TAGNAME= ${GH_COMMIT}
+GH_COMMIT= d052143
+
+USES= ncurses
+
+PLIST_FILES= bin/${PORTNAME}
+PORTDOCS= *
+
+OPTIONS_DEFINE= DOCS
+
+post-install:
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/Readme ${STAGEDIR}${DOCSDIR}/
+
+.include <bsd.port.mk>
diff --git a/games/xtgyoretsu/distinfo b/games/xtgyoretsu/distinfo
new file mode 100644
index 000000000000..fddc0be77ca1
--- /dev/null
+++ b/games/xtgyoretsu/distinfo
@@ -0,0 +1,2 @@
+SHA256 (xtgyoretsu-git20140822.tar.gz) = 2d01e15d8d0188b46a80bce008409f2525b4e82b38d64f338d1d355fa9544a9f
+SIZE (xtgyoretsu-git20140822.tar.gz) = 15794
diff --git a/games/xtgyoretsu/pkg-descr b/games/xtgyoretsu/pkg-descr
new file mode 100644
index 000000000000..898c5edf0e79
--- /dev/null
+++ b/games/xtgyoretsu/pkg-descr
@@ -0,0 +1,9 @@
+XT gyoretsu - extended ncurses version of "Renshu-cho gyoretsu"
+
+Goal of the game is to clear entire field by matching pairs of
+neighbouring (adjacent or on the same line/column without any other
+numbers in between) numbers, which must be either equal, or their
+sum must be equal to strike out sum.
+
+WWW: https://github.com/Penguinum/xtgyoretsu-forked/
+WWW: http://saahriktu.org/games.html