aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--devel/gobject-introspection/Makefile3
-rw-r--r--devel/gobject-introspection/files/patch-giscanner_scannerlexer.l11
-rw-r--r--devel/gobject-introspection/files/patch-tests_Makefile.in8
3 files changed, 18 insertions, 4 deletions
diff --git a/devel/gobject-introspection/Makefile b/devel/gobject-introspection/Makefile
index 30818f91e878..d06a0d279dad 100644
--- a/devel/gobject-introspection/Makefile
+++ b/devel/gobject-introspection/Makefile
@@ -11,6 +11,9 @@ DIST_SUBDIR= gnome3
MAINTAINER= gnome@FreeBSD.org
COMMENT= Generate interface introspection data for GObject libraries
+LICENSE= GPLv2+ LGPL20+
+LICENSE_COMB= dual
+
# we need cairo otherwise the generated Cairo gir is broken
BUILD_DEPENDS= cairo-trace:graphics/cairo
LIB_DEPENDS= libffi.so:devel/libffi
diff --git a/devel/gobject-introspection/files/patch-giscanner_scannerlexer.l b/devel/gobject-introspection/files/patch-giscanner_scannerlexer.l
new file mode 100644
index 000000000000..178293f90c0d
--- /dev/null
+++ b/devel/gobject-introspection/files/patch-giscanner_scannerlexer.l
@@ -0,0 +1,11 @@
+--- giscanner/scannerlexer.l.orig 2017-04-17 10:01:31 UTC
++++ giscanner/scannerlexer.l
+@@ -164,6 +164,8 @@ stringtext ([^\\\"])|(\\.)
+ "__inline__" { return INLINE; }
+ "__inline" { return INLINE; }
+ "__nonnull" { if (!parse_ignored_macro()) REJECT; }
++"_Nonnull" { /* Ignore */ }
++"_Nullable" { /* Ignore */ }
+ "_Noreturn" { /* Ignore */ }
+ "__signed" { return SIGNED; }
+ "__signed__" { return SIGNED; }
diff --git a/devel/gobject-introspection/files/patch-tests_Makefile.in b/devel/gobject-introspection/files/patch-tests_Makefile.in
index 4edb7bf4dc00..ab3038962a15 100644
--- a/devel/gobject-introspection/files/patch-tests_Makefile.in
+++ b/devel/gobject-introspection/files/patch-tests_Makefile.in
@@ -1,6 +1,6 @@
---- tests/Makefile.in.orig 2011-08-20 13:20:09.000000000 -0400
-+++ tests/Makefile.in 2011-08-20 13:20:26.000000000 -0400
-@@ -820,7 +820,7 @@ everything.h: everything-stamp.h
+--- tests/Makefile.in.orig 2017-04-17 10:01:31 UTC
++++ tests/Makefile.in
+@@ -1257,7 +1257,7 @@ everything.h: everything-stamp.h
@true
Everything-1.0.gir: libeverything-1.0.la Makefile
@@ -9,7 +9,7 @@
--namespace=Everything --nsversion=1.0 \
--libtool="$(LIBTOOL)" \
--add-include-path=$(top_builddir) --include=Gio-2.0 \
-@@ -828,7 +828,7 @@ Everything-1.0.gir: libeverything-1.0.la
+@@ -1266,7 +1266,7 @@ Everything-1.0.gir: libeverything-1.0.la Makefile
everything.h everything.c
GIMarshallingTests-1.0.gir: libgimarshallingtests-1.0.la Makefile