aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--dns/knot2/Makefile1
-rw-r--r--dns/knot2/files/knot.in2
2 files changed, 2 insertions, 1 deletions
diff --git a/dns/knot2/Makefile b/dns/knot2/Makefile
index aad3c1813d40..8bd7dd344953 100644
--- a/dns/knot2/Makefile
+++ b/dns/knot2/Makefile
@@ -3,6 +3,7 @@
PORTNAME= knot
PORTVERSION= 2.2.1
+PORTREVISION?= 1
CATEGORIES= dns ipv6
MASTER_SITES= https://secure.nic.cz/files/knot-dns/ \
http://dns-lab.com/downloads/knot-dns/
diff --git a/dns/knot2/files/knot.in b/dns/knot2/files/knot.in
index 0942d3711367..d502f6a313df 100644
--- a/dns/knot2/files/knot.in
+++ b/dns/knot2/files/knot.in
@@ -90,7 +90,7 @@ knot_prestart()
if [ ! -d /var/db/${name} ]; then
install -d -o ${diruser} -g ${dirgroup} /var/db/${name}
fi
- ${control} -c ${configfile} checkconf
+ ${control} -c ${configfile} conf-check
}
knot_reload()