aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--x11-toolkits/gtk20/Makefile2
-rw-r--r--x11-toolkits/gtk20/files/patch-gdk-pixbuf_io-jpeg.c11
-rw-r--r--x11-toolkits/gtk30/Makefile2
-rw-r--r--x11-toolkits/gtk30/files/patch-gdk-pixbuf_io-jpeg.c11
4 files changed, 24 insertions, 2 deletions
diff --git a/x11-toolkits/gtk20/Makefile b/x11-toolkits/gtk20/Makefile
index dbc76af211da..5517b22d9a88 100644
--- a/x11-toolkits/gtk20/Makefile
+++ b/x11-toolkits/gtk20/Makefile
@@ -8,7 +8,7 @@
PORTNAME= gtk
PORTVERSION= 2.16.5
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES= x11-toolkits
MASTER_SITES= ${MASTER_SITE_GNOME:S,%SUBDIR%,sources/gtk+/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}/,} \
ftp://ftp.gtk.org/pub/gtk/%SUBDIR%/ \
diff --git a/x11-toolkits/gtk20/files/patch-gdk-pixbuf_io-jpeg.c b/x11-toolkits/gtk20/files/patch-gdk-pixbuf_io-jpeg.c
new file mode 100644
index 000000000000..1701b054b402
--- /dev/null
+++ b/x11-toolkits/gtk20/files/patch-gdk-pixbuf_io-jpeg.c
@@ -0,0 +1,11 @@
+--- gdk-pixbuf/io-jpeg.c.orig 2009-07-30 00:54:14.000000000 -0400
++++ gdk-pixbuf/io-jpeg.c 2009-07-30 00:54:27.000000000 -0400
+@@ -922,7 +922,7 @@ gdk_pixbuf__jpeg_image_load_increment (g
+ }
+ }
+
+- for (cinfo->scale_denom = 2; cinfo->scale_denom <= 8; cinfo->scale_denom *= 2) {
++ for (cinfo->scale_denom = 2; cinfo->scale_denom <= 16; cinfo->scale_denom *= 2) {
+ jpeg_calc_output_dimensions (cinfo);
+ if (cinfo->output_width < width || cinfo->output_height < height) {
+ cinfo->scale_denom /= 2;
diff --git a/x11-toolkits/gtk30/Makefile b/x11-toolkits/gtk30/Makefile
index dbc76af211da..5517b22d9a88 100644
--- a/x11-toolkits/gtk30/Makefile
+++ b/x11-toolkits/gtk30/Makefile
@@ -8,7 +8,7 @@
PORTNAME= gtk
PORTVERSION= 2.16.5
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES= x11-toolkits
MASTER_SITES= ${MASTER_SITE_GNOME:S,%SUBDIR%,sources/gtk+/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}/,} \
ftp://ftp.gtk.org/pub/gtk/%SUBDIR%/ \
diff --git a/x11-toolkits/gtk30/files/patch-gdk-pixbuf_io-jpeg.c b/x11-toolkits/gtk30/files/patch-gdk-pixbuf_io-jpeg.c
new file mode 100644
index 000000000000..1701b054b402
--- /dev/null
+++ b/x11-toolkits/gtk30/files/patch-gdk-pixbuf_io-jpeg.c
@@ -0,0 +1,11 @@
+--- gdk-pixbuf/io-jpeg.c.orig 2009-07-30 00:54:14.000000000 -0400
++++ gdk-pixbuf/io-jpeg.c 2009-07-30 00:54:27.000000000 -0400
+@@ -922,7 +922,7 @@ gdk_pixbuf__jpeg_image_load_increment (g
+ }
+ }
+
+- for (cinfo->scale_denom = 2; cinfo->scale_denom <= 8; cinfo->scale_denom *= 2) {
++ for (cinfo->scale_denom = 2; cinfo->scale_denom <= 16; cinfo->scale_denom *= 2) {
+ jpeg_calc_output_dimensions (cinfo);
+ if (cinfo->output_width < width || cinfo->output_height < height) {
+ cinfo->scale_denom /= 2;