aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--databases/Makefile1
-rw-r--r--databases/php5-tarantool/Makefile31
-rw-r--r--databases/php5-tarantool/distinfo2
-rw-r--r--databases/php5-tarantool/pkg-descr3
4 files changed, 37 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 66b756cfe39a..a788d93bcece 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -601,6 +601,7 @@
SUBDIR += php5-redis
SUBDIR += php5-sqlite3
SUBDIR += php5-sybase_ct
+ SUBDIR += php5-tarantool
SUBDIR += php52-dba
SUBDIR += php52-dbase
SUBDIR += php52-interbase
diff --git a/databases/php5-tarantool/Makefile b/databases/php5-tarantool/Makefile
new file mode 100644
index 000000000000..7742bae763cb
--- /dev/null
+++ b/databases/php5-tarantool/Makefile
@@ -0,0 +1,31 @@
+# Created by: Veniamin Gvozdikov <vg@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= tarantool
+PORTVERSION= ${TR_VER}
+CATEGORIES= databases
+MASTER_SITES= GH GHC
+PKGNAMEPREFIX= php5-
+DISTFILES= ${PKGNAMEPREFIX}${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}
+
+MAINTAINER= vg@FreeBSD.org
+COMMENT= PECL PHP driver for Tarantool/Box
+
+USE_GITHUB= yes
+USE_PHP= yes
+USE_PHPEXT= yes
+USE_PHPIZE= yes
+DEFAULT_PHP_VER=5
+
+PHP_MODNAME= ${PORTNAME}
+GH_PROJECT= ${PORTNAME}-php
+GH_ACCOUNT= tarantool
+GH_COMMIT= d88ac7b
+GH_TAGNAME= ${GH_COMMIT}
+TR_VER= 20131031
+
+CONFIGURE_ARGS+= --with-tarantool
+
+NO_STAGE= yes
+
+.include <bsd.port.mk>
diff --git a/databases/php5-tarantool/distinfo b/databases/php5-tarantool/distinfo
new file mode 100644
index 000000000000..68938a88053a
--- /dev/null
+++ b/databases/php5-tarantool/distinfo
@@ -0,0 +1,2 @@
+SHA256 (php5-tarantool-20131031.tar.gz) = 3671e3c134de0fa225199afca9414931e8b0773b3ffa04f501c71cbc52ff21b2
+SIZE (php5-tarantool-20131031.tar.gz) = 21000
diff --git a/databases/php5-tarantool/pkg-descr b/databases/php5-tarantool/pkg-descr
new file mode 100644
index 000000000000..9aa49257161f
--- /dev/null
+++ b/databases/php5-tarantool/pkg-descr
@@ -0,0 +1,3 @@
+PECL PHP driver for Tarantool/Box
+
+WWW: https://github.com/tarantool/tarantool-php