aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--lang/bas2tap/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/lang/bas2tap/Makefile b/lang/bas2tap/Makefile
index f18d639fa91b..87f34393f55d 100644
--- a/lang/bas2tap/Makefile
+++ b/lang/bas2tap/Makefile
@@ -18,12 +18,14 @@ NO_WRKSUBDIR= yes
PORTDOCS= ${PORTNAME}.doc
PLIST_FILES= bin/${PORTNAME}
+.include <bsd.port.options.mk>
+
do-build:
${CC} ${WRKSRC}/${PORTNAME}.c -o ${WRKSRC}/${PORTNAME} -lm ${CFLAGS}
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
-.ifndef NOPORTDOCS
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
.for file in ${PORTDOCS}
${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}