aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--net/phamm/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/net/phamm/Makefile b/net/phamm/Makefile
index e757ebac9744..99c34e9df711 100644
--- a/net/phamm/Makefile
+++ b/net/phamm/Makefile
@@ -3,6 +3,7 @@
PORTNAME= phamm
PORTVERSION= 0.5.18
+PORTREVISION= 1
CATEGORIES= net www
MASTER_SITES= http://open.rhx.it/phamm/
@@ -12,8 +13,10 @@ COMMENT= Front-end written in PHP to manage virtual service
NO_BUILD= yes
USE_PHP= gettext ldap openssl pcre session
-USES= gettext
-
+USES= gettext shebangfix
+SHEBANG_FILES= po/update-all-mo.sh \
+ tools/*.sh tools/*.pl \
+ tools/ldap-schema-manage
PHAMMDIR?= www/${PORTNAME}
SCHEMADIR= ${WRKSRC}/schema
@@ -25,8 +28,6 @@ PORTDOCS= CHANGELOG INSTALL README LICENSE THANKS
OPTIONS_DEFINE= DOCS
-.include <bsd.port.pre.mk>
-
do-install:
@${MKDIR} ${STAGEDIR}${PREFIX}/${PHAMMDIR}
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
@@ -42,4 +43,4 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}
.endfor
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>