aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Test-Fatal/Makefile24
-rw-r--r--devel/p5-Test-Fatal/distinfo2
-rw-r--r--devel/p5-Test-Fatal/pkg-descr7
-rw-r--r--devel/p5-Test-Fatal/pkg-plist5
5 files changed, 39 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 8f40c8c48ea9..5305e58acc58 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -2217,6 +2217,7 @@
SUBDIR += p5-Test-Distribution
SUBDIR += p5-Test-Exception
SUBDIR += p5-Test-Expect
+ SUBDIR += p5-Test-Fatal
SUBDIR += p5-Test-File
SUBDIR += p5-Test-File-Contents
SUBDIR += p5-Test-Fixture-DBIC-Schema
diff --git a/devel/p5-Test-Fatal/Makefile b/devel/p5-Test-Fatal/Makefile
new file mode 100644
index 000000000000..17881fdc2af4
--- /dev/null
+++ b/devel/p5-Test-Fatal/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: devel/p5-Test-Fatal
+# Date created: 2010-11-15
+# Whom: Frederic Culot <culot@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Test-Fatal
+PORTVERSION= 0.003
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= culot@FreeBSD.org
+COMMENT= Incredibly simple helpers for testing code with exceptions
+
+BUILD_DEPENDS= p5-Try-Tiny>=0.07:${PORTSDIR}/lang/p5-Try-Tiny
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Test::Fatal.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Test-Fatal/distinfo b/devel/p5-Test-Fatal/distinfo
new file mode 100644
index 000000000000..90d67d1d4ea3
--- /dev/null
+++ b/devel/p5-Test-Fatal/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Test-Fatal-0.003.tar.gz) = 2725dbddf64a1c6f3a5bf29dc15d167d881716ec35b2abd6e05c05b537f65184
+SIZE (Test-Fatal-0.003.tar.gz) = 11256
diff --git a/devel/p5-Test-Fatal/pkg-descr b/devel/p5-Test-Fatal/pkg-descr
new file mode 100644
index 000000000000..422ec926863b
--- /dev/null
+++ b/devel/p5-Test-Fatal/pkg-descr
@@ -0,0 +1,7 @@
+Test::Fatal is an alternative to the popular Test::Exception.
+It does much less, but should allow greater flexibility in
+testing exception-throwing code with about the same amount of
+typing.
+
+
+WWW: http://search.cpan.org/dist/Test-Fatal/
diff --git a/devel/p5-Test-Fatal/pkg-plist b/devel/p5-Test-Fatal/pkg-plist
new file mode 100644
index 000000000000..a16c02e6269f
--- /dev/null
+++ b/devel/p5-Test-Fatal/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Test/Fatal.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/Fatal/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/Fatal
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Test
+@dirrmtry %%SITE_PERL%%/Test