aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--audio/faac/Makefile2
-rw-r--r--audio/faad/Makefile2
-rw-r--r--audio/mp3blaster/Makefile2
-rw-r--r--audio/volumeicon/Makefile2
-rw-r--r--biology/iqtree/Makefile7
-rw-r--r--cad/alliance/Makefile1
-rw-r--r--cad/freehdl/Makefile2
-rw-r--r--cad/meshlab/Makefile9
-rw-r--r--cad/repsnapper/Makefile7
-rw-r--r--chinese/ibus-libpinyin/Makefile2
-rw-r--r--comms/sunxi-tools/Makefile5
11 files changed, 30 insertions, 11 deletions
diff --git a/audio/faac/Makefile b/audio/faac/Makefile
index 84d3298ef053..d2626be9bc98 100644
--- a/audio/faac/Makefile
+++ b/audio/faac/Makefile
@@ -17,6 +17,8 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LICENSE_FILE_ISO= ${WRKSRC}/README
LICENSE_PERMS_ISO= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
+BROKEN_powerpc64= fails to build: quantize.c:152: error: initializer element is not constant
+
USES= gmake libtool
INSTALL_TARGET= install-strip
GNU_CONFIGURE= yes
diff --git a/audio/faad/Makefile b/audio/faad/Makefile
index fcb6b7d082d6..c6e86aa4ff42 100644
--- a/audio/faad/Makefile
+++ b/audio/faad/Makefile
@@ -13,6 +13,8 @@ COMMENT= MPEG-2 and MPEG-4 AAC audio decoder
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
+BROKEN_powerpc64= fails to build: mp4read.o:(.text+0x714): undefined reference to '__builtin_bswap16'
+
USES= autoreconf gmake libtool
INSTALL_TARGET= install-strip
diff --git a/audio/mp3blaster/Makefile b/audio/mp3blaster/Makefile
index e62129e77379..0b473ef17a2f 100644
--- a/audio/mp3blaster/Makefile
+++ b/audio/mp3blaster/Makefile
@@ -13,6 +13,8 @@ COMMENT= MP3 console ncurses-based player
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
+BROKEN_powerpc64= fails to configure: checking for main in -lm... no
+
USES= gmake localbase:ldflags ncurses
GNU_CONFIGURE= yes
CONFIGURE_ENV= CXXFLAGS="${CXXFLAGS} -Wno-narrowing"
diff --git a/audio/volumeicon/Makefile b/audio/volumeicon/Makefile
index e446337fe06b..c56514d36fc4 100644
--- a/audio/volumeicon/Makefile
+++ b/audio/volumeicon/Makefile
@@ -10,6 +10,8 @@ COMMENT= Lightweight volume control for the systray
LICENSE= GPLv3
+BROKEN_powerpc64= fails to build: oss3_backend.c:80: 'for' loop initial declaration used outside C99 mode
+
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-oss=v3 \
--with-oss-include-path=/usr/include/sys
diff --git a/biology/iqtree/Makefile b/biology/iqtree/Makefile
index e140a345ba35..6f2ddc8d6868 100644
--- a/biology/iqtree/Makefile
+++ b/biology/iqtree/Makefile
@@ -11,9 +11,10 @@ COMMENT= Efficient phylogenomic software by maximum likelihood
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/LICENSE
-BROKEN_aarch64= fails to compile: unrecognized command line option '-msse3'
-BROKEN_armv6= fails to compile: unrecognized command line options '-m32' and '-msse3'
-BROKEN_armv7= fails to compile: unrecognized command line options '-m32' and '-msse3'
+BROKEN_aarch64= fails to compile: unrecognized command line option '-msse3'
+BROKEN_armv6= fails to compile: unrecognized command line options '-m32' and '-msse3'
+BROKEN_armv7= fails to compile: unrecognized command line options '-m32' and '-msse3'
+BROKEN_powerpc64= fails to build: GCC version must be at least 4.8!
USES= cmake compiler:openmp eigen:3
USE_GITHUB= yes
diff --git a/cad/alliance/Makefile b/cad/alliance/Makefile
index 3de3e7d30124..acc97ec88783 100644
--- a/cad/alliance/Makefile
+++ b/cad/alliance/Makefile
@@ -18,6 +18,7 @@ LICENSE_FILE= ${WRKSRC}/LICENCE
LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
BROKEN_aarch64= fails to link: collect2: error: ld returned 1 exit status
+BROKEN_powerpc64= fails to build: cc1plus: error: unrecognized command line option "-std=gnu++03"
CONFLICTS_INSTALL= fspclient-*
diff --git a/cad/freehdl/Makefile b/cad/freehdl/Makefile
index 0f87ad5031f9..562718ca7be9 100644
--- a/cad/freehdl/Makefile
+++ b/cad/freehdl/Makefile
@@ -10,6 +10,8 @@ MASTER_SITES= http://freehdl.seul.org/~enaroska/
MAINTAINER= ports@FreeBSD.org
COMMENT= Free VHDL simulator
+BROKEN_powerpc64= fails to build: cc1plus: error: unrecognized command line option "-std=gnu++03"
+
USES= gmake pathfix libtool makeinfo perl5 pkgconfig
USE_LDCONFIG= yes
USE_GCC= any
diff --git a/cad/meshlab/Makefile b/cad/meshlab/Makefile
index be87ff7bd0c4..6f859088c4f4 100644
--- a/cad/meshlab/Makefile
+++ b/cad/meshlab/Makefile
@@ -13,13 +13,16 @@ COMMENT= 3D triangular meshes processing and editing tool
LICENSE= GPLv2
+BROKEN_aarch64= fails to compile: constant expression evaluates to -1 which cannot be narrowed to type char
+BROKEN_armv6= fails to compile: constant expression evaluates to -1 which cannot be narrowed to type char
+BROKEN_armv7= fails to compile: constant expression evaluates to -1 which cannot be narrowed to type char
+BROKEN_powerpc64= fails to compile: mc_lookup_table.h:316:5: narrowing conversion of '-1' from 'int' to 'char' inside { }
+
EXTRACT_DEPENDS=gtar:archivers/gtar
LIB_DEPENDS= libQtSolutions_SOAP-head.so:devel/qt4-qtsolutions-soap \
libmpir.so:math/mpir
-BROKEN_aarch64= Fails to compile: constant expression evaluates to -1 which cannot be narrowed to type char
-
-USES= dos2unix qmake compiler:c++11-lib tar:tgz
+USES= compiler:c++11-lib dos2unix qmake tar:tgz
USE_CXXSTD= c++11
USE_GL= glew glu
USE_QT4= moc_build rcc_build uic_build corelib gui xml \
diff --git a/cad/repsnapper/Makefile b/cad/repsnapper/Makefile
index ad2f30bfb670..c1da5ce8b16b 100644
--- a/cad/repsnapper/Makefile
+++ b/cad/repsnapper/Makefile
@@ -12,15 +12,16 @@ COMMENT= Controller and GCode generator for RepRap 3D printers
LICENSE= GPLv2 BSD3CLAUSE MIT
LICENSE_COMB= multi
+BROKEN_powerpc64= fails to compile: clipper.hpp:52:10: 'vector' file not found
+
LIB_DEPENDS= libgtkglextmm-x11-1.2.so:x11-toolkits/gtkglextmm \
libpolyclipping.so:graphics/polyclipping \
libzip.so:archivers/libzip
-USE_GITHUB= yes
-GH_ACCOUNT= timschmidt
-
USES= compiler:c++11-lib autoreconf gettext gmake libtool localbase \
perl5 pkgconfig
+USE_GITHUB= yes
+GH_ACCOUNT= timschmidt
USE_GNOME= gtkmm24 intltool libxml++26
USE_GL= gl
USE_PERL5= build
diff --git a/chinese/ibus-libpinyin/Makefile b/chinese/ibus-libpinyin/Makefile
index 2137785d4524..864bec896235 100644
--- a/chinese/ibus-libpinyin/Makefile
+++ b/chinese/ibus-libpinyin/Makefile
@@ -12,6 +12,8 @@ COMMENT= Intelligent Pinyin engine based on libpinyin for IBus
LICENSE= GPLv2
+BROKEN_powerpc64= fails to compile: PYLibPinyin.cc:222:54: 'getline' was not declared in this scope
+
LIB_DEPENDS= libsqlite3.so:databases/sqlite3 \
libibus-1.0.so:textproc/ibus \
libpinyin.so:chinese/libpinyin
diff --git a/comms/sunxi-tools/Makefile b/comms/sunxi-tools/Makefile
index 747e139d9c0a..ef2d5821d765 100644
--- a/comms/sunxi-tools/Makefile
+++ b/comms/sunxi-tools/Makefile
@@ -11,9 +11,10 @@ COMMENT= Tools to help hacking Allwinner devices
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/LICENSE.md
-USE_GITHUB= yes
-GH_ACCOUNT= linux-sunxi
+BROKEN_powerpc64= fails to build: unrecognized command line option "-Wno-unused-result"
USES= gmake pkgconfig
+USE_GITHUB= yes
+GH_ACCOUNT= linux-sunxi
.include <bsd.port.mk>