aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--games/nil/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/games/nil/Makefile b/games/nil/Makefile
index 48bbc9d15b77..08dd80ee197b 100644
--- a/games/nil/Makefile
+++ b/games/nil/Makefile
@@ -26,6 +26,13 @@ OPTIONS= OPTIMIZED_CFLAGS "Enable compilation optimizations" on
.include <bsd.port.pre.mk>
+.if ${ARCH} == "ia64"
+BROKEN= does not link on ${ARCH}
+.endif
+.if ${ARCH} == "i386" && ${OSVERSION} < 500000
+BROKEN= does not compile
+.endif
+
post-patch:
@${FIND} ${WRKSRC} -type f -name configure -print0 | ${XARGS} -0 \
${REINPLACE_CMD} -e \