aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--sysutils/sge/Makefile8
-rw-r--r--sysutils/sge60/Makefile8
-rw-r--r--sysutils/sge61/Makefile8
-rw-r--r--sysutils/sge62/Makefile8
4 files changed, 32 insertions, 0 deletions
diff --git a/sysutils/sge/Makefile b/sysutils/sge/Makefile
index dc13c4230eaa..d0071759c58a 100644
--- a/sysutils/sge/Makefile
+++ b/sysutils/sge/Makefile
@@ -92,6 +92,14 @@ EXCEPTFILES= arc_depend_irix.asc arc_depend_solaris.asc man testsuite
.include <bsd.port.pre.mk>
+.if ${OSVERSION} < 503000
+.if ${OSVERSION} < 500000
+BROKEN= "Does not build without libpthread"
+.else
+IGNORE= "Not supported for FreeBSD < 5.3"
+.endif
+.endif
+
.if defined(WITH_BDB)
LIB_DEPENDS= db-4.2:${PORTSDIR}/databases/db42
PLIST_SUB+= BDB_SPOOL=
diff --git a/sysutils/sge60/Makefile b/sysutils/sge60/Makefile
index dc13c4230eaa..d0071759c58a 100644
--- a/sysutils/sge60/Makefile
+++ b/sysutils/sge60/Makefile
@@ -92,6 +92,14 @@ EXCEPTFILES= arc_depend_irix.asc arc_depend_solaris.asc man testsuite
.include <bsd.port.pre.mk>
+.if ${OSVERSION} < 503000
+.if ${OSVERSION} < 500000
+BROKEN= "Does not build without libpthread"
+.else
+IGNORE= "Not supported for FreeBSD < 5.3"
+.endif
+.endif
+
.if defined(WITH_BDB)
LIB_DEPENDS= db-4.2:${PORTSDIR}/databases/db42
PLIST_SUB+= BDB_SPOOL=
diff --git a/sysutils/sge61/Makefile b/sysutils/sge61/Makefile
index dc13c4230eaa..d0071759c58a 100644
--- a/sysutils/sge61/Makefile
+++ b/sysutils/sge61/Makefile
@@ -92,6 +92,14 @@ EXCEPTFILES= arc_depend_irix.asc arc_depend_solaris.asc man testsuite
.include <bsd.port.pre.mk>
+.if ${OSVERSION} < 503000
+.if ${OSVERSION} < 500000
+BROKEN= "Does not build without libpthread"
+.else
+IGNORE= "Not supported for FreeBSD < 5.3"
+.endif
+.endif
+
.if defined(WITH_BDB)
LIB_DEPENDS= db-4.2:${PORTSDIR}/databases/db42
PLIST_SUB+= BDB_SPOOL=
diff --git a/sysutils/sge62/Makefile b/sysutils/sge62/Makefile
index dc13c4230eaa..d0071759c58a 100644
--- a/sysutils/sge62/Makefile
+++ b/sysutils/sge62/Makefile
@@ -92,6 +92,14 @@ EXCEPTFILES= arc_depend_irix.asc arc_depend_solaris.asc man testsuite
.include <bsd.port.pre.mk>
+.if ${OSVERSION} < 503000
+.if ${OSVERSION} < 500000
+BROKEN= "Does not build without libpthread"
+.else
+IGNORE= "Not supported for FreeBSD < 5.3"
+.endif
+.endif
+
.if defined(WITH_BDB)
LIB_DEPENDS= db-4.2:${PORTSDIR}/databases/db42
PLIST_SUB+= BDB_SPOOL=