aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--astro/Makefile1
-rw-r--r--astro/phoon/Makefile26
-rw-r--r--astro/phoon/distinfo1
-rw-r--r--astro/phoon/files/patch-Makefile33
-rw-r--r--astro/phoon/pkg-descr8
-rw-r--r--astro/phoon/pkg-plist1
6 files changed, 70 insertions, 0 deletions
diff --git a/astro/Makefile b/astro/Makefile
index 6025e8e47991..a0574ab1d6e2 100644
--- a/astro/Makefile
+++ b/astro/Makefile
@@ -32,6 +32,7 @@
SUBDIR += p5-GPS
SUBDIR += p5-Geo-METAR
SUBDIR += p5-SETI-Stats
+ SUBDIR += phoon
SUBDIR += planets
SUBDIR += py-metar
SUBDIR += pyweather
diff --git a/astro/phoon/Makefile b/astro/phoon/Makefile
new file mode 100644
index 000000000000..64ba2bf5ede6
--- /dev/null
+++ b/astro/phoon/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: phoon
+# Date created: 14 May 2003
+# Whom: Kirill Ponomarew <ponomarew@oberon.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= phoon
+PORTVERSION= 2003
+CATEGORIES= astro
+MASTER_SITES= http://www.acme.com/software/phoon/
+PKGNAMESUFFIX= _20jan
+DISTNAME= ${PORTNAME}${PKGNAMESUFFIX}${PORTVERSION}
+
+MAINTAINER= ponomarew@oberon.net
+COMMENT= Phoon displays the phase of the moon
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+USE_REINPLACE= yes
+MAN1= phoon.1
+
+pre-patch:
+ @${REINPLACE_CMD} -e 's|gmtoff = !!!;||g' \
+ ${WRKSRC}/date_parse.c
+
+.include <bsd.port.mk>
diff --git a/astro/phoon/distinfo b/astro/phoon/distinfo
new file mode 100644
index 000000000000..36fb154c48f8
--- /dev/null
+++ b/astro/phoon/distinfo
@@ -0,0 +1 @@
+MD5 (phoon_20jan2003.tar.gz) = 843ee16af4b50c53688f24c24169425b
diff --git a/astro/phoon/files/patch-Makefile b/astro/phoon/files/patch-Makefile
new file mode 100644
index 000000000000..93a0a4c417d7
--- /dev/null
+++ b/astro/phoon/files/patch-Makefile
@@ -0,0 +1,33 @@
+--- Makefile.orig Thu May 15 09:07:10 2003
++++ Makefile Thu May 15 09:08:24 2003
+@@ -1,13 +1,13 @@
+ # Makefile for phoon
+
+-BINDIR = /usr/local/bin
+-MANDIR = /usr/local/man/man1
++BINDIR = ${PREFIX}/bin
++MANDIR = ${MANPREFIX}/man/man1
+
+ DEFINES = -DOS_BSD
+ #DEFINES = -DOS_SYSV
+
+-CC = gcc
+-CFLAGS = -O $(DEFINES)
++CC ?= gcc
++CFLAGS ?= ${CFLAGS}
+
+ LDFLAGS = -s
+
+@@ -15,10 +15,10 @@
+ all: phoon
+
+ phoon: phoon.o date_parse.o astro.o
+- $(CC) $(LDFLAGS) -o phoon phoon.o date_parse.o astro.o -lm
++ ${CC} $(LDFLAGS) -o phoon phoon.o date_parse.o astro.o -lm
+
+ .c.o:
+- $(CC) $(CFLAGS) -c $<
++ ${CC} $(CFLAGS) -c $<
+
+ date_parse.o: date_parse.h
+ astro.o: astro.h
diff --git a/astro/phoon/pkg-descr b/astro/phoon/pkg-descr
new file mode 100644
index 000000000000..0f0f9d318995
--- /dev/null
+++ b/astro/phoon/pkg-descr
@@ -0,0 +1,8 @@
+Phoon displays the phase of the moon, either currently or at a
+specified date / time. Unlike other such programs, which just
+tell you how long since first quarter or something like that,
+phoon shows you the phase with a cute little picture. You can
+vary the size of the picture with the -l flag, but only some
+sizes have pictures defined - other sizes use @'s.
+
+WWW: http://www.acme.com/software/phoon
diff --git a/astro/phoon/pkg-plist b/astro/phoon/pkg-plist
new file mode 100644
index 000000000000..5eb4bd93db65
--- /dev/null
+++ b/astro/phoon/pkg-plist
@@ -0,0 +1 @@
+bin/phoon