aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--astro/Makefile1
-rw-r--r--astro/gdesklets-goodweather-psi/Makefile44
-rw-r--r--astro/gdesklets-goodweather-psi/distinfo2
-rw-r--r--astro/gdesklets-goodweather-psi/files/pkg-message.in13
-rw-r--r--astro/gdesklets-goodweather-psi/pkg-descr3
5 files changed, 63 insertions, 0 deletions
diff --git a/astro/Makefile b/astro/Makefile
index 97bceb22fde5..85f127c34b90 100644
--- a/astro/Makefile
+++ b/astro/Makefile
@@ -11,6 +11,7 @@
SUBDIR += ephem
SUBDIR += fooseti
SUBDIR += gdesklets-goodweather
+ SUBDIR += gdesklets-goodweather-psi
SUBDIR += gdesklets-seti
SUBDIR += gdesklets-weather
SUBDIR += gkrellmearth
diff --git a/astro/gdesklets-goodweather-psi/Makefile b/astro/gdesklets-goodweather-psi/Makefile
new file mode 100644
index 000000000000..48d8ee169c17
--- /dev/null
+++ b/astro/gdesklets-goodweather-psi/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: gdesklets-goodweather-psi
+# Date created: 17 November 2003
+# Whom: Mezz <mezz7@cox.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= goodweather
+PORTVERSION= 0.1
+CATEGORIES= astro gnome
+MASTER_SITES= http://gdesklets.gnomedesktop.org/files/
+PKGNAMEPREFIX= gdesklets-
+PKGNAMESUFFIX= -psi
+DISTNAME= GoodWeather-psi
+
+MAINTAINER= ahze@ahze.net
+COMMENT= A desklet that displays current weather condition and forecast
+
+RUN_DEPENDS= ${X11BASE}/share/gnome/gdesklets/Sensors/GoodWeather/__init__.py:${PORTSDIR}/astro/gdesklets-goodweather \
+ ${X11BASE}/share/gnome/gdesklets/Themes/Psi-Disp-Themes/backgrounds/dark/bg.png:${PORTSDIR}/deskutils/gdesklets-psi_themes
+
+NO_BUILD= yes
+USE_BZIP2= yes
+USE_X_PREFIX= yes
+USE_REINPLACE= yes
+PLIST_FILES= %%DATADIR%%/gdesklets/Displays/${NAME}/gfx/bg-bar.png \
+ %%DATADIR%%/gdesklets/Displays/${NAME}/GoodWeather-psi.display
+PLIST_DIRS= %%DATADIR%%/gdesklets/Displays/${NAME}/gfx \
+ %%DATADIR%%/gdesklets/Displays/${NAME}
+
+NAME= GoodWeather-psi
+WRKSRC= ${WRKDIR}/${NAME}
+DATADIR= ${PREFIX}/share/gnome
+PKGMESSAGE= ${WRKDIR}/pkg-message
+
+do-install:
+ @${MKDIR} ${DATADIR}/gdesklets/Displays/${NAME}/gfx
+ @${INSTALL_DATA} ${WRKSRC}/gfx/*.png ${DATADIR}/gdesklets/Displays/${NAME}/gfx/
+ @${INSTALL_DATA} ${WRKSRC}/${NAME}.display ${DATADIR}/gdesklets/Displays/${NAME}/
+ @${SED} -e 's|%%PREFIX%%|${PREFIX}|g ; s|%%NAME%%|${NAME}|g' \
+ ${FILESDIR}/pkg-message.in > ${PKGMESSAGE}
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/astro/gdesklets-goodweather-psi/distinfo b/astro/gdesklets-goodweather-psi/distinfo
new file mode 100644
index 000000000000..973236d77982
--- /dev/null
+++ b/astro/gdesklets-goodweather-psi/distinfo
@@ -0,0 +1,2 @@
+MD5 (GoodWeather-psi.tar.bz2) = 74ecf90f7c2f01f96e41a8c0416eaa23
+SIZE (GoodWeather-psi.tar.bz2) = 1335
diff --git a/astro/gdesklets-goodweather-psi/files/pkg-message.in b/astro/gdesklets-goodweather-psi/files/pkg-message.in
new file mode 100644
index 000000000000..a39827d3e970
--- /dev/null
+++ b/astro/gdesklets-goodweather-psi/files/pkg-message.in
@@ -0,0 +1,13 @@
+##
+To view the installed applets:
+
+ ls %%PREFIX%%/share/gnome/gdesklets/Displays
+
+To use those applets:
+
+ gdesklets %%PREFIX%%/share/gnome/gdesklets/Displays/%%NAME%%/%%NAME%%.display
+
+NOTE: Be sure to login as your user when you use the gdesklets command,
+ as the configuration will be stored in the ~/.gdesklets/ directory
+ and/or gconf database.
+##
diff --git a/astro/gdesklets-goodweather-psi/pkg-descr b/astro/gdesklets-goodweather-psi/pkg-descr
new file mode 100644
index 000000000000..51b5253c3898
--- /dev/null
+++ b/astro/gdesklets-goodweather-psi/pkg-descr
@@ -0,0 +1,3 @@
+GoodWeather with a psi theme.
+
+WWW: http://gdesklets.gnomedesktop.org