aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--x11/kdelibs3/Makefile2
-rw-r--r--x11/kdelibs3/files/patch-khtml-rendering-render_block.cpp22
-rw-r--r--x11/kdelibs4/Makefile2
-rw-r--r--x11/kdelibs4/files/patch-khtml-rendering-render_block.cpp22
4 files changed, 46 insertions, 2 deletions
diff --git a/x11/kdelibs3/Makefile b/x11/kdelibs3/Makefile
index f996c1cd6231..a7639bcba687 100644
--- a/x11/kdelibs3/Makefile
+++ b/x11/kdelibs3/Makefile
@@ -8,7 +8,7 @@
PORTNAME= kdelibs
PORTVERSION= ${KDE_VERSION}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= x11 kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/${PORTVERSION}/src
diff --git a/x11/kdelibs3/files/patch-khtml-rendering-render_block.cpp b/x11/kdelibs3/files/patch-khtml-rendering-render_block.cpp
new file mode 100644
index 000000000000..c8569bd92bfc
--- /dev/null
+++ b/x11/kdelibs3/files/patch-khtml-rendering-render_block.cpp
@@ -0,0 +1,22 @@
+--- khtml/rendering/render_block.cpp 2004/03/01 04:46:27 1.20.2.6
++++ khtml/rendering/render_block.cpp 2004/04/26 21:05:27 1.20.2.7
+@@ -422,14 +422,16 @@ void RenderBlock::layout()
+
+ void RenderBlock::layoutBlock(bool relayoutChildren)
+ {
++ if (isInline() && !isReplacedBlock()) {
++ setLayouted();
++ return;
++ }
++
+ // kdDebug( 6040 ) << renderName() << " " << this << "::layoutBlock() start" << endl;
+ // QTime t;
+ // t.start();
+ KHTMLAssert( !layouted() );
+ KHTMLAssert( minMaxKnown() );
+-
+- if (isInline()) // Inline <form>s inside various table elements can cause us to
+- return; // come in here. Just bail. -dwh
+
+ int oldWidth = m_width;
+
diff --git a/x11/kdelibs4/Makefile b/x11/kdelibs4/Makefile
index f996c1cd6231..a7639bcba687 100644
--- a/x11/kdelibs4/Makefile
+++ b/x11/kdelibs4/Makefile
@@ -8,7 +8,7 @@
PORTNAME= kdelibs
PORTVERSION= ${KDE_VERSION}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= x11 kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/${PORTVERSION}/src
diff --git a/x11/kdelibs4/files/patch-khtml-rendering-render_block.cpp b/x11/kdelibs4/files/patch-khtml-rendering-render_block.cpp
new file mode 100644
index 000000000000..c8569bd92bfc
--- /dev/null
+++ b/x11/kdelibs4/files/patch-khtml-rendering-render_block.cpp
@@ -0,0 +1,22 @@
+--- khtml/rendering/render_block.cpp 2004/03/01 04:46:27 1.20.2.6
++++ khtml/rendering/render_block.cpp 2004/04/26 21:05:27 1.20.2.7
+@@ -422,14 +422,16 @@ void RenderBlock::layout()
+
+ void RenderBlock::layoutBlock(bool relayoutChildren)
+ {
++ if (isInline() && !isReplacedBlock()) {
++ setLayouted();
++ return;
++ }
++
+ // kdDebug( 6040 ) << renderName() << " " << this << "::layoutBlock() start" << endl;
+ // QTime t;
+ // t.start();
+ KHTMLAssert( !layouted() );
+ KHTMLAssert( minMaxKnown() );
+-
+- if (isInline()) // Inline <form>s inside various table elements can cause us to
+- return; // come in here. Just bail. -dwh
+
+ int oldWidth = m_width;
+