aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--graphics/py-opengl/Makefile2
-rw-r--r--graphics/py-opengl/files/patch-OpenGL-__init__.py11
2 files changed, 12 insertions, 1 deletions
diff --git a/graphics/py-opengl/Makefile b/graphics/py-opengl/Makefile
index 60773e60482a..f03b90f2ecec 100644
--- a/graphics/py-opengl/Makefile
+++ b/graphics/py-opengl/Makefile
@@ -7,7 +7,7 @@
PORTNAME= opengl
PORTVERSION= 3.0.0.b8
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics python
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= py${PORTNAME}
diff --git a/graphics/py-opengl/files/patch-OpenGL-__init__.py b/graphics/py-opengl/files/patch-OpenGL-__init__.py
new file mode 100644
index 000000000000..5c30f4685978
--- /dev/null
+++ b/graphics/py-opengl/files/patch-OpenGL-__init__.py
@@ -0,0 +1,11 @@
+--- OpenGL/__init__.py.orig 2008-12-07 06:58:16.000000000 +0300
++++ OpenGL/__init__.py 2009-04-12 07:52:27.000000000 +0400
+@@ -102,7 +102,7 @@
+ # Declarations of plugins provided by PyOpenGL itself
+ from OpenGL.plugins import PlatformPlugin, FormatHandler
+ PlatformPlugin( 'nt', 'OpenGL.platform.win32.Win32Platform' )
+-PlatformPlugin( 'posix ', 'OpenGL.platform.glx.GLXPlatform' )
++PlatformPlugin( 'posix', 'OpenGL.platform.glx.GLXPlatform' )
+ PlatformPlugin( 'linux2', 'OpenGL.platform.glx.GLXPlatform' )
+ PlatformPlugin( 'darwin', 'OpenGL.platform.darwin.DarwinPlatform' )
+