aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--print/lilypond-devel/Makefile17
-rw-r--r--print/lilypond-devel/distinfo6
-rw-r--r--print/lilypond-devel/files/fonts.conf6
-rw-r--r--print/lilypond-devel/files/patch-configure12
-rw-r--r--print/lilypond-devel/pkg-plist1
5 files changed, 27 insertions, 15 deletions
diff --git a/print/lilypond-devel/Makefile b/print/lilypond-devel/Makefile
index 783b72c8df90..c3b7d64ea9b6 100644
--- a/print/lilypond-devel/Makefile
+++ b/print/lilypond-devel/Makefile
@@ -2,9 +2,10 @@
# $FreeBSD$
PORTNAME= lilypond
-PORTVERSION= 2.19.57
+DISTVERSION= 2.19.81
CATEGORIES= print audio
-MASTER_SITES= http://download.linuxaudio.org/lilypond/sources/v${PORTVERSION:R}/
+MASTER_SITES= http://download.linuxaudio.org/lilypond/sources/v${PORTVERSION:R}/ \
+ http://lilypond.org/downloads/sources/v${PORTVERSION:R}/
PKGNAMESUFFIX= -devel
MAINTAINER= m.ne@gmx.net
@@ -56,27 +57,27 @@ GNU_MAKEFILE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--with-texgyre-dir=${LOCALBASE}/${TEXMFDISTDIR}/fonts/opentype/public/tex-gyre \
- --with-python-include=${PYTHON_INCLUDEDIR}
+ --with-python-include=${PYTHON_INCLUDEDIR} --without-urwotf-dir
CONFIGURE_ENV+= ac_cv_prog_MAKEINFO="${LOCALBASE}/bin/makeinfo" \
FLEX=${FLEX} YACC=${YACC} HOME=${WRKDIR}
ALL_TARGET= all
-NO_CCACHE= yes
-
PLIST_SUB= PORTVERSION=${PORTVERSION}
OPTIONS_DEFINE= NLS
OPTIONS_SUB= yes
post-patch:
- ${FIND} ${WRKSRC} -name "*.cc" | ${XARGS} \
+ @${FIND} ${WRKSRC} -name "*.cc" | ${XARGS} \
${REINPLACE_CMD} -e 's|isinf[ ]*(|::isinf(|g' -e 's|isnan|::isnan|g'
- ${REINPLACE_CMD} -e 's|<FlexLexer.h>|"/usr/include/FlexLexer.h"|' \
+ @${REINPLACE_CMD} -e 's|<FlexLexer.h>|"/usr/include/FlexLexer.h"|' \
${WRKSRC}/lily/include/includable-lexer.hh
+ ${SED} -e 's|%%FONTDIR%%|${WRKDIR}/fontconfig/cache/|' \
+ ${FILESDIR}/fonts.conf > ${WRKDIR}/.fonts.conf
post-patch-NLS-off:
- ${REINPLACE_CMD} -e '/po \\$$/d' ${WRKSRC}/${MAKEFILE}.in
+ @${REINPLACE_CMD} -e '/po \\$$/d' ${WRKSRC}/${MAKEFILE}.in
post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/lilypond
diff --git a/print/lilypond-devel/distinfo b/print/lilypond-devel/distinfo
index afd50b6d8c52..4584aae4ec56 100644
--- a/print/lilypond-devel/distinfo
+++ b/print/lilypond-devel/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1489482521
-SHA256 (lilypond-2.19.57.tar.gz) = be86019ae91cf78267081e96f35cf682931d0219215e160b16b03b907cac755a
-SIZE (lilypond-2.19.57.tar.gz) = 17182103
+TIMESTAMP = 1517308646
+SHA256 (lilypond-2.19.81.tar.gz) = 2ac299045dc4a8fa3bd7c67af7b06877b21cdb50321fec5baa558e3173ed646c
+SIZE (lilypond-2.19.81.tar.gz) = 17303532
diff --git a/print/lilypond-devel/files/fonts.conf b/print/lilypond-devel/files/fonts.conf
new file mode 100644
index 000000000000..d90cc830783d
--- /dev/null
+++ b/print/lilypond-devel/files/fonts.conf
@@ -0,0 +1,6 @@
+<?xml version="1.0"?>
+<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
+<!-- /etc/fonts/fonts.conf file to configure system font access -->
+<fontconfig>
+ <cachedir>%%FONTDIR%%</cachedir>
+</fontconfig>
diff --git a/print/lilypond-devel/files/patch-configure b/print/lilypond-devel/files/patch-configure
index 614b6624ec6a..ec85d6c7d6d5 100644
--- a/print/lilypond-devel/files/patch-configure
+++ b/print/lilypond-devel/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig 2017-02-12 12:13:29 UTC
+--- configure.orig 2017-10-15 16:42:11 UTC
+++ configure
-@@ -11503,74 +11503,7 @@ test -n "$PKG_CONFIG" || PKG_CONFIG="no"
+@@ -11527,75 +11527,10 @@ test -n "$PKG_CONFIG" || PKG_CONFIG="no"
if test $? -eq 0 -a -n "0.9.0"; then
@@ -72,7 +72,11 @@
- { $as_echo "$as_me:$LINENO: result: $ver" >&5
-$as_echo "$ver" >&6; }
- if test "$num" -lt "$req"; then
-+ if $exe --atleast-pkgconfig-version 0.9.0; then
-
+-
++ $PKG_CONFIG --atleast-pkgconfig-version 0.9.0
++
++ if test ! $?; then
++ ver=`$PKG_CONFIG --version`
eval "REQUIRED"=\"`eval echo \"'$'REQUIRED\" \""$r >= 0.9.0 (installed: $ver)"\"`\"
+ fi
diff --git a/print/lilypond-devel/pkg-plist b/print/lilypond-devel/pkg-plist
index 214109b28b94..d0bb2940e436 100644
--- a/print/lilypond-devel/pkg-plist
+++ b/print/lilypond-devel/pkg-plist
@@ -360,6 +360,7 @@ share/emacs/site-lisp/lilypond-words.el
%%DATADIR%%/%%PORTVERSION%%/scm/translation-functions.scm
%%DATADIR%%/%%PORTVERSION%%/scm/x11-color.scm
%%DATADIR%%/%%PORTVERSION%%/tex/lilypond-tex-metrics.tex
+%%DATADIR%%/%%PORTVERSION%%/tex/texinfo-ja.tex
%%DATADIR%%/%%PORTVERSION%%/vim/compiler/lilypond.vim
%%DATADIR%%/%%PORTVERSION%%/vim/ftdetect/lilypond.vim
%%DATADIR%%/%%PORTVERSION%%/vim/ftplugin/lilypond.vim