aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Mk/Scripts/do-users-groups.sh2
-rw-r--r--Mk/Uses/7z.mk5
-rw-r--r--Mk/Uses/compiler.mk6
-rw-r--r--Mk/Uses/iconv.mk4
-rw-r--r--Mk/Uses/linux.mk4
-rw-r--r--Mk/bsd.gecko.mk2
-rw-r--r--Mk/bsd.port.mk6
-rw-r--r--Mk/bsd.ssp.mk13
8 files changed, 8 insertions, 34 deletions
diff --git a/Mk/Scripts/do-users-groups.sh b/Mk/Scripts/do-users-groups.sh
index ad8ed1856a57..34a47461479c 100644
--- a/Mk/Scripts/do-users-groups.sh
+++ b/Mk/Scripts/do-users-groups.sh
@@ -28,7 +28,7 @@ error() {
rm -f "${dp_UG_INSTALL}" "${dp_UG_DEINSTALL}" || :
# Before FreeBSD 10.2, PW did not have -R support.
-if [ "${dp_OPSYS}" = FreeBSD ] && [ "${dp_OSVERSION}" -ge 1002000 ]; then
+if [ "${dp_OPSYS}" = FreeBSD ] ; then
cat >> "${dp_UG_INSTALL}" <<-eot
if [ -n "\${PKG_ROOTDIR}" ] && [ "\${PKG_ROOTDIR}" != "/" ]; then
PW="${dp_PW} -R \${PKG_ROOTDIR}"
diff --git a/Mk/Uses/7z.mk b/Mk/Uses/7z.mk
index 3a5be240f975..a12cb7af367c 100644
--- a/Mk/Uses/7z.mk
+++ b/Mk/Uses/7z.mk
@@ -23,11 +23,6 @@ P7ZIP_WRKDIR?= ${EXTRACT_WRKDIR}
IGNORE= USES=7z has invalid arguments: ${7z_ARGS:Np7zip:Npartial}
.endif
-.if ! ${7z_ARGS:Mp7zip} && (${OPSYS} == FreeBSD && ${OSVERSION} < 1000009)
-# libarchive lacks 7zip reader, fallback to P7ZIP_CMD
-7z_ARGS+= p7zip
-.endif
-
.if ${7z_ARGS:Mp7zip}
EXTRACT_DEPENDS+= ${P7ZIP_CMD}:archivers/p7zip
.endif
diff --git a/Mk/Uses/compiler.mk b/Mk/Uses/compiler.mk
index 20cd2883e2f4..b4575f235573 100644
--- a/Mk/Uses/compiler.mk
+++ b/Mk/Uses/compiler.mk
@@ -241,18 +241,12 @@ CXX= ${LOCALBASE}/bin/clang++34
USE_GCC= yes
CHOSEN_COMPILER_TYPE= gcc
.if ${COMPILER_FEATURES:Mlibc++}
-.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1001508
-LDFLAGS+= -L${LOCALBASE}/lib/c++
-CXXFLAGS+= -nostdinc++ -isystem ${LOCALBASE}/include/c++/v1
-BUILD_DEPENDS+= ${LOCALBASE}/lib/c++/libstdc++.so:devel/libc++
-.else
CXXFLAGS+= -nostdinc++ -isystem /usr/include/c++/v1
LDFLAGS+= -L${WRKDIR}
_USES_configure+= 200:gcc-libc++-configure
gcc-libc++-configure:
@${LN} -fs /usr/lib/libc++.so ${WRKDIR}/libstdc++.so
-.endif # OSVERSION < 1001508
.endif
.endif
diff --git a/Mk/Uses/iconv.mk b/Mk/Uses/iconv.mk
index 7f808dc30616..a8275442276b 100644
--- a/Mk/Uses/iconv.mk
+++ b/Mk/Uses/iconv.mk
@@ -41,8 +41,8 @@ ICONV_CONFIGURE_BASE=
ICONV_INCLUDE_PATH= /usr/include
ICONV_LIB_PATH= /usr/lib/libc.so
-.if (${OPSYS} == FreeBSD && (${OSVERSION} < 1001514 \
- || (${OSVERSION} >= 1100000 && ${OSVERSION} < 1100069))) \
+.if (${OPSYS} == FreeBSD && \
+ (${OSVERSION} >= 1100000 && ${OSVERSION} < 1100069)) \
|| exists(${LOCALBASE}/include/iconv.h)
BUILD_DEPENDS+= libiconv>=1.14_9:converters/libiconv
ICONV_INCLUDE_PATH= ${LOCALBASE}/include
diff --git a/Mk/Uses/linux.mk b/Mk/Uses/linux.mk
index 480b8ed94ff4..3879843a010b 100644
--- a/Mk/Uses/linux.mk
+++ b/Mk/Uses/linux.mk
@@ -40,9 +40,9 @@ IGNORE= Invalid Linux distribution: ${linux_ARGS}
.if ${LINUX_DEFAULT:M*_64}
LINUX_ARCH= x86_64
LINUX_ARCH32= i386
-.if ${ARCH} != amd64 || ${OPSYS} != FreeBSD || ${OSVERSION} < 1002507 \
+.if ${ARCH} != amd64 || ${OPSYS} != FreeBSD \
|| ( ${OSVERSION} >= 1100000 && ${OSVERSION} < 1100105 )
-IGNORE= Linux ${LINUX_DEFAULT} is only supported on FreeBSD/amd64 10.3 or higher
+IGNORE= Linux ${LINUX_DEFAULT} is unsupported on pre-release versions of FreeBSD 11. Update to 11.0-RELEASE or higher.
.endif
.else
LINUX_ARCH= i386
diff --git a/Mk/bsd.gecko.mk b/Mk/bsd.gecko.mk
index 810b3ebac955..9b1c71decfa6 100644
--- a/Mk/bsd.gecko.mk
+++ b/Mk/bsd.gecko.mk
@@ -144,7 +144,7 @@ LDFLAGS+= -L${LOCALBASE}/lib \
.if ${OPSYS} != DragonFly # XXX xpcshell crash during install
# use jemalloc 3.0.0 (4.0 for firefox 43+) API for stats/tuning
MOZ_EXPORT+= MOZ_JEMALLOC3=1 MOZ_JEMALLOC4=1
-.if ${OPSYS} != FreeBSD || ${OSVERSION} < 1000012 || ${MOZILLA_VER:R:R} >= 37
+.if ${OPSYS} != FreeBSD || ${MOZILLA_VER:R:R} >= 37
. if ${MOZILLA_VER:R:R} >= 48
MOZ_OPTIONS+= --enable-jemalloc=4
.else
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 17e607cfef3b..f67c12b5d037 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -1633,9 +1633,7 @@ MAKE_ENV+= NO_PIE=yes
# We prefer to pass MK_*=no but it was only supported after a certain
# revision. Passing WITHOUT_* may conflict with a make.conf or src.conf's
# WITH_* value. Note that ports *do* pull in src.conf.
-.if (${OSVERSION} >= 903510 && ${OSVERSION} < 1000000) || \
- (${OSVERSION} >= 1003503 && ${OSVERSION} < 1100000) || \
- ${OSVERSION} >= 1100000
+.if ${OSVERSION} >= 1003503
# We will control debug files. Don't let builds that use /usr/share/mk
# split out debug symbols since the plist won't know to expect it.
MAKE_ENV+= MK_DEBUG_FILES=no
@@ -3150,7 +3148,7 @@ do-patch:
.if !target(run-autotools-fixup)
run-autotools-fixup:
# Work around an issue where FreeBSD 10.0 is detected as FreeBSD 1.x.
-.if ${OSVERSION} >= 1000000 && !defined(WITHOUT_FBSD10_FIX)
+.if !defined(WITHOUT_FBSD10_FIX)
-@for f in `${FIND} ${WRKDIR} -type f \( -name config.libpath -o \
-name config.rpath -o -name configure -o -name libtool.m4 -o \
-name ltconfig -o -name libtool -o -name aclocal.m4 -o \
diff --git a/Mk/bsd.ssp.mk b/Mk/bsd.ssp.mk
index 5e944c0e0b21..4f0058fe38da 100644
--- a/Mk/bsd.ssp.mk
+++ b/Mk/bsd.ssp.mk
@@ -3,19 +3,6 @@
SSP_Include_MAINTAINER= portmgr@FreeBSD.org
-# See: http://svnweb.freebsd.org/base/head/lib/libc/libc.ldscript?revision=251668&view=markup
-.if ${OSVERSION} < 1000036 && ${ARCH} == i386
-
-# Disabled on i386 for now on releases without the ldscript as too many ports
-# do not respect LDFLAGS and fail to build due to not adding in -lssp_nonshared when needed
-# despite dependencies working fine, which breaks a lot. Can enable once LDFLAGS is more
-# supported. XXX
-SSP_UNSAFE= yes
-
-# i386 needs -lssp_nonshared, see svn link above for more information
-SSP_NEED_NONSHARED= yes
-.endif
-
.if !defined(SSP_UNSAFE) && \
(${ARCH} == i386 || ${ARCH} == amd64)
# Overridable as a user may want to use -fstack-protector-all