aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--net/Makefile1
-rw-r--r--net/py-magic-wormhole/Makefile23
-rw-r--r--net/py-magic-wormhole/distinfo3
-rw-r--r--net/py-magic-wormhole/pkg-descr3
4 files changed, 30 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index bab5dae86262..672419355910 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -965,6 +965,7 @@
SUBDIR += py-libcloud
SUBDIR += py-libdnet
SUBDIR += py-libnet
+ SUBDIR += py-magic-wormhole
SUBDIR += py-matrix-synapse
SUBDIR += py-maxminddb
SUBDIR += py-miniupnpc
diff --git a/net/py-magic-wormhole/Makefile b/net/py-magic-wormhole/Makefile
new file mode 100644
index 000000000000..94ab01d2c652
--- /dev/null
+++ b/net/py-magic-wormhole/Makefile
@@ -0,0 +1,23 @@
+# $FreeBSD$
+
+PORTNAME= magic-wormhole
+PORTVERSION= 0.8.0
+CATEGORIES= net
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= swills@FreeBSD.org
+COMMENT= Get things from one computer to another, safely
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}tqdm>0:misc/py-tqdm \
+ ${PYTHON_PKGNAMEPREFIX}hkdf>0:security/py-hkdf \
+ ${PYTHON_PKGNAMEPREFIX}autobahn>=0.14.1:www/py-autobahn \
+ ${PYTHON_PKGNAMEPREFIX}argparse>0:devel/py-argparse \
+ ${PYTHON_PKGNAMEPREFIX}pynacl>=0.3.0:security/py-pynacl \
+ ${PYTHON_PKGNAMEPREFIX}spake2>=0.7:security/py-spake2 \
+ ${PYTHON_PKGNAMEPREFIX}txaio>=2.5.1:devel/py-txaio
+
+USES= python
+USE_PYTHON= autoplist distutils
+
+.include <bsd.port.mk>
diff --git a/net/py-magic-wormhole/distinfo b/net/py-magic-wormhole/distinfo
new file mode 100644
index 000000000000..84d1ab87acac
--- /dev/null
+++ b/net/py-magic-wormhole/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1467486862
+SHA256 (magic-wormhole-0.8.0.tar.gz) = 802085dc4e6ba9dd74555bb42059e25b3960110add83d5083d36a95c78e172b5
+SIZE (magic-wormhole-0.8.0.tar.gz) = 124428
diff --git a/net/py-magic-wormhole/pkg-descr b/net/py-magic-wormhole/pkg-descr
new file mode 100644
index 000000000000..29256150d396
--- /dev/null
+++ b/net/py-magic-wormhole/pkg-descr
@@ -0,0 +1,3 @@
+Get things from one computer to another, safely.
+
+WWW: http://magic-wormhole.io