aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--audio/Makefile1
-rw-r--r--audio/linux-genpuid/Makefile31
-rw-r--r--audio/linux-genpuid/distinfo3
-rw-r--r--audio/linux-genpuid/pkg-descr3
4 files changed, 38 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 8d3cfdf753bb..6e220d0a388c 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -400,6 +400,7 @@
SUBDIR += linux-f8-openal
SUBDIR += linux-f8-sdl_mixer
SUBDIR += linux-freealut
+ SUBDIR += linux-genpuid
SUBDIR += linux-libaudiofile
SUBDIR += linux-libmad
SUBDIR += linux-libogg
diff --git a/audio/linux-genpuid/Makefile b/audio/linux-genpuid/Makefile
new file mode 100644
index 000000000000..da21431b599e
--- /dev/null
+++ b/audio/linux-genpuid/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: audio/linux-genpuid
+# Date created: 2009-03-24
+# Whom: Christopher Key <cjk32@cam.ac.uk>
+#
+# $FreeBSD$
+#
+
+PORTNAME= genpuid
+PORTVERSION= 1.4
+CATEGORIES= audio linux
+MASTER_SITES= https://secure.musicip.com/dns/files/
+PKGNAMEPREFIX= linux-
+DISTNAME= ${PORTNAME}_linux_${PORTVERSION}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= cjk32@cam.ac.uk
+COMMENT= Application for generating MusicIP puids
+
+USE_LINUX= yes
+NO_BUILD= yes
+
+PLIST_FILES= bin/genpuid bin/mipcore libexec/mipcore
+
+do-install:
+ ${BRANDELF} -t Linux ${WRKDIR}/${PORTNAME}-${PORTVERSION}/genpuid
+ ${BRANDELF} -t Linux ${WRKDIR}/${PORTNAME}-${PORTVERSION}/mipcore
+ ${INSTALL_PROGRAM} ${WRKDIR}/${PORTNAME}-${PORTVERSION}/genpuid ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKDIR}/${PORTNAME}-${PORTVERSION}/mipcore ${PREFIX}/libexec
+ ${LN} -fhs ${PREFIX}/libexec/mipcore ${PREFIX}/bin/mipcore
+
+.include <bsd.port.mk>
diff --git a/audio/linux-genpuid/distinfo b/audio/linux-genpuid/distinfo
new file mode 100644
index 000000000000..04b8a323efb3
--- /dev/null
+++ b/audio/linux-genpuid/distinfo
@@ -0,0 +1,3 @@
+MD5 (genpuid_linux_1.4.tgz) = fa4a6ae23adaaefa02f07de6321913fe
+SHA256 (genpuid_linux_1.4.tgz) = 906a4085dd508e5b29d5b7cb3d60087a44496490fd3374232a17c8f62a88b499
+SIZE (genpuid_linux_1.4.tgz) = 4453312
diff --git a/audio/linux-genpuid/pkg-descr b/audio/linux-genpuid/pkg-descr
new file mode 100644
index 000000000000..4cc15b7824d0
--- /dev/null
+++ b/audio/linux-genpuid/pkg-descr
@@ -0,0 +1,3 @@
+This is an application for generating MusicIP puids.
+
+WWW: http://www.musicip.com/