aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--games/avoision/Makefile29
1 files changed, 14 insertions, 15 deletions
diff --git a/games/avoision/Makefile b/games/avoision/Makefile
index 26ee2567bf3c..711877dbc2d0 100644
--- a/games/avoision/Makefile
+++ b/games/avoision/Makefile
@@ -1,18 +1,14 @@
-# New Ports collection makefile for: Avoision
-# Date created: 2012-05-17
-# Whom: nemysis@gmx.ch
-#
+# Created by: nemysis <nemysis@gmx.ch>
# $FreeBSD$
-#
PORTNAME= avoision
PORTVERSION= 1.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= games
MASTER_SITES= SF/avsn/
MAINTAINER= nemysis@gmx.ch
-COMMENT= A simple collect-dots-avoid-blocks game
+COMMENT= Simple collect-dots-avoid-blocks game
LICENSE= GPLv2 CCbyNCSA3
LICENSE_COMB= dual
@@ -21,32 +17,35 @@ LICENSE_FILE= ${WRKSRC}/License.txt
LICENSE_FILE_CCbyNCSA3=${WRKSRC}/License.txt
LICENSE_PERMS_CCbyNCSA3=dist-mirror pkg-mirror auto-accept
+BUILD_DEPENDS= ${LOCALBASE}/lib/libradius-engine.a:${PORTSDIR}/graphics/radius-engine
LIB_DEPENDS= lua-5.1:${PORTSDIR}/lang/lua \
png15:${PORTSDIR}/graphics/png \
physfs.1:${PORTSDIR}/devel/physfs
-BUILD_DEPENDS= ${LOCALBASE}/include/radius.h:${PORTSDIR}/graphics/radius-engine \
- zip:${PORTSDIR}/archivers/zip
+RUN_DEPENDS= zip:${PORTSDIR}/archivers/zip
-GNU_CONFIGURE= yes
-ALL_TARGET= ${PORTNAME}
USE_SDL= sdl sound
USE_GL= glu
+GNU_CONFIGURE= yes
+ALL_TARGET= ${PORTNAME}
MAKE_JOBS_SAFE= yes
PLIST_FILES= bin/${PORTNAME} \
share/applications/${PORTNAME}.desktop \
- share/pixmaps/${PORTNAME}.png
+ share/pixmaps/${PORTNAME}.png \
+ %%DATADIR%%/${PORTNAME}.zip
+PLIST_DIRS= %%DATADIR%%
PLIST_DIRSTRY= share/applications
-PORTDATA= *
PORTDOCS= ChangeLog
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
post-install:
.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/ChangeLog ${DOCSDIR}
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
.endif
.include <bsd.port.mk>