aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--net/prosearch/Makefile54
-rw-r--r--net/prosearch/distinfo5
-rw-r--r--net/prosearch/pkg-plist19
3 files changed, 46 insertions, 32 deletions
diff --git a/net/prosearch/Makefile b/net/prosearch/Makefile
index 9bde58d88461..0d6219634495 100644
--- a/net/prosearch/Makefile
+++ b/net/prosearch/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= prosearch
-PORTVERSION= 0.18.3
-PORTREVISION= 2
+PORTVERSION= 0.19.0
CATEGORIES= net www
MASTER_SITES= http://pro.setun.net/search/download/ SF/pro-search/pro-search/${PORTVERSION}
@@ -24,27 +23,39 @@ PLIST_SUB+= SEARCHDIR=${SEARCHDIR}
SAMBA_PORT?= net/samba34
+USE_PERL5_RUN= YES
+
#todo
-# user and group for crawler
+# user and group for crawler, nginx
OPTIONS=\
- CRAWLER "With crawler deps" on \
+ CRAWLER "With crawler deps (nmap, p5-libwww)" on \
SAMBA "crawler with SAMBA (file://)" on \
RSYNC " crawler with RSYNC " off \
- WEB "With web deps (APACHE)" on \
+ APACH22 "With web server apache2.2+" on \
+ APACH20 "With web server apache2.0+" off \
MOD_PERL2 "With MOD_PERL2" off \
MOD_FASTCGI "With MOD_FASTCGI" off \
DB "With database server deps" on \
MYSQL "mysql" on \
+ MARIA "maria (mysql replace)" off \
PGSQL "postgres" off \
- PGPP "postgres pure perl connection" off \
- SQLITE "sqlite" off
+ PGPP "postgres pure Perl connection driver" off \
+ SQLITE "sqlite" off \
+ SPHINX "sphinx fulltext search engine" off
+
+# NGINX "With web server deps (NGINX)" off
.include <bsd.port.pre.mk>
+RUN_DEPENDS+=\
+${SITE_PERL}/lib/abs.pm:${PORTSDIR}/devel/p5-lib-abs
+
.if defined(WITH_CRAWLER)
RUN_DEPENDS+=\
${SITE_PERL}/LWP.pm:${PORTSDIR}/www/p5-libwww \
-nmap:${PORTSDIR}/security/nmap
+${SITE_PERL}/${PERL_ARCH}/HTML/Entities.pm:${PORTSDIR}/www/p5-HTML-Parser \
+nmap:${PORTSDIR}/security/nmap \
+${SITE_PERL}/Net/DirectConnect.pm:${PORTSDIR}/net-p2p/p5-Net-DirectConnect
.endif
.if defined(WITH_SAMBA)
@@ -55,10 +66,19 @@ RUN_DEPENDS+= smbclient:${PORTSDIR}/${SAMBA_PORT}
RUN_DEPENDS+= rsync:${PORTSDIR}/net/rsync
.endif
-.if defined(WITH_WEB)
+.if defined(WITH_APACH22)
+USE_APACHE= 2.2+
+.endif
+
+.if defined(WITH_APACH20)
USE_APACHE= 2.0+
.endif
+.if defined(WITH_NGINX)
+RUN_DEPENDS+=\
+nginx:${PORTSDIR}/www/nginx
+.endif
+
.if defined(WITH_MOD_PERL2)
RUN_DEPENDS+=\
${LOCALBASE}/${APACHEMODDIR}/mod_perl.so:${PORTSDIR}/www/mod_perl2
@@ -70,10 +90,15 @@ ${LOCALBASE}/${APACHEMODDIR}/mod_fastcgi.so:${PORTSDIR}/www/mod_fastcgi \
${SITE_PERL}/${PERL_ARCH}/FCGI.pm:${PORTSDIR}/www/p5-FastCGI
.endif
+.if defined(WITH_SPHINX)
+WITH_MYSQL= client # for dbi
+RUN_DEPENDS+=\
+searchd:${PORTSDIR}/textproc/sphinxsearch-devel
+.endif
+
.if defined(WITH_MYSQL)
USE_MYSQL= client
-USE_PERL5_RUN= YES
-RUN_DEPENDS+=
+RUN_DEPENDS+=\
${SITE_PERL}/${PERL_ARCH}/DBD/mysql.pm:${PORTSDIR}/databases/p5-DBD-mysql
.endif
@@ -81,6 +106,12 @@ ${SITE_PERL}/${PERL_ARCH}/DBD/mysql.pm:${PORTSDIR}/databases/p5-DBD-mysql
USE_MYSQL= server
.endif
+.if defined(WITH_MARIA)
+RUN_DEPENDS+=\
+${SITE_PERL}/${PERL_ARCH}/DBD/mysql.pm:${PORTSDIR}/databases/p5-DBD-mysql \
+${LOCALBASE}/libexec/mysqld:${PORTSDIR}/databases/mariadb
+.endif
+
.if defined(WITH_PGSQL)
USE_PGSQL= yes
RUN_DEPENDS+=\
@@ -108,6 +139,7 @@ WRKSRC= ${WRKDIR}/search
do-install:
@cd ${WRKSRC} && ${COPYTREE_SHARE} . ${PREFIX}/${SEARCHDIR}/
@${CHOWN} -R ${WWWOWN}:${WWWGRP} ${PREFIX}/${SEARCHDIR}
+ @${CHMOD} +x ${PREFIX}/${SEARCHDIR}/crawler.pl ${PREFIX}/${SEARCHDIR}/010.search.purge ${PREFIX}/${SEARCHDIR}/*.sh.* ${PREFIX}/${SEARCHDIR}/web/*.*cgi
@${ECHO_CMD} @exec ${CHOWN} -R ${WWWOWN}:${WWWGRP} \
${SEARCHDIR:S|^${PREFIX}/|%D/|} >> ${TMPPLIST}
diff --git a/net/prosearch/distinfo b/net/prosearch/distinfo
index aaa21b5149d8..fa44c860f6f2 100644
--- a/net/prosearch/distinfo
+++ b/net/prosearch/distinfo
@@ -1,3 +1,2 @@
-MD5 (prosearch-0.18.3.tar.bz2) = b3ade36ba0a0f324d964a34401aac95e
-SHA256 (prosearch-0.18.3.tar.bz2) = 2d8b730763ab5263fbf495fa7fa76ba5dc821190901f188109d299847af941db
-SIZE (prosearch-0.18.3.tar.bz2) = 326241
+SHA256 (prosearch-0.19.0.tar.bz2) = b2739cbdf433c1259aefbc54f0a9ad75807f180a5c932743ed56bd0e1e7dee03
+SIZE (prosearch-0.19.0.tar.bz2) = 305008
diff --git a/net/prosearch/pkg-plist b/net/prosearch/pkg-plist
index 3e0ae8238077..e055942eb9a3 100644
--- a/net/prosearch/pkg-plist
+++ b/net/prosearch/pkg-plist
@@ -8,6 +8,7 @@
%%SEARCHDIR%%/tools/size.sh
%%SEARCHDIR%%/tools/grant.sql
%%SEARCHDIR%%/tools/search.conf
+%%SEARCHDIR%%/tools/sphinx.conf
%%SEARCHDIR%%/tools/cp_auto_gen.pl
%%SEARCHDIR%%/doc/html2txt.pl
%%SEARCHDIR%%/doc/cuted.old
@@ -21,7 +22,6 @@
%%SEARCHDIR%%/lib/search1.js
%%SEARCHDIR%%/lib/player.js
%%SEARCHDIR%%/lib/psmisc.pm
-%%SEARCHDIR%%/lib/psconn.pm
%%SEARCHDIR%%/lib/psweb.pm
%%SEARCHDIR%%/lib/lib.css
%%SEARCHDIR%%/lib/pssql.pm
@@ -72,17 +72,10 @@
%%SEARCHDIR%%/web/img/dcuser.png
%%SEARCHDIR%%/web/img/nrg.png
%%SEARCHDIR%%/web/img/ftp.png
-%%SEARCHDIR%%/web/Net/DirectConnect/clihub.pm
-%%SEARCHDIR%%/web/Net/DirectConnect/hubcli.pm
-%%SEARCHDIR%%/web/Net/DirectConnect/hubhub.pm
-%%SEARCHDIR%%/web/Net/DirectConnect/hub.pm
-%%SEARCHDIR%%/web/Net/DirectConnect/clicli.pm
-%%SEARCHDIR%%/web/Net/DirectConnect.pm
%%SEARCHDIR%%/web/lib/lib.js
%%SEARCHDIR%%/web/lib/search1.js
%%SEARCHDIR%%/web/lib/player.js
%%SEARCHDIR%%/web/lib/psmisc.pm
-%%SEARCHDIR%%/web/lib/psconn.pm
%%SEARCHDIR%%/web/lib/psweb.pm
%%SEARCHDIR%%/web/lib/lib.css
%%SEARCHDIR%%/web/lib/pssql.pm
@@ -105,22 +98,12 @@
%%SEARCHDIR%%/web/.htaccess.dist
%%SEARCHDIR%%/web/search1.css
%%SEARCHDIR%%/web/search2.css
-%%SEARCHDIR%%/Net/DirectConnect/clihub.pm
-%%SEARCHDIR%%/Net/DirectConnect/hubcli.pm
-%%SEARCHDIR%%/Net/DirectConnect/hubhub.pm
-%%SEARCHDIR%%/Net/DirectConnect/hub.pm
-%%SEARCHDIR%%/Net/DirectConnect/clicli.pm
-%%SEARCHDIR%%/Net/DirectConnect.pm
%%SEARCHDIR%%/COPYING
%%SEARCHDIR%%/crawler.pl
%%SEARCHDIR%%/confdef.pl
-@dirrm %%SEARCHDIR%%/Net/DirectConnect
-@dirrm %%SEARCHDIR%%/Net
@dirrm %%SEARCHDIR%%/tools/prosearch/files
@dirrm %%SEARCHDIR%%/tools/prosearch
@dirrm %%SEARCHDIR%%/tools
-@dirrm %%SEARCHDIR%%/web/Net/DirectConnect
-@dirrm %%SEARCHDIR%%/web/Net
@dirrm %%SEARCHDIR%%/web/img
@dirrm %%SEARCHDIR%%/web/lib
@dirrm %%SEARCHDIR%%/doc