aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-configargparse/Makefile20
-rw-r--r--devel/py-configargparse/distinfo2
-rw-r--r--devel/py-configargparse/pkg-descr5
4 files changed, 28 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index baceb05d703e..50c89db9197a 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -3811,6 +3811,7 @@
SUBDIR += py-colorama
SUBDIR += py-colorlog
SUBDIR += py-conditional
+ SUBDIR += py-configargparse
SUBDIR += py-configobj
SUBDIR += py-configparser
SUBDIR += py-construct
diff --git a/devel/py-configargparse/Makefile b/devel/py-configargparse/Makefile
new file mode 100644
index 000000000000..81188a95eb92
--- /dev/null
+++ b/devel/py-configargparse/Makefile
@@ -0,0 +1,20 @@
+# Created by: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= configargparse
+PORTVERSION= 0.9.3
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= ConfigArgParse-${PORTVERSION}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Drop-in replacement for argparse
+
+LICENSE= MIT
+
+NO_ARCH= yes
+USE_PYTHON= autoplist distutils
+USES= python
+
+.include <bsd.port.mk>
diff --git a/devel/py-configargparse/distinfo b/devel/py-configargparse/distinfo
new file mode 100644
index 000000000000..2c8a7f3e33a3
--- /dev/null
+++ b/devel/py-configargparse/distinfo
@@ -0,0 +1,2 @@
+SHA256 (ConfigArgParse-0.9.3.tar.gz) = 141c57112e1f8eb7e594a9820e95af897a7fa2d186cef5cff7e08cb3f7252829
+SIZE (ConfigArgParse-0.9.3.tar.gz) = 18983
diff --git a/devel/py-configargparse/pkg-descr b/devel/py-configargparse/pkg-descr
new file mode 100644
index 000000000000..eb97e191a04b
--- /dev/null
+++ b/devel/py-configargparse/pkg-descr
@@ -0,0 +1,5 @@
+ConfigArgParse is a drop-in replacement for argparse that allows options to
+also be set via config files and/or environment variables.
+
+WWW: https://pypi.python.org/pypi/ConfigArgParse
+WWW: https://github.com/bw2/ConfigArgParse