aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--devel/aegis/Makefile3
-rw-r--r--devel/apr2/Makefile4
-rw-r--r--devel/bison/Makefile4
-rw-r--r--devel/cvsutils/Makefile2
-rw-r--r--devel/doxygen/Makefile4
-rw-r--r--devel/gearmand/Makefile5
-rw-r--r--devel/git/Makefile3
-rw-r--r--devel/msp430-gcc3/Makefile4
-rw-r--r--devel/p5-Data-TreeDumper/Makefile3
-rw-r--r--devel/p5-Event-RPC/Makefile3
-rw-r--r--devel/p5-ExtUtils-XSpp/Makefile3
-rw-r--r--devel/p5-IO-TieCombine/Makefile3
-rw-r--r--devel/p5-Log-Dispatchouli/Makefile3
-rw-r--r--devel/p5-PAR/Makefile3
-rw-r--r--devel/p5-SVN-Notify-Mirror/Makefile3
-rw-r--r--devel/p5-SVN-Simple/Makefile3
-rw-r--r--devel/p5-perlbrew/Makefile3
-rw-r--r--devel/stringencoders/Makefile2
-rw-r--r--devel/svn_load_dirs/Makefile2
19 files changed, 32 insertions, 28 deletions
diff --git a/devel/aegis/Makefile b/devel/aegis/Makefile
index f54ebd59fec5..a7dab029a664 100644
--- a/devel/aegis/Makefile
+++ b/devel/aegis/Makefile
@@ -17,9 +17,8 @@ COMMENT= Transaction-based software configuration management system
LIB_DEPENDS= curl:${PORTSDIR}/ftp/curl
RUN_DEPENDS= tkdiff:${PORTSDIR}/textproc/tkdiff
-USES= gettext
+USES= gettext perl5
USE_GNOME= libxml2
-USE_PERL5= yes
USE_TK= yes
GNU_CONFIGURE= yes
CPPFLAGS+= "-I${LOCALBASE}/include"
diff --git a/devel/apr2/Makefile b/devel/apr2/Makefile
index 7edd06b7d1ae..d3ad98d4a0cf 100644
--- a/devel/apr2/Makefile
+++ b/devel/apr2/Makefile
@@ -31,9 +31,9 @@ DEVELOPER_ONLY_DESC= I want to test apr2 not the maintainer
.include <bsd.port.options.mk>
-USES= iconv
+USES= iconv perl5
USE_AUTOTOOLS= automake autoconf libtool:env
-USE_PERL5_BUILD= yes
+USE_PERL5= build
USE_PYTHON_BUILD= -2.7
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
diff --git a/devel/bison/Makefile b/devel/bison/Makefile
index 71da5785931d..2b380d770c63 100644
--- a/devel/bison/Makefile
+++ b/devel/bison/Makefile
@@ -13,9 +13,9 @@ COMMENT= A parser generator from FSF, (mostly) compatible with Yacc
BUILD_DEPENDS= m4>=1.4.16,1:${PORTSDIR}/devel/m4
RUN_DEPENDS= m4>=1.4.16,1:${PORTSDIR}/devel/m4
-USES= charsetfix
+USES= charsetfix perl5
USE_XZ= yes
-USE_PERL5_BUILD=yes
+USE_PERL5= build
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/devel/cvsutils/Makefile b/devel/cvsutils/Makefile
index 32b087c54c13..db4398b06fbc 100644
--- a/devel/cvsutils/Makefile
+++ b/devel/cvsutils/Makefile
@@ -12,7 +12,7 @@ COMMENT= CVS utilities which facilitate working with local working directories
LICENSE= GPLv2
-USE_PERL5= yes
+USES= perl5
GNU_CONFIGURE= yes
MAN1= cvsutils.1
diff --git a/devel/doxygen/Makefile b/devel/doxygen/Makefile
index 2c307bff58a7..5e46a045a624 100644
--- a/devel/doxygen/Makefile
+++ b/devel/doxygen/Makefile
@@ -18,11 +18,9 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= tmake:${PORTSDIR}/devel/tmake
LIB_DEPENDS= png15:${PORTSDIR}/graphics/png
-USES= bison iconv
+USES= bison iconv perl5 gmake
ALL_TARGET= all
-USE_PERL5= yes
HAS_CONFIGURE= yes
-USE_GMAKE= yes
QT_NONSTANDARD= yes # non-standard configure arguments
CONFIGURE_ARGS= --prefix ${PREFIX} --perl ${PERL} --make ${GMAKE} \
--install "${INSTALL}"
diff --git a/devel/gearmand/Makefile b/devel/gearmand/Makefile
index a00f017812a3..1e468c9dde5e 100644
--- a/devel/gearmand/Makefile
+++ b/devel/gearmand/Makefile
@@ -30,10 +30,9 @@ USERS= gearmand
GROUPS= gearmand
FETCH_ARGS= -pRr
-USE_PERL5_BUILD=yes
+USE_PERL5= build
GNU_CONFIGURE= yes
-USE_GMAKE= yes
-USES= pathfix
+USES= pathfix gmake perl5
USE_LDCONFIG= yes
USE_PYTHON_BUILD=yes
USE_RC_SUBR= gearmand
diff --git a/devel/git/Makefile b/devel/git/Makefile
index bb26e800d127..3443f6691106 100644
--- a/devel/git/Makefile
+++ b/devel/git/Makefile
@@ -195,7 +195,6 @@ MAKE_ENV+= V=1
MAKE_ARGS+= prefix="${PREFIX}"
USE_OPENSSL= yes
USE_RC_SUBR= git_daemon
-WANT_PERL= yes
CONFIGURE_ARGS= --enable-pthreads=-pthread
@@ -235,7 +234,7 @@ PLIST_SUB+= PYTHON="@comment "
.endif
.if ${PORT_OPTIONS:MPERL}
-USE_PERL5= yes
+USES+= perl5
MAKE_ENV+= PERL_PATH=${PERL}
BUILD_DEPENDS+= p5-Error>=0:${PORTSDIR}/lang/p5-Error
RUN_DEPENDS+= p5-Error>=0:${PORTSDIR}/lang/p5-Error \
diff --git a/devel/msp430-gcc3/Makefile b/devel/msp430-gcc3/Makefile
index 313a167d9039..959ab854fb19 100644
--- a/devel/msp430-gcc3/Makefile
+++ b/devel/msp430-gcc3/Makefile
@@ -35,9 +35,9 @@ PATCHVERSION= 20050317
WRKSRC= ${WRKDIR}/${PORTNAME}-${GCCVERSION}
+USES= gmake perl5
USE_BZIP2= yes
-USE_GMAKE= yes
-USE_PERL5_BUILD=yes
+USE_PERL5= build
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --target=${PKGNAMEPREFIX:S/-$//} \
--with-gcc --with-gnu-ld --with-gnu-as \
diff --git a/devel/p5-Data-TreeDumper/Makefile b/devel/p5-Data-TreeDumper/Makefile
index 76a774030f19..5bc1eda875a9 100644
--- a/devel/p5-Data-TreeDumper/Makefile
+++ b/devel/p5-Data-TreeDumper/Makefile
@@ -20,7 +20,8 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
MAN3= Data::TreeDumper.3
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
.include <bsd.port.pre.mk>
diff --git a/devel/p5-Event-RPC/Makefile b/devel/p5-Event-RPC/Makefile
index be36003c4781..c0fa39452dab 100644
--- a/devel/p5-Event-RPC/Makefile
+++ b/devel/p5-Event-RPC/Makefile
@@ -13,7 +13,8 @@ COMMENT= Event based transparent Client/Server RPC framework
LICENSE= ART10 GPLv1
LICENSE_COMB= dual
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Event::RPC.3 \
Event::RPC::Client.3 \
diff --git a/devel/p5-ExtUtils-XSpp/Makefile b/devel/p5-ExtUtils-XSpp/Makefile
index aa39aba4f08a..276269828a6a 100644
--- a/devel/p5-ExtUtils-XSpp/Makefile
+++ b/devel/p5-ExtUtils-XSpp/Makefile
@@ -14,7 +14,8 @@ COMMENT= XS for C++ in Perl
BUILD_DEPENDS= p5-Test-Base>=0:${PORTSDIR}/devel/p5-Test-Base \
p5-Test-Differences>=0:${PORTSDIR}/devel/p5-Test-Differences
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
MAN1= xspp.1
MAN3= ExtUtils::XSpp.3 \
diff --git a/devel/p5-IO-TieCombine/Makefile b/devel/p5-IO-TieCombine/Makefile
index f3cd08e3a8c0..17765ddd5d86 100644
--- a/devel/p5-IO-TieCombine/Makefile
+++ b/devel/p5-IO-TieCombine/Makefile
@@ -14,7 +14,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= miwi@FreeBSD.org
COMMENT= Perl 5 module to produce tied separate but combined variables
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= IO::TieCombine.3 \
IO::TieCombine::Handle.3 \
diff --git a/devel/p5-Log-Dispatchouli/Makefile b/devel/p5-Log-Dispatchouli/Makefile
index 9d581d2f4720..3859341a0efc 100644
--- a/devel/p5-Log-Dispatchouli/Makefile
+++ b/devel/p5-Log-Dispatchouli/Makefile
@@ -26,7 +26,8 @@ BUILD_DEPENDS:= ${RUN_DEPENDS}
TEST_DEPENDS= p5-Test-Deep>=0:${PORTSDIR}/devel/p5-Test-Deep \
p5-Test-Fatal>=0:${PORTSDIR}/devel/p5-Test-Fatal
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Log::Dispatchouli.3 \
Log::Dispatchouli::Global.3 \
diff --git a/devel/p5-PAR/Makefile b/devel/p5-PAR/Makefile
index 6ae31000f5dd..efb4ce148fc2 100644
--- a/devel/p5-PAR/Makefile
+++ b/devel/p5-PAR/Makefile
@@ -16,7 +16,8 @@ RUN_DEPENDS= p5-Archive-Zip>=1.00:${PORTSDIR}/archivers/p5-Archive-Zip \
p5-PAR-Dist>=0.32:${PORTSDIR}/devel/p5-PAR-Dist
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= PAR.3 \
PAR::Environment.3 \
diff --git a/devel/p5-SVN-Notify-Mirror/Makefile b/devel/p5-SVN-Notify-Mirror/Makefile
index 8cf8caa2387f..29955d69321f 100644
--- a/devel/p5-SVN-Notify-Mirror/Makefile
+++ b/devel/p5-SVN-Notify-Mirror/Makefile
@@ -19,7 +19,8 @@ BUILD_DEPENDS= p5-SVN-Notify>=2.83:${PORTSDIR}/devel/p5-SVN-Notify \
p5-YAML>=0.81:${PORTSDIR}/textproc/p5-YAML
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
MAN3= SVN::Notify::Mirror.3 SVN::Notify::Mirror::ConfigData.3 \
SVN::Notify::Mirror::Rsync.3 SVN::Notify::Mirror::SSH.3
diff --git a/devel/p5-SVN-Simple/Makefile b/devel/p5-SVN-Simple/Makefile
index 08fe34748045..fed27240ff96 100644
--- a/devel/p5-SVN-Simple/Makefile
+++ b/devel/p5-SVN-Simple/Makefile
@@ -18,7 +18,8 @@ COMMENT= Simple interface to SVN::Delta::Editor
BUILD_DEPENDS= p5-subversion>=0:${PORTSDIR}/devel/p5-subversion
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= SVN::Simple::Edit.3 SVN::Simple::Editor.3
diff --git a/devel/p5-perlbrew/Makefile b/devel/p5-perlbrew/Makefile
index 3dc0752b25a1..ecb097bb91d3 100644
--- a/devel/p5-perlbrew/Makefile
+++ b/devel/p5-perlbrew/Makefile
@@ -26,7 +26,8 @@ TEST_DEPENDS= p5-IO-All>=0:${PORTSDIR}/devel/p5-IO-All \
p5-Test-Output>=0:${PORTSDIR}/devel/p5-Test-Output \
p5-Test-Spec>=0:${PORTSDIR}/devel/p5-Test-Spec
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN1= perlbrew.1
MAN3= App::perlbrew.3
diff --git a/devel/stringencoders/Makefile b/devel/stringencoders/Makefile
index 12219caaa951..3128aaac0681 100644
--- a/devel/stringencoders/Makefile
+++ b/devel/stringencoders/Makefile
@@ -14,7 +14,7 @@ DISTNAME= ${PORTNAME}-v${PORTVERSION}
MAINTAINER= skreuzer@FreeBSD.org
COMMENT= Collection of high performance c-string transformations
-USE_PERL5= yes
+USES= perl5
HAS_CONFIGURE= yes
USE_LDCONFIG= yes
USE_AUTOTOOLS= libtool
diff --git a/devel/svn_load_dirs/Makefile b/devel/svn_load_dirs/Makefile
index 04c0bd2e4bd0..a13e573514f1 100644
--- a/devel/svn_load_dirs/Makefile
+++ b/devel/svn_load_dirs/Makefile
@@ -17,8 +17,8 @@ COMMENT= A Perl script to load directories into a Subversion repository
RUN_DEPENDS= p5-URI>=0:${PORTSDIR}/net/p5-URI \
${LOCALBASE}/bin/svn:${PORTSDIR}/devel/subversion16
+USES= perl5
USE_BZIP2= yes
-USE_PERL5= yes
WRKSRC= ${WRKDIR}/subversion-${SVN_PORTVERSION}/contrib/client-side/svn_load_dirs