aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--databases/Makefile1
-rw-r--r--databases/py-Pyrseas/Makefile26
-rw-r--r--databases/py-Pyrseas/distinfo2
-rw-r--r--databases/py-Pyrseas/pkg-descr5
4 files changed, 34 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index f54266a44a98..26cbbf1c88c6 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -729,6 +729,7 @@
SUBDIR += py-MySQLdb51
SUBDIR += py-MySQLdb55
SUBDIR += py-PyGreSQL
+ SUBDIR += py-Pyrseas
SUBDIR += py-apsw
SUBDIR += py-bsddb
SUBDIR += py-bsddb3
diff --git a/databases/py-Pyrseas/Makefile b/databases/py-Pyrseas/Makefile
new file mode 100644
index 000000000000..5e29d01180ff
--- /dev/null
+++ b/databases/py-Pyrseas/Makefile
@@ -0,0 +1,26 @@
+# $FreeBSD$
+
+PORTNAME= Pyrseas
+PORTVERSION= 0.6.1
+CATEGORIES= databases python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= c.kworr@gmail.com
+COMMENT= Framework and utilities to upgrade and maintain a relational database
+
+LICENSE= BSD
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}psycopg2>0:${PORTSDIR}/databases/py-psycopg2 \
+ ${PYTHON_PKGNAMEPREFIX}yaml>0:${PORTSDIR}/devel/py-yaml
+
+USE_GITHUB= yes
+USE_PYTHON= yes
+USE_PYDISTUTILS= easy_install
+PYDISTUTILS_AUTOPLIST= yes
+NO_STAGE= yes
+
+GH_ACCOUNT= jmafc
+GH_COMMIT= 9d64338
+GH_TAGNAME= v${PORTVERSION}
+
+.include <bsd.port.mk>
diff --git a/databases/py-Pyrseas/distinfo b/databases/py-Pyrseas/distinfo
new file mode 100644
index 000000000000..d52b10cb9d53
--- /dev/null
+++ b/databases/py-Pyrseas/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Pyrseas-0.6.1.tar.gz) = a04216850441aedc26a92339edccc603be9638425dea810ae324314ce32afbb6
+SIZE (Pyrseas-0.6.1.tar.gz) = 111637
diff --git a/databases/py-Pyrseas/pkg-descr b/databases/py-Pyrseas/pkg-descr
new file mode 100644
index 000000000000..a531deea4056
--- /dev/null
+++ b/databases/py-Pyrseas/pkg-descr
@@ -0,0 +1,5 @@
+Pyrseas provides a framework and utilities to upgrade and maintain a relational
+database. Its purpose is to enhance and follow through on the concepts of the
+Andromeda Project (http://www.andromeda-project.org/)
+
+WWW: http://pgfoundry.org/projects/pyrseas/