aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--audio/p5-Audio-Scrobbler/Makefile2
-rw-r--r--japanese/p5-Mail-SpamAssassin/Makefile2
-rw-r--r--mail/demime/Makefile2
-rw-r--r--mail/p5-Mail-SpamAssassin/Makefile4
-rw-r--r--www/p5-Net-Akismet/Makefile4
-rw-r--r--www/p5-Net-eBay/Makefile2
-rw-r--r--www/validator/Makefile2
7 files changed, 9 insertions, 9 deletions
diff --git a/audio/p5-Audio-Scrobbler/Makefile b/audio/p5-Audio-Scrobbler/Makefile
index 4628596d087e..de109e495fd8 100644
--- a/audio/p5-Audio-Scrobbler/Makefile
+++ b/audio/p5-Audio-Scrobbler/Makefile
@@ -16,7 +16,7 @@ MAINTAINER= roam@FreeBSD.org
COMMENT= A Perl interface to Last.fm / AudioScrobbler
BUILD_DEPENDS= ${SITE_PERL}/Config/IniFiles.pm:${PORTSDIR}/devel/p5-Config-IniFiles \
- ${SITE_PERL}/Bundle/LWP.pm:${PORTSDIR}/www/p5-libwww
+ p5-libwww>=5:${PORTSDIR}/www/p5-libwww
RUN_DEPENDS= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/japanese/p5-Mail-SpamAssassin/Makefile b/japanese/p5-Mail-SpamAssassin/Makefile
index a3e0de4a867e..b685685507f2 100644
--- a/japanese/p5-Mail-SpamAssassin/Makefile
+++ b/japanese/p5-Mail-SpamAssassin/Makefile
@@ -30,7 +30,7 @@ COMMENT= SpamAssassin with Japanese tokenizer
RUN_DEPENDS= p5-NetAddr-IP>=4.00.7:${PORTSDIR}/net-mgmt/p5-NetAddr-IP \
p5-Net-DNS>=0.63:${PORTSDIR}/dns/p5-Net-DNS \
p5-HTML-Parser>=3.43:${PORTSDIR}/www/p5-HTML-Parser \
- ${SITE_PERL}/Bundle/LWP.pm:${PORTSDIR}/www/p5-libwww \
+ p5-libwww>=0:${PORTSDIR}/www/p5-libwww \
${SITE_PERL}/${PERL_ARCH}/Encode/Detect.pm:${PORTSDIR}/converters/p5-Encode-Detect \
${SITE_PERL}/Mail/Internet.pm:${PORTSDIR}/mail/p5-Mail-Tools
RUN_DEPENDS+= ja-p5-MeCab>=0.98:${PORTSDIR}/japanese/p5-MeCab
diff --git a/mail/demime/Makefile b/mail/demime/Makefile
index 47a12ed6eb79..4031eafc8e79 100644
--- a/mail/demime/Makefile
+++ b/mail/demime/Makefile
@@ -15,7 +15,7 @@ DISTFILES= ${PORTNAME}.${PORTVERSION} ${PORTNAME}_junkmail.cf
MAINTAINER= gjb@FreeBSD.org
COMMENT= A tool to scrub mime from mailing lists
-RUN_DEPENDS= ${SITE_PERL}/Bundle/LWP.pm:${PORTSDIR}/www/p5-libwww \
+RUN_DEPENDS= p5-libwww>=0:${PORTSDIR}/www/p5-libwww \
${SITE_PERL}/HTML/FormatText.pm:${PORTSDIR}/textproc/p5-HTML-Format \
${SITE_PERL}/HTML/Element.pm:${PORTSDIR}/www/p5-HTML-Tree \
${SITE_PERL}/HTML/Tagset.pm:${PORTSDIR}/www/p5-HTML-Tagset
diff --git a/mail/p5-Mail-SpamAssassin/Makefile b/mail/p5-Mail-SpamAssassin/Makefile
index 9b699054133f..8878497b6b86 100644
--- a/mail/p5-Mail-SpamAssassin/Makefile
+++ b/mail/p5-Mail-SpamAssassin/Makefile
@@ -19,13 +19,13 @@ COMMENT= A highly efficient mail filter for identifying spam
RUN_DEPENDS= p5-NetAddr-IP>=4.00.7:${PORTSDIR}/net-mgmt/p5-NetAddr-IP \
p5-Net-DNS>=0.63:${PORTSDIR}/dns/p5-Net-DNS \
p5-HTML-Parser>=3.43:${PORTSDIR}/www/p5-HTML-Parser \
- ${SITE_PERL}/Bundle/LWP.pm:${PORTSDIR}/www/p5-libwww \
+ p5-libwww>=0:${PORTSDIR}/www/p5-libwww \
${SITE_PERL}/${PERL_ARCH}/Encode/Detect.pm:${PORTSDIR}/converters/p5-Encode-Detect \
${SITE_PERL}/Mail/Internet.pm:${PORTSDIR}/mail/p5-Mail-Tools
BUILD_DEPENDS= p5-NetAddr-IP>=4.00.7:${PORTSDIR}/net-mgmt/p5-NetAddr-IP \
p5-Net-DNS>=0.63:${PORTSDIR}/dns/p5-Net-DNS \
p5-HTML-Parser>=3.43:${PORTSDIR}/www/p5-HTML-Parser \
- ${SITE_PERL}/Bundle/LWP.pm:${PORTSDIR}/www/p5-libwww \
+ p5-libwww>=0:${PORTSDIR}/www/p5-libwww \
${SITE_PERL}/${PERL_ARCH}/Encode/Detect.pm:${PORTSDIR}/converters/p5-Encode-Detect \
${SITE_PERL}/Mail/Internet.pm:${PORTSDIR}/mail/p5-Mail-Tools
diff --git a/www/p5-Net-Akismet/Makefile b/www/p5-Net-Akismet/Makefile
index 58d44e677958..6f6a8cd94a08 100644
--- a/www/p5-Net-Akismet/Makefile
+++ b/www/p5-Net-Akismet/Makefile
@@ -14,8 +14,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= roam@FreeBSD.org
COMMENT= A Perl interface to the Akismet comment and trackback spam blocker
-BUILD_DEPENDS+= ${SITE_PERL}/Bundle/LWP.pm:${PORTSDIR}/www/p5-libwww
-RUN_DEPENDS+= ${SITE_PERL}/Bundle/LWP.pm:${PORTSDIR}/www/p5-libwww
+BUILD_DEPENDS= p5-libwww>=5.09:${PORTSDIR}/www/p5-libwww
+RUN_DEPENDS= p5-libwww>=5.09:${PORTSDIR}/www/p5-libwww
.if !defined(WITHOUT_TEST_POD_COVERAGE)
BUILD_DEPENDS+= ${SITE_PERL}/Test/Pod/Coverage.pm:${PORTSDIR}/devel/p5-Test-Pod-Coverage
diff --git a/www/p5-Net-eBay/Makefile b/www/p5-Net-eBay/Makefile
index fe9e792840d2..ff40351f8972 100644
--- a/www/p5-Net-eBay/Makefile
+++ b/www/p5-Net-eBay/Makefile
@@ -14,7 +14,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
COMMENT= Perl Interface to XML based eBay API
-BUILD_DEPENDS= ${SITE_PERL}/Bundle/LWP.pm:${PORTSDIR}/www/p5-libwww \
+BUILD_DEPENDS= p5-libwww>=0:${PORTSDIR}/www/p5-libwww \
${SITE_PERL}/XML/Simple.pm:${PORTSDIR}/textproc/p5-XML-Simple \
${SITE_PERL}/XML/Dumper.pm:${PORTSDIR}/textproc/p5-XML-Dumper \
${SITE_PERL}/DateTime/Precise.pm:${PORTSDIR}/devel/p5-DateTime-Precise \
diff --git a/www/validator/Makefile b/www/validator/Makefile
index 1ab48fa4430c..0fd3178574f8 100644
--- a/www/validator/Makefile
+++ b/www/validator/Makefile
@@ -22,7 +22,7 @@ RUN_DEPENDS= onsgmls:${PORTSDIR}/textproc/opensp \
${SITE_PERL}/${PERL_ARCH}/HTML/Parser.pm:${PORTSDIR}/www/p5-HTML-Parser \
${SITE_PERL}/HTML/Encoding.pm:${PORTSDIR}/www/p5-HTML-Encoding \
${SITE_PERL}/HTML/Template.pm:${PORTSDIR}/www/p5-HTML-Template \
- ${SITE_PERL}/Bundle/LWP.pm:${PORTSDIR}/www/p5-libwww \
+ p5-libwww>=5.817:${PORTSDIR}/www/p5-libwww \
${SITE_PERL}/JSON.pm:${PORTSDIR}/converters/p5-JSON \
${SITE_PERL}/Net/IP.pm:${PORTSDIR}/net-mgmt/p5-Net-IP \
${SITE_PERL}/${PERL_ARCH}/SGML/Parser/OpenSP.pm:${PORTSDIR}/textproc/p5-SGML-Parser-OpenSP \