aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--math/Makefile1
-rw-r--r--math/p5-Math-SymbolicX-Statistics-Distributions/Makefile32
-rw-r--r--math/p5-Math-SymbolicX-Statistics-Distributions/distinfo3
-rw-r--r--math/p5-Math-SymbolicX-Statistics-Distributions/pkg-descr21
-rw-r--r--math/p5-Math-SymbolicX-Statistics-Distributions/pkg-plist9
5 files changed, 66 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 85554c5ce81f..06abe2446b93 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -197,6 +197,7 @@
SUBDIR += p5-Math-SymbolicX-Complex
SUBDIR += p5-Math-SymbolicX-Inline
SUBDIR += p5-Math-SymbolicX-ParserExtensionFactory
+ SUBDIR += p5-Math-SymbolicX-Statistics-Distributions
SUBDIR += p5-Math-TrulyRandom
SUBDIR += p5-Math-Vec
SUBDIR += p5-Math-VecStat
diff --git a/math/p5-Math-SymbolicX-Statistics-Distributions/Makefile b/math/p5-Math-SymbolicX-Statistics-Distributions/Makefile
new file mode 100644
index 000000000000..3eaf3fd60d03
--- /dev/null
+++ b/math/p5-Math-SymbolicX-Statistics-Distributions/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: Math-SymbolicX-Statistics-Distributions
+# Date created: 15 May 2006
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Math-SymbolicX-Statistics-Distributions
+PORTVERSION= 1.01
+CATEGORIES= math perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Math
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= Statistical distributions
+
+BUILD_DEPENDS= ${SITE_PERL}/Math/Symbolic.pm:${PORTSDIR}/math/p5-Math-Symbolic \
+ ${SITE_PERL}/Math/SymbolicX/ParserExtensionFactory.pm:${PORTSDIR}/math/p5-Math-SymbolicX-ParserExtensionFactory
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+MAN3= Math::SymbolicX::Statistics::Distributions.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires at least Perl 5.6 due to dependencies. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/math/p5-Math-SymbolicX-Statistics-Distributions/distinfo b/math/p5-Math-SymbolicX-Statistics-Distributions/distinfo
new file mode 100644
index 000000000000..3fa5a351d31e
--- /dev/null
+++ b/math/p5-Math-SymbolicX-Statistics-Distributions/distinfo
@@ -0,0 +1,3 @@
+MD5 (Math-SymbolicX-Statistics-Distributions-1.01.tar.gz) = 21dffd64338ff58b924557bbffb4ee6c
+SHA256 (Math-SymbolicX-Statistics-Distributions-1.01.tar.gz) = 2c19c21d416779df5c96c9b55f0b8e00b2c777ecb88d647b81e97ae6b3f3cb06
+SIZE (Math-SymbolicX-Statistics-Distributions-1.01.tar.gz) = 7033
diff --git a/math/p5-Math-SymbolicX-Statistics-Distributions/pkg-descr b/math/p5-Math-SymbolicX-Statistics-Distributions/pkg-descr
new file mode 100644
index 000000000000..6727cc6f03ec
--- /dev/null
+++ b/math/p5-Math-SymbolicX-Statistics-Distributions/pkg-descr
@@ -0,0 +1,21 @@
+This module offers easy access to formulas for a few often-used
+distributions. For that, it uses the Math::Symbolic module which gives the
+user an opportunity to manufacture distributions to his liking.
+
+The module can be used in two styles: It has a procedural interface which
+is demonstrated in the first half of the synopsis. But it also features a
+wholly different interface: It can modify the Math::Symbolic parser so
+that you can use the distributions right inside strings that will be
+parsed as Math::Symbolic trees. This is demonstrated for very simple cases
+in the second half of the synopsis.
+
+All arguments in both interface styles are optional. Whichever expression
+is used instead of, for examle 'mean', is plugged into the formula for the
+distribution as a Math::Symbolic tree. Details on argument handling are
+explained below.
+
+Please see the section on Export for details on how to choose the
+interface style you want to use.
+
+WWW: http://search.cpan.org/dist/Math-SymbolicX-Statistics-Distributions
+Author: Steffen Mueller <symbolic-module@steffen-mueller.net>
diff --git a/math/p5-Math-SymbolicX-Statistics-Distributions/pkg-plist b/math/p5-Math-SymbolicX-Statistics-Distributions/pkg-plist
new file mode 100644
index 000000000000..5e363fdab995
--- /dev/null
+++ b/math/p5-Math-SymbolicX-Statistics-Distributions/pkg-plist
@@ -0,0 +1,9 @@
+%%SITE_PERL%%/Math/SymbolicX/Statistics/Distributions.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/SymbolicX/Statistics/Distributions/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/SymbolicX/Statistics/Distributions
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/SymbolicX/Statistics
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/SymbolicX
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Math
+@dirrm %%SITE_PERL%%/Math/SymbolicX/Statistics
+@dirrmtry %%SITE_PERL%%/Math/SymbolicX
+@dirrmtry %%SITE_PERL%%/Math