aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/rubygem-hiera-puppet/Makefile38
-rw-r--r--sysutils/rubygem-hiera-puppet/distinfo2
-rw-r--r--sysutils/rubygem-hiera-puppet/pkg-descr9
4 files changed, 50 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index c9cb7032b6b0..af6c2d6c51e8 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -784,6 +784,7 @@
SUBDIR += rubygem-guard-livereload
SUBDIR += rubygem-guard-rspec
SUBDIR += rubygem-hiera
+ SUBDIR += rubygem-hiera-puppet
SUBDIR += rubygem-log4r
SUBDIR += rubygem-murder
SUBDIR += rubygem-ohai
diff --git a/sysutils/rubygem-hiera-puppet/Makefile b/sysutils/rubygem-hiera-puppet/Makefile
new file mode 100644
index 000000000000..397201f34b8a
--- /dev/null
+++ b/sysutils/rubygem-hiera-puppet/Makefile
@@ -0,0 +1,38 @@
+# Ports collection makefile for: hiera-puppet
+# Date created: 10 May 2012
+# Whom: Greg Larkin <glarkin@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= hiera-puppet
+PORTVERSION= 0.3.0
+CATEGORIES= sysutils rubygems
+MASTER_SITES= RG
+
+MAINTAINER= glarkin@FreeBSD.org
+COMMENT= A data backend for Hiera that queries the Puppet scope for data
+
+RUN_DEPENDS= puppet:${PORTSDIR}/sysutils/puppet \
+ rubygem-hiera:${PORTSDIR}/sysutils/rubygem-hiera
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+HIERA_DBDIR= /var/db/hiera
+
+dummy-post-install:
+ @${REINPLACE_CMD} "s!/etc/hiera.yaml!${PREFIX}/etc/hiera.yaml!" \
+ ${PREFIX}/${GEM_LIB_DIR}/bin/hiera \
+ ${PREFIX}/${GEM_LIB_DIR}/lib/hiera.rb \
+ ${PREFIX}/${GEM_LIB_DIR}/spec/unit/hiera_spec.rb
+ @${REINPLACE_CMD} "s!/var/lib/hiera!${HIERA_DBDIR}!" \
+ ${PREFIX}/${GEM_LIB_DIR}/lib/hiera/backend.rb \
+ ${PREFIX}/${GEM_LIB_DIR}/spec/unit/backend_spec.rb
+ @${MKDIR} ${HIERA_DBDIR}
+ @${ECHO_CMD} '@cwd /' >> ${TMPPLIST}
+ @${ECHO_CMD} "@exec ${MKDIR} ${HIERA_DBDIR}" >> ${TMPPLIST}
+ @${ECHO_CMD} "@unexec ${RMDIR} \"%D/${HIERA_DBDIR}\" 2>/dev/null || true" >> ${TMPPLIST}
+ @${ECHO_CMD} '@cwd' >> ${TMPPLIST}
+
+.include <bsd.port.mk>
diff --git a/sysutils/rubygem-hiera-puppet/distinfo b/sysutils/rubygem-hiera-puppet/distinfo
new file mode 100644
index 000000000000..ef8e2feb4afe
--- /dev/null
+++ b/sysutils/rubygem-hiera-puppet/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rubygem/hiera-puppet-0.3.0.gem) = bee1c598d1a90910baa8a417b622854a682f1d56317a544d6b82972458785d95
+SIZE (rubygem/hiera-puppet-0.3.0.gem) = 7168
diff --git a/sysutils/rubygem-hiera-puppet/pkg-descr b/sysutils/rubygem-hiera-puppet/pkg-descr
new file mode 100644
index 000000000000..80c9a756f08e
--- /dev/null
+++ b/sysutils/rubygem-hiera-puppet/pkg-descr
@@ -0,0 +1,9 @@
+Hiera-puppet is a data backend for Hiera that queries the internal
+Puppet scope for data. The data structure and approach is heavily
+based on work by Nigel Kersten but made more configurable and with
+full hierarchy.
+
+It also includes a Puppet function that works like extlookup() but
+uses the Hiera backends.
+
+WWW: https://github.com/puppetlabs/hiera-puppet