aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--devel/p5-Attribute-Persistent/Makefile4
-rw-r--r--devel/p5-CommitBit/Makefile2
-rw-r--r--devel/p5-DateTime-Event-Cron/Makefile6
-rw-r--r--devel/p5-DateTime-Format-Duration/Makefile2
-rw-r--r--devel/p5-DateTime-Format-Excel/Makefile2
-rw-r--r--devel/p5-DateTime-Functions/Makefile2
-rw-r--r--devel/p5-IOC/Makefile10
-rw-r--r--devel/p5-Inline-Filters/Makefile2
-rw-r--r--devel/p5-POE-Component-RSS/Makefile4
-rw-r--r--devel/p5-Test-Log4perl/Makefile8
-rw-r--r--russian/p5-XML-Parser-encodings/Makefile4
-rw-r--r--security/p5-Authen-SASL-Cyrus/Makefile2
-rw-r--r--security/p5-Authen-Simple-SSH/Makefile4
-rw-r--r--security/p5-Crypt-DES_EDE3/Makefile2
-rw-r--r--security/p5-OpenCA-REQ/Makefile2
15 files changed, 28 insertions, 28 deletions
diff --git a/devel/p5-Attribute-Persistent/Makefile b/devel/p5-Attribute-Persistent/Makefile
index 1cfc32f8d323..ea3938a504ed 100644
--- a/devel/p5-Attribute-Persistent/Makefile
+++ b/devel/p5-Attribute-Persistent/Makefile
@@ -14,8 +14,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Attribute::Persistent - Really lazy persistence
-BUILD_DEPENDS= ${SITE_PERL}/Attribute/Handlers/Prospective.pm:${PORTSDIR}/devel/p5-Attribute-Handlers-Prospective \
- ${SITE_PERL}/MLDBM.pm:${PORTSDIR}/databases/p5-MLDBM
+BUILD_DEPENDS= p5-Attribute-Handlers-Prospective>=0:${PORTSDIR}/devel/p5-Attribute-Handlers-Prospective \
+ p5-MLDBM>=0:${PORTSDIR}/databases/p5-MLDBM
PERL_CONFIGURE= yes
diff --git a/devel/p5-CommitBit/Makefile b/devel/p5-CommitBit/Makefile
index ffdbb7c21ed5..937da7894928 100644
--- a/devel/p5-CommitBit/Makefile
+++ b/devel/p5-CommitBit/Makefile
@@ -16,7 +16,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= A project administration tool
-RUN_DEPENDS= ${SITE_PERL}/UNIVERSAL/require.pm:${PORTSDIR}/devel/p5-UNIVERSAL-require \
+RUN_DEPENDS= p5-UNIVERSAL-require>=0:${PORTSDIR}/devel/p5-UNIVERSAL-require \
p5-Jifty>=0.60728:${PORTSDIR}/www/p5-Jifty \
p5-Text-Password-Pronounceable>=0:${PORTSDIR}/security/p5-Text-Password-Pronounceable
diff --git a/devel/p5-DateTime-Event-Cron/Makefile b/devel/p5-DateTime-Event-Cron/Makefile
index 6c7c3e14a8c1..f7f443dfb6c9 100644
--- a/devel/p5-DateTime-Event-Cron/Makefile
+++ b/devel/p5-DateTime-Event-Cron/Makefile
@@ -14,9 +14,9 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= DateTime extension for generating recurrence sets from crontab
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DateTime.pm:${PORTSDIR}/devel/p5-DateTime \
- ${SITE_PERL}/DateTime/Set.pm:${PORTSDIR}/devel/p5-DateTime-Set \
- ${SITE_PERL}/Set/Crontab.pm:${PORTSDIR}/devel/p5-Set-Crontab
+BUILD_DEPENDS= p5-DateTime>=0:${PORTSDIR}/devel/p5-DateTime \
+ p5-DateTime-Set>=0:${PORTSDIR}/devel/p5-DateTime-Set \
+ p5-Set-Crontab>=0:${PORTSDIR}/devel/p5-Set-Crontab
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/devel/p5-DateTime-Format-Duration/Makefile b/devel/p5-DateTime-Format-Duration/Makefile
index 2fe1dea4c02a..703f16f4e30e 100644
--- a/devel/p5-DateTime-Format-Duration/Makefile
+++ b/devel/p5-DateTime-Format-Duration/Makefile
@@ -15,7 +15,7 @@ EXTRACT_SUFX= .tgz
MAINTAINER= perl@FreeBSD.org
COMMENT= Format and parse DateTime::Durations
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DateTime.pm:${PORTSDIR}/devel/p5-DateTime
+BUILD_DEPENDS= p5-DateTime>=0:${PORTSDIR}/devel/p5-DateTime
RUN_DEPENDS:= ${BUILD_DEPENDS}
WRKSRC= ${WRKDIR}/${DISTNAME:C/a$//}
diff --git a/devel/p5-DateTime-Format-Excel/Makefile b/devel/p5-DateTime-Format-Excel/Makefile
index d8e9fea04595..0d03a06913f9 100644
--- a/devel/p5-DateTime-Format-Excel/Makefile
+++ b/devel/p5-DateTime-Format-Excel/Makefile
@@ -15,7 +15,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Convert between DateTime and Excel dates
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DateTime.pm:${PORTSDIR}/devel/p5-DateTime
+BUILD_DEPENDS= p5-DateTime>=0:${PORTSDIR}/devel/p5-DateTime
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_MODBUILD= yes
diff --git a/devel/p5-DateTime-Functions/Makefile b/devel/p5-DateTime-Functions/Makefile
index ec1fe8e53f05..a4c139688585 100644
--- a/devel/p5-DateTime-Functions/Makefile
+++ b/devel/p5-DateTime-Functions/Makefile
@@ -14,7 +14,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Procedural interface to DateTime functions
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DateTime.pm:${PORTSDIR}/devel/p5-DateTime
+BUILD_DEPENDS= p5-DateTime>=0:${PORTSDIR}/devel/p5-DateTime
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/devel/p5-IOC/Makefile b/devel/p5-IOC/Makefile
index 640136da6d22..aff4053167e6 100644
--- a/devel/p5-IOC/Makefile
+++ b/devel/p5-IOC/Makefile
@@ -16,11 +16,11 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Lightweight IOC (Inversion of Control) framework
-BUILD_DEPENDS= ${SITE_PERL}/Class/Throwable.pm:${PORTSDIR}/devel/p5-Class-Throwable \
- ${SITE_PERL}/XML/SAX.pm:${PORTSDIR}/textproc/p5-XML-SAX \
- ${SITE_PERL}/Test/Exception.pm:${PORTSDIR}/devel/p5-Test-Exception \
- ${SITE_PERL}/Class/StrongSingleton.pm:${PORTSDIR}/devel/p5-Class-StrongSingleton \
- ${SITE_PERL}/Class/Interfaces.pm:${PORTSDIR}/devel/p5-Class-Interfaces
+BUILD_DEPENDS= p5-Class-Throwable>=0:${PORTSDIR}/devel/p5-Class-Throwable \
+ p5-XML-SAX>=0:${PORTSDIR}/textproc/p5-XML-SAX \
+ p5-Test-Exception>=0:${PORTSDIR}/devel/p5-Test-Exception \
+ p5-Class-StrongSingleton>=0:${PORTSDIR}/devel/p5-Class-StrongSingleton \
+ p5-Class-Interfaces>=0:${PORTSDIR}/devel/p5-Class-Interfaces
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/devel/p5-Inline-Filters/Makefile b/devel/p5-Inline-Filters/Makefile
index dd93b77a5932..7b5a73a95497 100644
--- a/devel/p5-Inline-Filters/Makefile
+++ b/devel/p5-Inline-Filters/Makefile
@@ -14,7 +14,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Common source code filters for Inline Modules
-BUILD_DEPENDS= ${SITE_PERL}/Inline.pm:${PORTSDIR}/devel/p5-Inline
+BUILD_DEPENDS= p5-Inline>=0:${PORTSDIR}/devel/p5-Inline
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/devel/p5-POE-Component-RSS/Makefile b/devel/p5-POE-Component-RSS/Makefile
index 5e7d8348c360..3f0742698d12 100644
--- a/devel/p5-POE-Component-RSS/Makefile
+++ b/devel/p5-POE-Component-RSS/Makefile
@@ -14,8 +14,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= A module for event based RSS parsing
-BUILD_DEPENDS= ${SITE_PERL}/POE.pm:${PORTSDIR}/devel/p5-POE \
- ${SITE_PERL}/XML/RSS.pm:${PORTSDIR}/textproc/p5-XML-RSS
+BUILD_DEPENDS= p5-POE>=0:${PORTSDIR}/devel/p5-POE \
+ p5-XML-RSS>=0:${PORTSDIR}/textproc/p5-XML-RSS
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/devel/p5-Test-Log4perl/Makefile b/devel/p5-Test-Log4perl/Makefile
index 01c46c5395e4..197125298002 100644
--- a/devel/p5-Test-Log4perl/Makefile
+++ b/devel/p5-Test-Log4perl/Makefile
@@ -14,10 +14,10 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Test::Log4perl - test Log::Log4perl
-BUILD_DEPENDS= ${SITE_PERL}/Test/Exception.pm:${PORTSDIR}/devel/p5-Test-Exception \
- ${SITE_PERL}/Lingua/EN/Numbers/Ordinate.pm:${PORTSDIR}/textproc/p5-Lingua-EN-Numbers-Ordinate \
- ${SITE_PERL}/Class/Accessor/Chained.pm:${PORTSDIR}/devel/p5-Class-Accessor-Chained \
- ${SITE_PERL}/Log/Log4perl.pm:${PORTSDIR}/devel/p5-Log-Log4perl
+BUILD_DEPENDS= p5-Test-Exception>=0:${PORTSDIR}/devel/p5-Test-Exception \
+ p5-Lingua-EN-Numbers-Ordinate>=0:${PORTSDIR}/textproc/p5-Lingua-EN-Numbers-Ordinate \
+ p5-Class-Accessor-Chained>=0:${PORTSDIR}/devel/p5-Class-Accessor-Chained \
+ p5-Log-Log4perl>=0:${PORTSDIR}/devel/p5-Log-Log4perl
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/russian/p5-XML-Parser-encodings/Makefile b/russian/p5-XML-Parser-encodings/Makefile
index 91ec099ca642..d647878b7658 100644
--- a/russian/p5-XML-Parser-encodings/Makefile
+++ b/russian/p5-XML-Parser-encodings/Makefile
@@ -15,8 +15,8 @@ MAINTAINER= perl@FreeBSD.org
COMMENT= Additional russian encodings for XML::Parser
RUN_DEPENDS= p5-XML-Parser>=2.40:${PORTSDIR}/textproc/p5-XML-Parser
-BUILD_DEPENDS= ${RUN_DEPENDS} \
- ${SITE_PERL}/XML/Encoding.pm:${PORTSDIR}/textproc/p5-XML-Encoding \
+BUILD_DEPENDS:= ${RUN_DEPENDS} \
+ p5-XML-Encoding>=0:${PORTSDIR}/textproc/p5-XML-Encoding \
${NONEXISTENT}:${PORTSDIR}/converters/iconv:extract \
${NONEXISTENT}:${PORTSDIR}/converters/iconv-extra:extract
diff --git a/security/p5-Authen-SASL-Cyrus/Makefile b/security/p5-Authen-SASL-Cyrus/Makefile
index ff99379d52b3..4e1b50e96319 100644
--- a/security/p5-Authen-SASL-Cyrus/Makefile
+++ b/security/p5-Authen-SASL-Cyrus/Makefile
@@ -14,7 +14,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= XS SASL Authentication
-BUILD_DEPENDS= ${SITE_PERL}/Authen/SASL.pm:${PORTSDIR}/security/p5-Authen-SASL
+BUILD_DEPENDS= p5-Authen-SASL>=0:${PORTSDIR}/security/p5-Authen-SASL
LIB_DEPENDS= sasl2:${PORTSDIR}/security/cyrus-sasl2
RUN_DEPENDS:= ${BUILD_DEPENDS}
diff --git a/security/p5-Authen-Simple-SSH/Makefile b/security/p5-Authen-Simple-SSH/Makefile
index e35b80a6f853..b869920c5734 100644
--- a/security/p5-Authen-Simple-SSH/Makefile
+++ b/security/p5-Authen-Simple-SSH/Makefile
@@ -14,8 +14,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Simple SSH authentication
-BUILD_DEPENDS= ${SITE_PERL}/Authen/Simple.pm:${PORTSDIR}/security/p5-Authen-Simple \
- ${SITE_PERL}/Net/SSH/Perl.pm:${PORTSDIR}/net/p5-Net-SSH-Perl
+BUILD_DEPENDS= p5-Authen-Simple>=0:${PORTSDIR}/security/p5-Authen-Simple \
+ p5-Net-SSH-Perl>=0:${PORTSDIR}/net/p5-Net-SSH-Perl
RUN_DEPENDS:= ${BUILD_DEPENDS}
MAKE_JOBS_SAFE= yes
diff --git a/security/p5-Crypt-DES_EDE3/Makefile b/security/p5-Crypt-DES_EDE3/Makefile
index 3bb15364611e..216fba811358 100644
--- a/security/p5-Crypt-DES_EDE3/Makefile
+++ b/security/p5-Crypt-DES_EDE3/Makefile
@@ -15,7 +15,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Perl5 interface to a implementing 3-DES EDE encryption and decryption
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Crypt/DES.pm:${PORTSDIR}/security/p5-Crypt-DES
+BUILD_DEPENDS= p5-Crypt-DES>=0:${PORTSDIR}/security/p5-Crypt-DES
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/security/p5-OpenCA-REQ/Makefile b/security/p5-OpenCA-REQ/Makefile
index 467c67bd87eb..c21d23814147 100644
--- a/security/p5-OpenCA-REQ/Makefile
+++ b/security/p5-OpenCA-REQ/Makefile
@@ -14,7 +14,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Perl extension to easily manage Cert REQUESTs
-BUILD_DEPENDS= ${SITE_PERL}/X500/DN.pm:${PORTSDIR}/net/p5-X500-DN
+BUILD_DEPENDS= p5-X500-DN>=0:${PORTSDIR}/net/p5-X500-DN
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes