aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--comms/Makefile1
-rw-r--r--comms/esmska/Makefile45
-rw-r--r--comms/esmska/distinfo3
-rw-r--r--comms/esmska/files/esmska.in6
-rw-r--r--comms/esmska/pkg-descr16
-rw-r--r--comms/esmska/pkg-plist44
6 files changed, 115 insertions, 0 deletions
diff --git a/comms/Makefile b/comms/Makefile
index f92798e1b43b..5540f553bc3f 100644
--- a/comms/Makefile
+++ b/comms/Makefile
@@ -28,6 +28,7 @@
SUBDIR += echolinux
SUBDIR += efax
SUBDIR += efax-gtk
+ SUBDIR += esmska
SUBDIR += fldigi
SUBDIR += gammu
SUBDIR += garmin-utils
diff --git a/comms/esmska/Makefile b/comms/esmska/Makefile
new file mode 100644
index 000000000000..2a330ea6a908
--- /dev/null
+++ b/comms/esmska/Makefile
@@ -0,0 +1,45 @@
+# New ports collection makefile for: esmska
+# Date created: 18 Feb 2008
+# Whom: Martin Otto
+#
+# $FreeBSD$
+#
+
+PORTNAME= esmska
+PORTVERSION= 0.13.0
+CATEGORIES= comms java
+MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
+
+MAINTAINER= gamato@users.sf.net
+COMMENT= Program for sending SMS over the Internet
+
+RUN_DEPENDS= java:${PORTSDIR}/java/javavmwrapper
+
+USE_JAVA= yes
+JAVA_VERSION= 1.6+
+
+DATADIR= ${JAVASHAREDIR}/${PORTNAME}
+NO_BUILD= yes
+
+SUB_FILES= esmska
+
+PORTDOCS= readme.txt
+
+do-install:
+ @${MKDIR} ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/esmska.jar ${DATADIR}/
+ (cd ${WRKSRC}/ && ${COPYTREE_SHARE} icons ${DATADIR}/)
+ (cd ${WRKSRC}/ && ${COPYTREE_SHARE} lib ${DATADIR}/)
+ (cd ${WRKSRC}/ && ${COPYTREE_SHARE} license ${DATADIR}/)
+ (cd ${WRKSRC}/ && ${COPYTREE_SHARE} operators ${DATADIR}/)
+ ${INSTALL_SCRIPT} ${WRKDIR}/esmska ${PREFIX}/bin/
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for i in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}/
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/comms/esmska/distinfo b/comms/esmska/distinfo
new file mode 100644
index 000000000000..81cabe972af2
--- /dev/null
+++ b/comms/esmska/distinfo
@@ -0,0 +1,3 @@
+SHA256 (esmska-0.13.0.tar.gz) = 7e7988869dba5cbf586b5576f39ad18dfc706db86f1789a31a344dd1d55cffdf
+MD5 (esmska-0.13.0.tar.gz) = 6cc58e34a21aeac9c3ff7a1261fa1ca6
+SIZE (esmska-0.13.0.tar.gz) = 4670267
diff --git a/comms/esmska/files/esmska.in b/comms/esmska/files/esmska.in
new file mode 100644
index 000000000000..167bde324acb
--- /dev/null
+++ b/comms/esmska/files/esmska.in
@@ -0,0 +1,6 @@
+#!/bin/sh
+#
+# $FreeBSD$
+
+cd "%%DATADIR%%"
+JAVA_VERSION="%%JAVA_VERSION%%" exec "%%LOCALBASE%%/bin/java" -jar "%%DATADIR%%/esmska.jar" "$@"
diff --git a/comms/esmska/pkg-descr b/comms/esmska/pkg-descr
new file mode 100644
index 000000000000..83c00ebd1321
--- /dev/null
+++ b/comms/esmska/pkg-descr
@@ -0,0 +1,16 @@
+Esmska is a cross-platform application for sending SMS messages over the
+Internet.
+
+Features:
+ * Send SMS to various operators (local or international)
+ * Supports all common operating systems (Linux, Windows, Mac OS, etc.)
+ * Free, under open-source licence GNU AGPL3
+ * Import contacts from other programs (DreamCom) and formats (vCard)
+ * Send SMS to multiple recipients at once
+ * History of sent messages
+ * Pluggable operator system - easy to provide support for more operators
+ directly by users
+ * Extensive possibilities of changing appearance
+ * Many other planned features
+
+WWW: http://esmska.googlecode.com
diff --git a/comms/esmska/pkg-plist b/comms/esmska/pkg-plist
new file mode 100644
index 000000000000..3d6fff4d2fbd
--- /dev/null
+++ b/comms/esmska/pkg-plist
@@ -0,0 +1,44 @@
+bin/esmska
+%%DATADIR%%/esmska.jar
+%%DATADIR%%/icons/esmska.ico
+%%DATADIR%%/icons/esmska.png
+%%DATADIR%%/icons/esmska.svg
+%%DATADIR%%/lib/beansbinding-1.2.1.jar
+%%DATADIR%%/lib/commons-cli-1.1.jar
+%%DATADIR%%/lib/commons-codec-1.3.jar
+%%DATADIR%%/lib/commons-httpclient-3.1.jar
+%%DATADIR%%/lib/commons-io-1.4.jar
+%%DATADIR%%/lib/commons-lang-2.4.jar
+%%DATADIR%%/lib/commons-logging-1.1.1.jar
+%%DATADIR%%/lib/javacsv-2.0.jar
+%%DATADIR%%/lib/jpim.jar
+%%DATADIR%%/lib/js-engine.jar
+%%DATADIR%%/lib/js-1.7R1.jar
+%%DATADIR%%/lib/looks-2.1.4.jar
+%%DATADIR%%/lib/org-openide-awt.jar
+%%DATADIR%%/lib/org-openide-util.jar
+%%DATADIR%%/lib/substance-extras-5.0.jar
+%%DATADIR%%/lib/substance-5.1dev081129.jar
+%%DATADIR%%/license/gnu-agpl.txt
+%%DATADIR%%/license/license.txt
+%%DATADIR%%/operators/[CZ]O2.operator
+%%DATADIR%%/operators/[CZ]O2.png
+%%DATADIR%%/operators/[CZ]SMS.cz.operator
+%%DATADIR%%/operators/[CZ]SMS.cz.png
+%%DATADIR%%/operators/[CZ]T-mobile.operator
+%%DATADIR%%/operators/[CZ]T-mobile.png
+%%DATADIR%%/operators/[CZ]t-zones.operator
+%%DATADIR%%/operators/[CZ]t-zones.png
+%%DATADIR%%/operators/[CZ]Vodafone samoobsluha.operator
+%%DATADIR%%/operators/[CZ]Vodafone samoobsluha.png
+%%DATADIR%%/operators/[CZ]Vodafone.operator
+%%DATADIR%%/operators/[CZ]Vodafone.png
+%%DATADIR%%/operators/[INT]SMSdiscount.operator
+%%DATADIR%%/operators/[INT]SMSdiscount.png
+%%DATADIR%%/operators/[SK]Orange.operator
+%%DATADIR%%/operators/[SK]Orange.png
+@dirrm %%DATADIR%%/icons
+@dirrm %%DATADIR%%/lib
+@dirrm %%DATADIR%%/license
+@dirrm %%DATADIR%%/operators
+@dirrm %%DATADIR%%