aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--games/openbor/Makefile2
-rw-r--r--games/openbor/files/patch-openbor.c9
2 files changed, 10 insertions, 1 deletions
diff --git a/games/openbor/Makefile b/games/openbor/Makefile
index 3d50e242ed70..54e222e92f9c 100644
--- a/games/openbor/Makefile
+++ b/games/openbor/Makefile
@@ -2,7 +2,7 @@
PORTNAME= openbor
PORTVERSION= 3.0.r4415
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= games devel
MASTER_SITES= LOCAL/jbeich \
https://svn.code.sf.net/p/${PORTNAME}/engine/engine/:svn
diff --git a/games/openbor/files/patch-openbor.c b/games/openbor/files/patch-openbor.c
index d3af726c1212..4f1f134acf0b 100644
--- a/games/openbor/files/patch-openbor.c
+++ b/games/openbor/files/patch-openbor.c
@@ -18,6 +18,15 @@
// Allocate memory and get pointer.
result = malloc(alloc_size);
+@@ -20480,7 +20480,7 @@ void common_dot()
+ entity *eOpp; //Owner of dot effect.
+ s_collision_attack attack; //Attack struct.
+
+- for(iIndex = 0; iIndex <= MAX_DOTS; iIndex++) //Loop through all DOT indexes.
++ for(iIndex = 0; iIndex < MAX_DOTS; iIndex++) //Loop through all DOT indexes.
+ {
+ iDot_time = self->dot_time[iIndex]; //Get expire time.
+ iDot_cnt = self->dot_cnt[iIndex]; //Get next tick time.
@@ -34617,7 +34617,7 @@ void keyboard_setup(int player)
strncpy(buttonnames[SDID_SPECIAL], "Special", 16);
strncpy(buttonnames[SDID_START], "Start", 16);