aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--x11/mlterm/Makefile11
1 files changed, 10 insertions, 1 deletions
diff --git a/x11/mlterm/Makefile b/x11/mlterm/Makefile
index 9b48ea0dae25..007c594d5a59 100644
--- a/x11/mlterm/Makefile
+++ b/x11/mlterm/Makefile
@@ -33,7 +33,8 @@ OPTIONS= FRIBIDI "Use Fribidi for BiDi rendering" off \
M17NLIB "m17n library support (experimental)" off \
SCIM "SCIM support (experimental)" off \
IBUS "IBUS support (experimental)" off \
- CAIRO "Use Cairo for type engine (experimental)" off
+ CAIRO "Use Cairo for type engine (experimental)" off \
+ SIXEL "Sixel graphics support" off
.include <bsd.port.pre.mk>
@@ -96,6 +97,14 @@ CONFIGURE_ARGS+= --with-type-engines="xcore,xft"
PLIST_SUB+= CAIRO="@comment "
.endif
+.if defined(WITH_SIXEL)
+CONFIGURE_ARGS+= --enable-sixel
+PLIST_SUB+= SIXEL=""
+.else
+CONFIGURE_ARGS+= --disable-sixel
+PLIST_SUB+= SIXEL="@comment "
+.endif
+
.if ${OSVERSION} >= 900004
MAKE_ENV= LIBS_LOCAL=-lutempter
.else