aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--science/gamess/Makefile32
-rw-r--r--science/gamess/distinfo6
-rw-r--r--science/gamess/files/patch-comp16
-rw-r--r--science/gamess/files/patch-compall10
-rw-r--r--science/gamess/files/patch-compddi14
-rw-r--r--science/gamess/files/patch-lked25
-rw-r--r--science/gamess/files/patch-rungms59
-rw-r--r--science/gamess/pkg-plist2
8 files changed, 85 insertions, 79 deletions
diff --git a/science/gamess/Makefile b/science/gamess/Makefile
index e61ee5421b7a..bb96df00d894 100644
--- a/science/gamess/Makefile
+++ b/science/gamess/Makefile
@@ -7,7 +7,6 @@
PORTNAME= gamess
PORTVERSION= ${SNAPDATE}
-PORTREVISION= 1
CATEGORIES= science
MASTER_SITES= #http://www.msg.ameslab.gov/GAMESS/License_Agreement.html
DISTNAME= gamess-current
@@ -18,7 +17,7 @@ COMMENT= A freely obtainable ab-initio molecular orbital calculation program
USE_GMAKE= yes
WRKSRC= ${WRKDIR}/gamess
-SNAPDATE= 20070524.3
+SNAPDATE= 20090112.1
USE_FORTRAN= yes
@@ -33,17 +32,32 @@ MANUAL_PACKAGE_BUILD=You must manually get the source distribution from master s
.include <bsd.port.pre.mk>
-.if exists(${LOCALBASE}/lib/libatlas_r.so) && !defined(WITH_BLAS)
-WITH_ATLAS= yes
+USE_BLAS?= reference
+
+.if exists(${LOCALBASE}/lib/libgoto.so)
+USE_BLAS= gotoblas
+.elif exists(${LOCALBASE}/lib/libatlas_r.so)
+USE_BLAS= atlas
.endif
-.if defined(WITH_ATLAS)
-LIB_DEPENDS+= atlas.2:${PORTSDIR}/math/atlas
-BLAS= -lf77blas -latlas
-.else
+
+. if ${USE_BLAS} == reference
LIB_DEPENDS+= blas.2:${PORTSDIR}/math/blas
+LIB_DEPENDS+= lapack.4:${PORTSDIR}/math/lapack
BLAS= -lblas
+LAPACK= -llapack
+.elif ${USE_BLAS} == gotoblas
+LIB_DEPENDS+= goto:${PORTSDIR}/math/gotoblas
+LIB_DEPENDS+= lapack.4:${PORTSDIR}/math/lapack
+BLAS= -lgotop
+LAPACK= -lgotop -llapack
+.elif ${USE_BLAS} == atlas
+LIB_DEPENDS+= atlas:${PORTSDIR}/math/atlas
+BLAS= -lptf77blas -lptcblas -latlas_r
+LAPACK= -lalapack_r
.endif
+MAKE_ENV+= LANG="C"
+
.if defined(WITH_OPTIMIZED_FLAGS)
.if ${ARCH} == "amd64"
CFLAGS+= -pipe -O3 -ffast-math -funroll-all-loops -fpeel-loops -ftracer -funswitch-loops -funit-at-a-time
@@ -62,7 +76,7 @@ CC= ${LOCALBASE}/intel_cc_80/bin/icc
FFLAGS= -axP -xW -ipo -O3 -Vaxlib
CFLAGS= -axP -xW -ipo -O3 -Vaxlib
LIBSVM= -lsvml
-LIBG2C= -lg2c
+LIBG2C= -lg2c
.else
LIBG2C=
LIBSVM=
diff --git a/science/gamess/distinfo b/science/gamess/distinfo
index 42c42f2fe587..cc1411627d02 100644
--- a/science/gamess/distinfo
+++ b/science/gamess/distinfo
@@ -1,3 +1,3 @@
-MD5 (gamess/20070524.3/gamess-current.tar.gz) = 566fbdb5890abe2c04d1b5458400405b
-SHA256 (gamess/20070524.3/gamess-current.tar.gz) = c9650cca2c2f7b5973636d4d49f907fc5f975f430b0f78dd7d2ee2d83109900d
-SIZE (gamess/20070524.3/gamess-current.tar.gz) = 8219816
+MD5 (gamess/20090112.1/gamess-current.tar.gz) = a4141c0a3eac0d729192a3e0821ea6a3
+SHA256 (gamess/20090112.1/gamess-current.tar.gz) = 9f7763933479ba8aa730c392af25b8a271152115a0392707786b45871b52f6e0
+SIZE (gamess/20090112.1/gamess-current.tar.gz) = 10823509
diff --git a/science/gamess/files/patch-comp b/science/gamess/files/patch-comp
index 226790fde116..c728947b184a 100644
--- a/science/gamess/files/patch-comp
+++ b/science/gamess/files/patch-comp
@@ -1,9 +1,9 @@
---- comp.orig Wed Jul 11 05:00:07 2007
-+++ comp Thu Aug 2 11:09:35 2007
+--- comp.orig 2009-01-11 00:10:02.000000000 +0900
++++ comp 2009-05-08 12:12:09.000000000 +0900
@@ -9,11 +9,11 @@
# axp64,compaq-sc,cray-pvp,cray-t3e,cray-x1,cray-xd1,cray-xt3,
# fuji-pp32,fuji-pp64,hpux32,hpux64,ibm32,ibm64,ibm64-sp,ibm-bg,
- # linux32,linux64,linux-ia64,mac32,macG5,necsx,
+ # linux32,linux64,linux-ia64,mac32,mac64,macG5,necsx,
-# sgi32,sgi64,sun32,sun64
+# sgi32,sgi64,sun32,sun64,freebsd-amd64,freebsd-i386
# 2. Choose your GAMESS directory tree.
@@ -22,18 +22,18 @@
+if ($TARGET == freebsd-amd64) set OK=true
+if ($TARGET == freebsd-i386) set OK=true
if ($TARGET == mac32) set OK=true
+ if ($TARGET == mac64) set OK=true
if ($TARGET == macG5) set OK=true
- if ($TARGET == necsx) set OK=true
-@@ -108,6 +110,8 @@
- if ($TARGET == linux-ia64) set BLAS3=true
+@@ -110,6 +112,8 @@
if ($TARGET == mac32) set BLAS3=true
+ if ($TARGET == mac64) set BLAS3=true
if ($TARGET == macG5) set BLAS3=true
+if ($TARGET == freebsd-i386) set BLAS3=true
+if ($TARGET == freebsd-amd64) set BLAS3=true
if ($TARGET == sgi32) set BLAS3=true
if ($TARGET == sgi64) set BLAS3=true
if (($TARGET == sun32) && (-e /opt/SUNWspro/lib/libsunperf.so)) set BLAS3=true
-@@ -491,6 +495,19 @@
+@@ -493,6 +497,19 @@
if ($MODULE == iolib) setenv MACHIN '*UNX'
if ($MODULE == unport) setenv MACHIN '*INT'
endif
@@ -53,7 +53,7 @@
if (($TARGET == mac32) || ($TARGET == macG5)) then
setenv MACHIN '*I32'
if ($MODULE == ddi) setenv MACHIN '*SOC'
-@@ -1738,6 +1755,236 @@
+@@ -1832,6 +1849,236 @@
#-- f77 -c $OPT -stackvar $MODULE.f
#-- unset echo
#--endif
diff --git a/science/gamess/files/patch-compall b/science/gamess/files/patch-compall
index 47879c424f88..b9b38b4c6370 100644
--- a/science/gamess/files/patch-compall
+++ b/science/gamess/files/patch-compall
@@ -1,9 +1,9 @@
---- compall.orig Wed Jul 11 05:00:13 2007
-+++ compall Thu Aug 2 11:11:44 2007
+--- compall.orig 2009-01-07 06:20:46.000000000 +0900
++++ compall 2009-05-08 12:14:14.000000000 +0900
@@ -10,11 +10,11 @@
# axp64,compaq-sc,cray-pvp,cray-t3e,cray-x1,cray-xd1,cray-xt3,
# fuji-pp32,fuji-pp64,hpux32,hpux64,ibm32,ibm64,ibm64-sp,ibm-bg,
- # linux32,linux64,linux-ia64,mac32,macG5,necsx,
+ # linux32,linux64,linux-ia64,mac32,mac64,macG5,necsx,
-# sgi32,sgi64,sun32,sun64
+# sgi32,sgi64,sun32,sun64,freebsd-i386,freebsd-amd64
# 2. Choose your GAMESS directory tree.
@@ -24,12 +24,12 @@
#
unset extraflags
if ($TARGET == axp64) set extraflags='-DCOMPAQ'
-@@ -98,6 +100,8 @@
+@@ -99,6 +101,8 @@
if (`uname -p` == x86_64) set extraflags='-DLINUX64 -m64'
if (`uname -p` == ia64) set extraflags='-DLINUX64' # its always 64 bits
endif
+if ($TARGET == freebsd-amd64) set extraflags='-DLINUX64 -m64'
+if ($TARGET == freebsd-i386) set extraflags='-DLINUX32'
if ($TARGET == mac32) set extraflags='-DLINUX32'
+ if ($TARGET == mac64) set extraflags='-DLINUX64 -m64 -I/usr/include/malloc'
if ($TARGET == macG5) set extraflags='-DLINUX32'
- if ($TARGET == necsx) set extraflags='-DNECSX -size_t64'
diff --git a/science/gamess/files/patch-compddi b/science/gamess/files/patch-compddi
index 8e25bd94c53c..6196abf36b00 100644
--- a/science/gamess/files/patch-compddi
+++ b/science/gamess/files/patch-compddi
@@ -1,18 +1,18 @@
---- ddi/compddi.orig Wed Jul 11 05:01:19 2007
-+++ ddi/compddi Thu Aug 2 11:13:19 2007
+--- ddi/compddi.orig 2008-12-04 01:22:29.000000000 +0900
++++ ddi/compddi 2009-05-08 12:15:46.000000000 +0900
@@ -13,9 +13,9 @@
# axp64,compaq-sc,cray-pvp,cray-t3e,cray-x1,cray-xd1,cray-xt3,
# fuji-pp32,fuji-pp64,hpux32,hpux64,ibm32,ibm64,ibm64-sp,ibm-bg,
- # linux32,linux64,linux-ia64,mac32,macG5,necsx,
+ # linux32,linux64,linux-ia64,mac32,mac64,macG5,necsx,
-# sgi32,sgi64,sun32,sun64
+# sgi32,sgi64,sun32,sun64,freebsd-i386,freebsd-amd64
#
- set TARGET = ibm64
-+ set TARGET = %%ARCH%%
++ set TARGET = %%ARCH%%
# 2. Choose DDI communication layer, the only legal values are
# sockets,mixed,mpi,shmem,lapi,armci
-@@ -638,7 +638,77 @@
+@@ -639,7 +639,77 @@
set RANLIB_FLAGS = ' '
endif
@@ -88,5 +88,5 @@
+
+ endif
- # ------------------------- #
- # Mac OS X (10.2 or 10.3) #
+ # -------- #
+ # Mac OS X #
diff --git a/science/gamess/files/patch-lked b/science/gamess/files/patch-lked
index 9f60dbf2b0f0..b5e67825e834 100644
--- a/science/gamess/files/patch-lked
+++ b/science/gamess/files/patch-lked
@@ -1,9 +1,9 @@
---- lked.orig Wed Jul 11 05:00:02 2007
-+++ lked Thu Aug 2 11:14:45 2007
+--- lked.orig 2009-01-10 04:44:05.000000000 +0900
++++ lked 2009-05-08 12:18:46.000000000 +0900
@@ -12,11 +12,11 @@
# axp64,compaq-sc,cray-pvp,cray-t3e,cray-x1,cray-xd1,cray-xt3,
# fuji-pp32,fuji-pp64,hpux32,hpux64,ibm32,ibm64,ibm64-sp,ibm-bg,
- # linux32,linux64,linux-ia64,mac32,macG5,necsx,
+ # linux32,linux64,linux-ia64,mac32,mac64,macG5,necsx,
-# sgi32,sgi64,sun32,sun64
+# sgi32,sgi64,sun32,sun64,freebsd-i386,freebsd-amd64
# 2. Choose your GAMESS directory tree.
@@ -15,10 +15,11 @@
#
# ---- and now the script begins...
#
-@@ -518,6 +518,23 @@
- # MacIntosh, clauses for using g77 or xlf.
- # If Atlas was downloaded, it may be a little faster than Apple's.
- #
+@@ -605,6 +605,23 @@
+ set VECTOR=' '
+ set QUICHE='zunix.o'
+ endif
++#FreeBSD settings
+if ($TARGET == freebsd-i386) then
+ set LDR=%%FC%%
+ set LDOPTS=''
@@ -35,17 +36,17 @@
+ set VECTOR=' '
+ set QUICHE='zunix.o'
+endif
-+
- if ($TARGET == mac32) then
- set LDR='g77'
- set LDOPTS='-Wl,-multiply_defined -Wl,suppress' # add '-Wl,-M' for load map
-@@ -627,12 +644,14 @@
+ #
+ if ($TARGET == necsx) then
+ set LDR='f90'
+@@ -693,13 +710,15 @@
case linux32:
case linux64:
case linux-ia64:
+ case freebsd-amd64:
+ case freebsd-i386:
case mac32:
+ case mac64:
case macG5:
case sgi32:
case sun32:
diff --git a/science/gamess/files/patch-rungms b/science/gamess/files/patch-rungms
index 6467b62d3262..c02ad6c565fc 100644
--- a/science/gamess/files/patch-rungms
+++ b/science/gamess/files/patch-rungms
@@ -1,12 +1,12 @@
---- rungms.orig Wed Jun 6 17:03:07 2007
-+++ rungms Wed Sep 26 14:31:55 2007
+--- rungms.orig 2009-01-17 03:17:33.000000000 +0900
++++ rungms 2009-05-08 14:27:35.000000000 +0900
@@ -1,4 +1,4 @@
-#!/bin/csh
+#!/bin/csh -f
#
- # 9 May 07 - MWS
+ # last update = 6 January 2009
#
-@@ -54,7 +54,13 @@
+@@ -55,7 +55,13 @@
# of using LoadLeveler via a "llgms" front end in ~/gamess/misc.
#
set TARGET=sockets
@@ -21,7 +21,7 @@
#
set JOB=$1 # name of the input file xxx.inp, give only the xxx part
set VERNO=$2 # revision number of the executable created by 'lked' step
-@@ -66,35 +72,45 @@
+@@ -67,36 +73,29 @@
#
# ---- the top third of the script is input and other file assignments ----
#
@@ -38,6 +38,7 @@
+#df -k $SCR
# this added as experiment, February 2007
+ # its intent is to detect large arrays allocated off the stack
-limit stacksize 8192
+#limit stacksize 8192
+
@@ -70,27 +71,10 @@
- exit 4
- endif
-endif
-+#if ($JOB:r.inp == $JOB) set JOB=$JOB:r # strip off possible .inp
-+#if (-e $JOB.inp) then
-+# set echo
-+# cp $JOB.inp $SCR/$JOB.F05
-+# unset echo
-+#else
-+# if (-e tests/$JOB.inp) then
-+# set echo
-+# cp tests/$JOB.inp $SCR/$JOB.F05
-+# unset echo
-+# else
-+# echo "Input file $JOB.inp does not exist."
-+# echo "This job expected the input file to be in directory `pwd`"
-+# echo "Please fix your file name problem, and resubmit."
-+# exit 4
-+# endif
-+#endif
# file assignments.
#
-@@ -117,16 +133,16 @@
+@@ -120,19 +119,20 @@
# d. see NEO plug-in code's documentation regarding the NUCBAS file.
# Note that you must edit a+b, but will probably skip c+d.
#
@@ -104,7 +88,14 @@
setenv EXTBAS /dev/null
setenv NUCBAS /dev/null
#
--setenv IRCDATA ~$USER/scr/$JOB.irc
+-setenv MAKEFP ~$USER/scr/$JOB.efp
+-setenv GAMMA ~$USER/scr/$JOB.gamma
+-setenv TRAJECT ~$USER/scr/$JOB.trj
+-setenv RESTART ~$USER/scr/$JOB.rst
++setenv MAKEFP $SCR/scr/$JOB.efp
++setenv GAMMA $SCR/scr/$JOB.gamma
++setenv TRAJECT $SCR/scr/$JOB.trj
++setenv RESTART $SCR/scr/$JOB.rst
+setenv IRCDATA $SCR/$JOB.irc
setenv INPUT $SCR/$JOB.F05
-setenv PUNCH ~$USER/scr/$JOB.dat
@@ -112,14 +103,12 @@
setenv AOINTS $SCR/$JOB.F08
setenv MOINTS $SCR/$JOB.F09
setenv DICTNRY $SCR/$JOB.F10
-@@ -156,8 +172,8 @@
- setenv SOINTY $SCR/$JOB.F32
- setenv SOINTZ $SCR/$JOB.F33
- setenv SORESC $SCR/$JOB.F34
--setenv SIMEN ~$USER/scr/$JOB.simen
--setenv SIMCOR ~$USER/scr/$JOB.simcor
-+setenv SIMEN $SCR/$JOB.simen
-+setenv SIMCOR $SCR/$JOB.simcor
- setenv GCILIST $SCR/$JOB.F37
- setenv HESSIAN $SCR/$JOB.F38
- setenv SOCCDAT $SCR/$JOB.F40
+@@ -308,7 +308,7 @@
+ if (null$4 == null) set ELGNAME=ELGFILE
+ set echo
+ setenv AOINTS $SCR/$ELGNAME.F08
+- setenv ELGDOS ~$USER/scr/$JOB.ldos
++ setenv ELGDOS $SCR/$JOB.ldos
+ setenv ELGDAT $SCR/$ELGNAME.F71
+ setenv ELGPAR $SCR/$ELGNAME.F72
+ setenv ELGCUT $SCR/$ELGNAME.F74
diff --git a/science/gamess/pkg-plist b/science/gamess/pkg-plist
index bcc5e7557794..7b7419741918 100644
--- a/science/gamess/pkg-plist
+++ b/science/gamess/pkg-plist
@@ -58,6 +58,8 @@ share/examples/gamess/exam39.inp
share/examples/gamess/exam40.inp
share/examples/gamess/exam41.inp
share/examples/gamess/exam42.inp
+share/examples/gamess/exam43.inp
+share/examples/gamess/exam44.inp
@dirrm bin/gms
@dirrm share/doc/gamess
@dirrm share/gamess/mcpdata