aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--lang/ghc/bsd.hackage.mk1
-rw-r--r--x11-toolkits/hs-wxc/Makefile30
-rw-r--r--x11-toolkits/hs-wxc/distinfo2
-rw-r--r--x11-toolkits/hs-wxc/pkg-descr9
4 files changed, 42 insertions, 0 deletions
diff --git a/lang/ghc/bsd.hackage.mk b/lang/ghc/bsd.hackage.mk
index 5ed7f5fa4a84..587ccaf17cd5 100644
--- a/lang/ghc/bsd.hackage.mk
+++ b/lang/ghc/bsd.hackage.mk
@@ -310,6 +310,7 @@ wai-logger_port= www/hs-wai-logger
warp_port= www/hs-warp
webkit_port= www/hs-webkit
wx_port= x11-toolkits/hs-wx
+wxc_port= x11-toolkits/hs-wxc # lib_depends
wxcore_port= x11-toolkits/hs-wxcore # lib_depends
wxdirect_port= x11-toolkits/hs-wxdirect # executable
X11_port= x11/hs-X11 # lib_depends
diff --git a/x11-toolkits/hs-wxc/Makefile b/x11-toolkits/hs-wxc/Makefile
new file mode 100644
index 000000000000..8fc63fbde07b
--- /dev/null
+++ b/x11-toolkits/hs-wxc/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: hs-wxc
+# Date created: May 9, 2012
+# Whom: haskell@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= wxc
+PORTVERSION= 0.90.0.3
+CATEGORIES= x11-toolkits haskell
+
+MAINTAINER= haskell@FreeBSD.org
+COMMENT= wxHaskell C++ wrapper
+
+CABAL_SETUP= Setup.hs
+
+USE_CABAL= wxdirect>=0.90
+
+USE_WX= 2.9
+WX_COMPS= wx
+WX_UNICODE= yes
+
+NOPORTDOCS= yes
+
+post-patch::
+ @${REINPLACE_CMD} 's|"wx-config"|"wxgtk2u-2.9-config"| ; \
+ s|/sbin/ldconfig -n|/sbin/ldconfig -m| ' ${WRKSRC}/Setup.hs
+
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
+.include <bsd.port.mk>
diff --git a/x11-toolkits/hs-wxc/distinfo b/x11-toolkits/hs-wxc/distinfo
new file mode 100644
index 000000000000..a632cf0182ec
--- /dev/null
+++ b/x11-toolkits/hs-wxc/distinfo
@@ -0,0 +1,2 @@
+SHA256 (cabal/wxc-0.90.0.3.tar.gz) = 98b6b3e89486d3f36750f514ff832551573b2af2a99c3b77919ddb49b8786891
+SIZE (cabal/wxc-0.90.0.3.tar.gz) = 181683
diff --git a/x11-toolkits/hs-wxc/pkg-descr b/x11-toolkits/hs-wxc/pkg-descr
new file mode 100644
index 000000000000..ea012555c3a3
--- /dev/null
+++ b/x11-toolkits/hs-wxc/pkg-descr
@@ -0,0 +1,9 @@
+wxHaskell is a portable and native GUI library for Haskell. It is built
+on top of wxWidgets, a comprehensive C++ library that is portable across
+all major GUI platforms, including GTK, Windows, X11, and MacOS X. This
+version works with wxWidgets 2.9 only. Distributed under the WXWINDOWS
+LIBRARY LICENSE. Please see LICENSE file, but note that this is essentially
+LGPL with an exception allowing binary distribution of proprietary software.
+This is the same license as wxWidgets itself uses.
+
+WWW: http://haskell.org/haskellwiki/WxHaskell